Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

From: Lou Berger <[email-masked]>
Date: Tue, 1 Sep 2015 11:16:38 -0400

All,

This is start of a two week poll on making
draft-saad-teas-yang-te-02 a TEAS working group document. Please
send email to the list indicating “yes/support” or “no/do not support”.
If indicating no, please state your technical reservations with the
document.  If yes, please also feel free to provide comments you'd like
to see addressed once the document is a WG document.

The poll ends September 15th
Thanks,
Lou (and Pavan, who is a co-author)

---

From: "Matt Hartley (mhartley)" <[email-masked]>
Date: Wed, 2 Sep 2015 14:37:25 +0000

Yes/Support

Cheers

Matt

> draft-saad-teas-yang-te-02 a TEAS working group document. Please send
> email to the list indicating "yes/support" or "no/do not support".
> document.  If yes, please also feel free to provide comments you'd like to
> see addressed once the document is a WG document.
> 
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 2 Sep 2015 11:06:58 -0400

Yes- support. (..co-author)

Thanks,
Himanshu

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Tuesday, September 01, 2015 11:17 AM
To: TEAS WG
Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

All,

This is start of a two week poll on making
draft-saad-teas-yang-te-02 a TEAS working group document. Please send email to the list indicating "yes/support" or "no/do not support".
If indicating no, please state your technical reservations with the document.  If yes, please also feel free to provide comments you'd like to see addressed once the document is a WG document.

---

From: "Rakesh Gandhi (rgandhi)" <[email-masked]>
Date: Thu, 3 Sep 2015 11:36:01 +0000

Yes/support (as a co-author).

Thanks,
Rakesh

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Thu, 3 Sep 2015 13:29:29 +0000

Yes/support (as co-author).

Regards,
Tarek

On 2015-09-01, 11:16 AM, "Teas on behalf of Lou Berger"
<[email-masked] on behalf of [email-masked]> wrote:

>send email to the list indicating ³yes/support² or ³no/do not support².

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 3 Sep 2015 09:32:05 -0400

Lou,

Yes/support.

Cheers,
Andy

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Thu, 3 Sep 2015 13:56:50 +0000

Yes, Support. 

Thanks

Regards Š Zafar

---

From: "Takuya Miyasaka" <[email-masked]>
Date: Fri, 4 Sep 2015 09:10:27 +0900

Yes/Support

Thanks,
Takuya

> Sent: Wednesday, September 02, 2015 12:17 AM
> To: TEAS WG
> If indicating no, please state your technical reservations with the document.  If yes, please also feel free to provide
> comments you'd like to see addressed once the document is a WG document.
>

---

From: "Giovanni Martinelli (giomarti)" <[email-masked]>
Date: Fri, 4 Sep 2015 09:39:13 +0000

yes/support

cheers
G

> On 01 Sep 2015, at 17:16, Lou Berger <[email-masked]> wrote:
> 
> All,
>

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Fri, 4 Sep 2015 06:00:59 -0400

Yes/Support.

- Pavan (as a co-author)

> On Sep 1, 2015, at 11:16 AM, Lou Berger <[email-masked]> wrote:
> 
> All,
>

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 4 Sep 2015 12:11:49 +0000

__Yes/ support.
Igor
______________________________________
From: Teas [[email-masked]] on behalf of Vishnu Pavan Beeram [[email-masked]]
Sent: Friday, September 4, 2015 6:00 AM
To: Lou Berger
Cc: TEAS WG
Subject: Re: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

Yes/Support.

- Pavan (as a co-author)

---

From: Xufeng Liu <[email-masked]>
Date: Fri, 4 Sep 2015 15:29:53 +0000

Regards,
- Xufeng

> draft-saad-teas-yang-te-02 a TEAS working group document. Please send email
> to the list indicating "yes/support" or "no/do not support".
> If indicating no, please state your technical reservations with the document.  If
> yes, please also feel free to provide comments you'd like to see addressed once
> the document is a WG document.
>

---

From: Leeyoung <[email-masked]>
Date: Fri, 4 Sep 2015 15:57:59 +0000

Yes/support.

Thanks.
Young

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Tuesday, September 01, 2015 10:17 AM
To: TEAS WG
Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

All,

send email to the list indicating "yes/support" or "no/do not support".

---

From: Cyril Margaria <[email-masked]>
Date: Fri, 4 Sep 2015 12:14:59 -0400

Yes/Support

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 4 Sep 2015 17:21:57 +0000

Yes/support

Regards,
Jeff

On 1 September 2015 at 11:16, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
All,

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 7 Sep 2015 01:11:37 +0000

Support.

Best Regards,
Huaimo

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Tuesday, September 01, 2015 11:17 AM
To: TEAS WG
Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

All,

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Mon, 7 Sep 2015 07:24:52 +0000

Yes/support.

-Jie

> Sent: Tuesday, September 01, 2015 11:17 PM
> To: TEAS WG

---

From: Gert Grammel <[email-masked]>
Date: Mon, 7 Sep 2015 12:01:41 +0000

Yes, support

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 01 September 2015 17:17
To: TEAS WG
Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

All,

---

From: Mach Chen <[email-masked]>
Date: Tue, 8 Sep 2015 01:31:12 +0000

Yes/support.

Best regards,
Mach

> If indicating no, please state your technical reservations with the document.
> If yes, please also feel free to provide comments you'd like to see addressed
> once the document is a WG document.
>

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Mon, 14 Sep 2015 06:19:17 +0000

Dear all, 

    I support adopting this draft since I think it provides a good starting point for the working group to work on. 

    A non-blocking but a very important comment, which I would like to see addressed in future versions: how to model the LSP-state information, which can be exposed not only from the network element, but also from a PCE server?

   There are two options on the table: 

   A)	Writing generic groupings so that the TE YANG and PCEP YANG modules can both use
   B)	Following what the topology work does, where a generic LSP-state module is written and further augmented per case (and available both for the device and controller (PCE)).

  There are pros and cons with both approaches and we haven’t reached any agreement yet. I am personally in favor of the 2nd option. 

Regards,
Xian

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: 2015年9月1日 23:17
To: TEAS WG
Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

All,

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 14 Sep 2015 19:55:13 +0530

Hi All,

​Support adoption! ​

Thanks Xian for bringing this up, as a PCEP Yang co-author, would
appreciate conclusion on this by the WG.
Also, once we move to PCE-Initiated LSP in PCEP Yang Model, the same
questions will be applicable to tunnel configurations as well.

So once the adoption is out of the way, WG should make a decision regarding
this.

Regards,
Dhruv

On Mon, Sep 14, 2015 at 11:49 AM, Zhangxian (Xian) <[email-masked]>
wrote:

> Dear all,
>
>     I support adopting this draft since I think it provides a good
> starting point for the working group to work on.
>
>     A non-blocking but a very important comment, which I would like to see
> addressed in future versions: how to model the LSP-state information, which
> can be exposed not only from the network element, but also from a PCE
> server?
>
>    B)   Following what the topology work does, where a generic LSP-state
> module is written and further augmented per case (and available both for
> the device and controller (PCE)).
>
>   There are pros and cons with both approaches and we haven’t reached any
> agreement yet. I am personally in favor of the 2nd option.
>
> Regards,
> Xian
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 16 Sep 2015 17:33:49 -0400

All,
    The WG poll is closed.

Authors,
    Please republish draft-saad-teas-yang-te-02 as
draft-ietf-teas-yang-te-00 with only the date and file name changed. 
Comments received (publicly and privately) should be discussed and
addresses in the -01 version.

Thank you,
Lou (and Pavan)

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Mon, 21 Sep 2015 02:52:41 +0000

Thanks Dhurv and Xian for the feedback. Yes, we (the authors) are evaluating the option to allow the reuse of the same tunnel/LSP groupings in both the device and controller YANG models. We will update the group once we've converged.

Regards,
Tarek

From: <[email-masked]<mailto:[email-masked]>> on behalf of Dhruv Dhody <[email-masked]<mailto:[email-masked]>>
Date: Monday, September 14, 2015 at 10:25 AM
To: "Zhangxian (Xian)" <[email-masked]<mailto:[email-masked]>>
Cc: Lou Berger <[email-masked]<mailto:[email-masked]>>, TEAS WG <[email-masked]<mailto:[email-masked]>>, Tarek Saad <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

Hi All,

​Support adoption! ​

Thanks Xian for bringing this up, as a PCEP Yang co-author, would appreciate conclusion on this by the WG.
Also, once we move to PCE-Initiated LSP in PCEP Yang Model, the same questions will be applicable to tunnel configurations as well.

So once the adoption is out of the way, WG should make a decision regarding this.

Regards,
Dhruv

On Mon, Sep 14, 2015 at 11:49 AM, Zhangxian (Xian) <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

Regards,
Xian

-----Original Message-----
From: Teas [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lou Berger
Sent: 2015年9月1日 23:17
To: TEAS WG
Subject: [Teas] Poll on making draft-saad-teas-yang-te-02 a WG documents

All,