Subject: [Teas] TEAS WG Virtual Interim Meeting (before IETF-95)

From: Vishnu Pavan Beeram <[email-masked]>
Date: Tue, 5 Jan 2016 21:32:55 -0500

Folks, Hi!

Happy New Year!!

We’d like the TEAS WG to hold a virtual interim meeting before IETF-95 to
cover the following topic -

"RSVP Ingress Protection / Egress Protection” -- target meeting the week
of 25 January 2015 (with a second meeting possible if needed):
The main purpose of the meeting is to help select one of the two
alternatives contained in <draft-ietf-teas-rsvp-ingress-protection>. A
secondary purpose is to facilitate further discussion on
<draft-ietf-teas-rsvp-egress-protection>, and gauge WG consensus on both
drafts.

The following doodle poll will aid in selecting the exact date/time for
this meeting: http://doodle.com/poll/7g4st77huxv66z2d

Regards,
Pavan and Lou.

---

From: Huaimo Chen <[email-masked]>
Date: Sun, 24 Jan 2016 04:26:10 +0000

Hi Chairs,

    Thanks for organizing the interim meeting.

    Lou asked for technical trade-off discussion of the current options in the I-D, these are:

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

I conducted analysis and documented my results, these can be seen at:
http://www.slideshare.net/HuaimoChen/analysis-2methods
The findings include an example of both techniques. Looking forward to the interim call.

Best Regards,
Huaimo

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Tuesday, January 05, 2016 9:33 PM
To: [email-masked]; [email-masked]
Subject: [Teas] TEAS WG Virtual Interim Meeting (before IETF-95)

Folks, Hi!

Happy New Year!!

We’d like the TEAS WG to hold a virtual interim meeting before IETF-95 to cover the following topic -

"RSVP Ingress Protection / Egress Protection” -- target meeting the week
of 25 January 2015 (with a second meeting possible if needed):
The main purpose of the meeting is to help select one of the two alternatives contained in <draft-ietf-teas-rsvp-ingress-protection>. A secondary purpose is to facilitate further discussion on <draft-ietf-teas-rsvp-egress-protection>, and gauge WG consensus on both drafts.

The following doodle poll will aid in selecting the exact date/time for this meeting: http://doodle.com/poll/7g4st77huxv66z2d

Regards,
Pavan and Lou.

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Sun, 24 Jan 2016 17:53:31 -0500

Huaimo,

Much Thanks for putting this slide-set together. It will help drive the
discussion forward during the interim meeting.

It would be very useful if the comparative analysis covers all of the below
aspects for both approaches (please see if you can fill in the missing
pieces in your slide-set):

- Configuration Model: Discuss the "TE Tunnel" configuration needed for
requesting "ingress protection". Discuss other prerequisites (if any) for
configuring this.

- Protection Setup Procedures: Discuss the procedures on all relevant nodes
("primary ingress", " backup ingress" [,"proxy ingress"]) for setting up
the primary LSP and the corresponding backup LSP. A signaling sequence
diagram would be useful. Discuss the procedures for both "on path backup
ingress" and "off path backup ingress".

- Session Maintenance Procedures: Discuss the procedures on all relevant
nodes for maintaining (refreshes, triggers, teardown) primary-LSP state and
the corresponding backup-LSP state.

- Local Repair Procedures: Discuss the procedures that come into play at
the "backup ingress" when the "primary ingress" node failure is detected.

- "Revert to Primary Ingress" Procedures

- "Global Repair" Procedures

- Backwards Compatibility: Discuss "backwards compatibility" considerations
for the proposed signaling extensions/procedures.

- Scaling Considerations: Discuss "scaling considerations" (amount of
signaling state/messages to be maintained/processed).

- Security Considerations: Discuss "security considerations".

For items in the above list which do not entail any difference in the 2
approaches, just specify what is common to both.

****
Others in the WG,

If you disagree with any of the points made in the slide-set shared by
Huaimo, please plan on presenting your arguments.

****
Please do plan on sending your slides to the chairs and the secretary (Matt
on cc) by Wednesday.

Regards,
-Pavan

On Sat, Jan 23, 2016 at 11:26 PM, Huaimo Chen <[email-masked]>
wrote:

> *http://www.slideshare.net/HuaimoChen/analysis-2methods*
> <http://www.slideshare.net/HuaimoChen/analysis-2methods>
> *From:* Teas [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Vishnu Pavan Beeram
> *Sent:* Tuesday, January 05, 2016 9:33 PM
> *To:* [email-masked]; [email-masked]
> *Subject:* [Teas] TEAS WG Virtual Interim Meeting (before IETF-95)
>
> Folks, Hi!
>
> Happy New Year!!
>
> this meeting: *http://doodle.com/poll/7g4st77huxv66z2d*
> <http://doodle.com/poll/7g4st77huxv66z2d>
>
> Regards,
> Pavan and Lou.
>
>
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
>

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 25 Jan 2016 19:19:50 +0000

Dear Pavan, Huiamo, et. al,
I’d like to draw your attention to the fact that both methods rely on the Backup Ingress detecting when the Primary Ingress fails, e.g. slide 13 “When primary ingress fails, …”. I’m concerned that without clear indication that failure occurred at the Primary Ingress and not on the link, physical or logical, that connects the Backup and Primary, ingress protection is guaranteed to produce false negatives and, in my view, is not practical. I’d appreciate if we can discuss OAM aspects of ingress protection during our meeting on Thursday.

                Regards,
                                Greg

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Sunday, January 24, 2016 2:54 PM
To: Huaimo Chen
Cc: Matt Hartley; [email-masked]; [email-masked]
Subject: Re: [Teas] Comparison Analysis (TEAS WG Virtual Interim Meeting (before IETF-95))

Huaimo,
Much Thanks for putting this slide-set together. It will help drive the discussion forward during the interim meeting.
It would be very useful if the comparative analysis covers all of the below aspects for both approaches (please see if you can fill in the missing pieces in your slide-set):

- Configuration Model: Discuss the "TE Tunnel" configuration needed for requesting "ingress protection". Discuss other prerequisites (if any) for configuring this.
- Protection Setup Procedures: Discuss the procedures on all relevant nodes ("primary ingress", " backup ingress" [,"proxy ingress"]) for setting up the primary LSP and the corresponding backup LSP. A signaling sequence diagram would be useful. Discuss the procedures for both "on path backup ingress" and "off path backup ingress".
- Session Maintenance Procedures: Discuss the procedures on all relevant nodes for maintaining (refreshes, triggers, teardown) primary-LSP state and the corresponding backup-LSP state.
- Local Repair Procedures: Discuss the procedures that come into play at the "backup ingress" when the "primary ingress" node failure is detected.
- "Revert to Primary Ingress" Procedures
- "Global Repair" Procedures

- Backwards Compatibility: Discuss "backwards compatibility" considerations for the proposed signaling extensions/procedures.
- Scaling Considerations: Discuss "scaling considerations" (amount of signaling state/messages to be maintained/processed).

- Security Considerations: Discuss "security considerations".
For items in the above list which do not entail any difference in the 2 approaches, just specify what is common to both.

****
Others in the WG,
If you disagree with any of the points made in the slide-set shared by Huaimo, please plan on presenting your arguments.

****
Please do plan on sending your slides to the chairs and the secretary (Matt on cc) by Wednesday.
Regards,
-Pavan

On Sat, Jan 23, 2016 at 11:26 PM, Huaimo Chen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Chairs,

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

Best Regards,
Huaimo

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Tuesday, January 05, 2016 9:33 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Teas] TEAS WG Virtual Interim Meeting (before IETF-95)

Folks, Hi!

Happy New Year!!

Regards,
Pavan and Lou.

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 25 Jan 2016 19:45:29 +0000

Hi Greg,

It seems that the draft contains the description about the primary ingress failure detection by the backup ingress. I may add this into slide 13.

Best Regards,
Huaimo
From: Gregory Mirsky [mailto:[email-masked]]
Sent: Monday, January 25, 2016 2:20 PM
To: Vishnu Pavan Beeram; Huaimo Chen
Cc: Matt Hartley; [email-masked]; [email-masked]
Subject: RE: [Teas] Comparison Analysis (TEAS WG Virtual Interim Meeting (before IETF-95))

                Regards,
                                Greg

Huaimo,

****
Others in the WG,

****

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

Best Regards,
Huaimo

Folks, Hi!

Happy New Year!!

Regards,
Pavan and Lou.

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 25 Jan 2016 19:48:53 +0000

Hi Huiamo,
I don’t agree that the draft describes any OAM method that provides reliable mechanism to detect exclusively Primary Ingress node failure within sub-50 ms interval. I hope we can discuss this at the meeting.

                Regards,
                                Greg

From: Huaimo Chen [mailto:[email-masked]]
Sent: Monday, January 25, 2016 11:45 AM
To: Gregory Mirsky; Vishnu Pavan Beeram
Cc: Matt Hartley; [email-masked]; [email-masked]
Subject: RE: [Teas] Comparison Analysis (TEAS WG Virtual Interim Meeting (before IETF-95))

Hi Greg,

Best Regards,
Huaimo
Cc: Matt Hartley; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

                Regards,
                                Greg

From: Teas [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: Sunday, January 24, 2016 2:54 PM
To: Huaimo Chen
Cc: Matt Hartley; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] Comparison Analysis (TEAS WG Virtual Interim Meeting (before IETF-95))

Huaimo,

****
Others in the WG,

****

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

Best Regards,
Huaimo

Folks, Hi!

Happy New Year!!

Regards,
Pavan and Lou.

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 25 Jan 2016 19:56:43 +0000

Hi Greg,

It seems that a reliable mechanism to detect exclusively Primary Ingress node failure within seconds work well for keeping signaling primary LSP up. The traffic will be switched over by the source within 50ms when primary ingress fails. Thus the backup ingress seems not need to detect primary ingress failure within 50 ms.

Best Regards,
Huaimo
From: Gregory Mirsky [mailto:[email-masked]]
Sent: Monday, January 25, 2016 2:49 PM
To: Huaimo Chen; Vishnu Pavan Beeram
Cc: Matt Hartley; [email-masked]; [email-masked]
Subject: RE: [Teas] Comparison Analysis (TEAS WG Virtual Interim Meeting (before IETF-95))

Hi Huiamo,

                Regards,
                                Greg

Hi Greg,

Best Regards,
Huaimo

                Regards,
                                Greg

Huaimo,

****
Others in the WG,

****

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

Best Regards,
Huaimo

Folks, Hi!

Happy New Year!!

Regards,
Pavan and Lou.

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 25 Jan 2016 20:10:04 +0000

Hi Pavan,

Thanks much for your suggestions. I will try to cover as much as possible accordingly.

Best Regards,
Huaimo
From: Vishnu Pavan Beeram [mailto:[email-masked]]
Sent: Sunday, January 24, 2016 5:54 PM
To: Huaimo Chen
Cc: [email-masked]; [email-masked]; Matt Hartley
Subject: Re: [Teas] Comparison Analysis (TEAS WG Virtual Interim Meeting (before IETF-95))

Huaimo,

****
Others in the WG,

****

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

Best Regards,
Huaimo

Folks, Hi!

Happy New Year!!

Regards,
Pavan and Lou.

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Mon, 25 Jan 2016 15:17:10 -0500

Greg, Hi!

Thanks for bringing this up.
Yes, I do expect to hear the OAM aspects of the solution discussed on
Thursday.

Regards,
-Pavan

On Mon, Jan 25, 2016 at 2:19 PM, Gregory Mirsky <[email-masked]

> I’d like to draw your attention to the fact that both methods rely on the
> Backup Ingress detecting when the Primary Ingress fails, e.g. slide 13
> “When primary ingress fails, …”. I’m concerned that without clear
> indication that failure occurred at the Primary Ingress and not on the
> link, physical or logical, that connects the Backup and Primary, ingress
> protection is guaranteed to produce false negatives and, in my view, is not
> practical. I’d appreciate if we can discuss OAM aspects of ingress
> protection during our meeting on Thursday.
>
>
>
>                 Regards,
>
>                                 Greg
>
>
>
> *From:* Teas [mailto:[email-masked]] *On Behalf Of *Vishnu Pavan
> Beeram
> *Sent:* Sunday, January 24, 2016 2:54 PM
> *To:* Huaimo Chen
> *Cc:* Matt Hartley; [email-masked]; [email-masked]
> *Subject:* Re: [Teas] Comparison Analysis (TEAS WG Virtual Interim
> Meeting (before IETF-95))
>
>
>
> Huaimo,
>
> It would be very useful if the comparative analysis covers all of the
> below aspects for both approaches (please see if you can fill in the
> missing pieces in your slide-set):
>
>
>
> - Protection Setup Procedures: Discuss the procedures on all relevant
> nodes ("primary ingress", " backup ingress" [,"proxy ingress"]) for setting
> up the primary LSP and the corresponding backup LSP. A signaling sequence
> - Backwards Compatibility: Discuss "backwards compatibility"
> considerations for the proposed signaling extensions/procedures.
>

---

From: Huaimo Chen <[email-masked]>
Date: Wed, 27 Jan 2016 04:20:56 +0000

Hi Pavan,

I updated the slides to cover more as you suggested, which can be accessed by
http://www.slideshare.net/HuaimoChen/analysis-2methods01-57539501

Best Regards,
Huaimo

Huaimo,

****
Others in the WG,

****

        (1) Relay-Message Method

        (2) Proxy-Ingress Method

Best Regards,
Huaimo

Folks, Hi!

Happy New Year!!

Regards,
Pavan and Lou.