Subject: Re: [Teas] A basic question on draft-ietf-teas-rsvp-egress-protection

From: Huaimo Chen <[email-masked]>
Date: Sat, 20 Feb 2016 22:15:16 +0000

Hi Lou,

Thanks much for your comments.

My answer/explanation is inline below.

Best Regards,

Huaimo

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, January 27, 2016 9:09 AM
To: [email-masked]; TEAS WG
Subject: [Teas] A basic question on draft-ietf-teas-rsvp-egress-protection

Hi,

    I have a question on draft-ietf-teas-rsvp-egress-protection that is

prompted by today's interim and can be covered there and/or on list:

Given that the draft says:

>    The egress local protection may be generalized and used with the

>    segment protection defined in RFC 4873 <https://tools.ietf.org/html/rfc4873>.  How it is generalized and

>    used is out of scope for this document.

Why define a new set of formats and mechanisms when an existing set of

formats and mechanisms can be used or adapted to (a) provide the same

function and (b) do so in a more general way?

[Huaimo] RFC 4873 defines a segment protection, which provides a protection against a failure in a segment of an LSP. However, this segment protection can not be used or re-used to provide a protection against a failure in the egress of the LSP. For a segment from a node B to the egress E of the LSP, node B creates a backup LSP to egress E, and switches the traffic to the backup LSP when detecting a failure in the segment except for a failure in egress E. When egress E fails, the backup LSP will fail, thus no protection is provided by the segment protection against egress failure. To provide egress local (or fast) protection, the segment protection needs to be generalized/enhanced.

I look forward to hearing/discussing the rational for not not reusing

what we already have defined.

Thanks,

Lou

_______________________________________________

Teas mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/teas

---

From: Lou Berger <[email-masked]>
Date: Sun, 21 Feb 2016 07:35:16 -0500

Huaimo,
	See below.

On 02/20/2016 05:15 PM, Huaimo Chen wrote:
>>    segment protection defined in RFC 4873
> <https://tools.ietf.org/html/rfc4873>.  How it is generalized and
> 
> [Huaimo] RFC 4873 defines a segment protection, which provides a
> protection against a failure in a segment of an LSP. However, this
> segment protection can not be used or re-used to provide a protection
> against a failure in the egress of the LSP. 

> For a segment from a node B
> to the egress E of the LSP, node B creates a backup LSP to egress E, and
> switches the traffic to the backup LSP when detecting a failure in the
> segment except for a failure in egress E. When egress E fails, the
> backup LSP will fail, thus no protection is provided by the segment
> protection against egress failure. 

I'm sorry I just don't follow your argument here. Are you saying a
protected segment with a merge node which is also the egress doesn't
protect against egress failure?  If so, then yes - sure.  If not,
perhaps you can rephrase to state the point directly before jumping into
an example?

> To provide egress local (or fast)
> protection, the segment protection needs to be generalized/enhanced.

Right. So my basic question is why not reuse/build on this existing
mechanism?

For example why not just define egress protection to use an SERO with a
final subobject that is the secondary egress?

Lou