Subject: [Teas] IPR Disclosure Infinera Corporation's Statement about IPR related to draft-ietf-teas-interconnected-te-info-exchange

From: IETF Secretariat <[email-masked]>
Date: Mon, 01 Feb 2016 18:32:42 -0800

Dear Adrian Farrel, John Drake, Dr. Nabil N. Bitar, George Swallow, Daniele Ceccarelli, Xian Zhang:

An IPR disclosure that pertains to your Internet-Draft entitled "Problem
Statement and Architecture for Information Exchange Between Interconnected
Traffic Engineered Networks"
(draft-ietf-teas-interconnected-te-info-exchange) was submitted to the IETF
Secretariat on  and has been posted on the "IETF Page of Intellectual Property
Rights Disclosures" (https://datatracker.ietf.org/ipr/2745/). The title of the
IPR disclosure is "Infinera Corporation's Statement about IPR related to
draft-ietf-teas-interconnected-te-info-exchange"

Thank you

IETF Secretariat

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 2 Feb 2016 16:58:32 -0000

I'm always pleased to see IPR disclosed before last call even when the disclosure is painfully late.

In this case Rajan is named as a co-inventor on the patent application (which I see at http://www.freepatentsonline.com/20140156751.pdf). This patent application is dated June 5, 2014.

Rajan first became listed as a Contributor to draft-farrel-interconnected-te-info-exchange in revision -06 posted on July 25, 2014.

I may be a harsh judge, but this disclosure doesn't seem to me to have been made "as soon as reasonably possible."

That said, the cited patent application appears to describe a mechanism for backwards recursive path computation using RSVP-TE signaling (which is akin to a hybrid of RFC 5441 and RFC 4920). Such a mechanism is not proposed or even mentioned in this document, so readers may draw their own conclusions about the relevance of the disclosure.

Lastly, I note that the license terms disclosed appear to follow the "mutually assured destruction" terms commonly offered by IETF participants.

I do not propose any changes to this document resulting from this disclosure.

Adrian

> -----Original Message-----
> From: IETF Secretariat [mailto:[email-masked]]
> Sent: 02 February 2016 02:33
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: IPR Disclosure Infinera Corporation's Statement about IPR related to
> draft-ietf-teas-interconnected-te-info-exchange
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 2 Feb 2016 12:25:03 -0500

Rajan,

Thank you for the IPR disclosure. 

Can you point to the portion of the draft which has changed  since you
responded to the adoption IPR poll [1] to trigger the disclosure? 

For convenience, the difference in contents between [1] and now can be
found at:
   
https://tools.ietf.org/rfcdiff?url1=draft-farrel-interconnected-te-info-exchange-07.txt&url2=draft-ietf-teas-interconnected-te-info-exchange-03.txt

Thank you,
Lou
(Chair and Shepherd)

[1] https://www.ietf.org/mail-archive/web/ccamp/current/msg16440.html

On 2/1/2016 9:32 PM, IETF Secretariat wrote:
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Rajan Rao <[email-masked]>
Date: Tue, 2 Feb 2016 21:54:23 +0000

Lou,

There is no specific change that triggered the disclosure.  We revisited the list of IPRs based on IPR disclosure request from IETF and felt that it is related. Hence the disclosure.

The trigger for disclosure is related to BRPC in Appendix A.3.

Thx
Rajan

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Tuesday, February 02, 2016 9:25 AM
To: Rajan Rao <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Teas] IPR Disclosure Infinera Corporation's Statement about IPR related to draft-ietf-teas-interconnected-te-info-exchange

Rajan,

Can you point to the portion of the draft which has changed  since you responded to the adoption IPR poll [1] to trigger the disclosure? 

For convenience, the difference in contents between [1] and now can be found at:

Thank you,
Lou
(Chair and Shepherd)

On 2/1/2016 9:32 PM, IETF Secretariat wrote:
> An IPR disclosure that pertains to your Internet-Draft entitled 
> "Problem Statement and Architecture for Information Exchange Between 
> Interconnected Traffic Engineered Networks"
> (draft-ietf-teas-interconnected-te-info-exchange) was submitted to the 
> IETF Secretariat on  and has been posted on the "IETF Page of 
> Intellectual Property Rights Disclosures" 
> (https://datatracker.ietf.org/ipr/2745/). The title of the IPR 
> disclosure is "Infinera Corporation's Statement about IPR related to draft-ietf-teas-interconnected-te-info-exchange"
>
>
> Thank you
>
> IETF Secretariat
>

---

From: Lou Berger <[email-masked]>
Date: Tue, 2 Feb 2016 17:20:11 -0500

Adrian/All,
    Please discuss the disclosure and additional information provided by
Rajan to the group as you see fit -- both now and during LC. 

Without regard to contents, I note that IPR was also been disclosed on
"The Backward-Recursive PCE-Based Computation (BRPC) mechanism",
RFC5441,  back in 2007.

Lou

---

From: Lou Berger <[email-masked]>
Date: Tue, 2 Feb 2016 17:14:29 -0500

Rajan,
    Thank you again for the disclosure and providing the additional
information.

Lou