Subject: Re: [Teas] MPLS and TE tunnels YANG data model meeting

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Fri, 27 May 2016 15:33:51 +0000

Copying WG for fyi as feedback as per agreement.

Thanks all for attending meeting weekly meeting today. Below are today’s MoMs. Feel free to add if I missed any.

Regards,
Tarek

Friday May 27, 2016:
===================
Agenda:
A. Discuss new update(s) to MPLS static LSPs module
   - new static LSP attributes
   - static bidirectional LSPs
   - static MBB
   - static end-to-end LSP protection
B. Discuss SR-TE new module details
C. how to proceed with schema mount

--> AI: to send a doodle for SR-TE meeting

A. SR-TE:
=========
Explicit path:
- label (already have it in TE model)
- SID index

Tunnel:
new: binding-label (not specific to SR tunnel)
new: per path "segment-routing" attribute
new: per path constraints:
      - cost limit
      - link/adj-SID protection types: any, protected, unprotected
      - invalidation timeout
      - invalidation action
        - drop
        - tear
      - prepend label(s) per path
      - prepend bgp-next-hop

New TE link attributes (state-only):
Delay:
– Unidirectional Link Delay (D)
– Min/Max Unidirectional Link Delay (DM)
– Unidirectional Delay Variation (DV)

Loss:
– Unidirectional Link Loss (L)

Bandwidth:
– Unidirectional Residual Bandwidth (BR)
– Unidirectional Available Bandwidth (BA)
– Unidirectional Utilized Bandwidth (BUTIL)

B. Update to MPLS static LSPs
New attributes for static LSPs needed to allocate resources on per hop/link:
- BW with CTs?
- priority/preemption
- discussion, what occurs if static LSPs is contending with RSVP allocation (at same or different priority)?

Bidirectional Static LSPs:
Option #1:

-          association of forward/reverse siblings maintained in hierarchical configuration (under same LSP(name=foo))
LSP(name=foo):
BW
bidirectional
forward
   BW1
   in-segment (in-label, next-hop)
   out-segment (out-label(s), next-hop)
reverse
   BW2
   in-segment (in-label, next-hop)
   out-segment (out-label(s), next-hop)

--> In current model the LSP has only one cross-connect
--> will need to have multiple cross-connects per LSP
---> to realize asymmetrical behavior (eg. BW alloc) need to allow config under each forward/reverse leg

Option #2:

-          forward/reverse LSPs as separate entries in the static LSP list

-          entries have different names, but associated using below

-          use a configured association-ID (tunnel-ID or service-ID) as way to associate LSPs
LSP(name=foo-forward):
bidirectional
forward
association ID = 1001
in-segment (in-label, next-hop)
out-segment (out-label(s), next-hop)

LSP(name=foo-reverse):
bidirectional
reverse
association ID = 1001
in-segment (in-label, next-hop)
out-segment (out-label(s), next-hop)

Option #3:

-          forward/reverse LSPs as separate entries in the static LSP list

-          both entries have the same name, but new key is needed iin the list (role?, e.g. sibling1, sibling2, etc..)

MBB for Static:
1. how to realize resource sharing if needed?
2. coordinate switchover on the ingress using configuration

Option#2 (add role in list of LSPs key), e.g. key= (name=foo, role=mbb-sibling1), (name=foo, mbb-sibling2), (name=foo, path-protect-sibling1), (name=foo, path-protect-sibling2)

LSP(foo, mbb-sibling1):
in-segment (in-label, next-hop)
out-segment (out-label(s), next-hop)
association ID = 1001
role=MBB sibling

LSP(foo, mbb-sibling2):
in-segment (in-label, next-hop)
out-segment (out-label(s), next-hop)
association ID = 1001
role=MBB sibling

T0: traffic on LSP(foo1)
T1: configure LSP(foo2) on mid(s)
T2: map traffic to LSP(foo2) on ingress
T3: delete LSP(foo1)

Background (snippet from Huawei’s OS support for static LSP):
[LSRA] bidirectional static-cr-lsp ingress Tunnel1/0/0
[LSRA-bi-static-ingress-Tunnell/0/0] forward nexthop 2.1.1.2 out-label 20 bandwidth ct0 10000
[LSRA-bi-static-ingress-Tunnell/0/0] backward in-label 20
[LSRB]bidirectional static-cr-lsp transit lsp1
[LSRB-bi-static-transit-lsp1] forward in-label 20 nexthop 3.2.1.2 out-label 40 bandwidth ct0 10000
[LSRB-bi-static-transit-lsp1] backward in-label 16 nexthop 2.1.1.1 out-label 20 bandwidth ct0 10000
[LSRC] bidirectional static-cr-lsp egress lsp1
[LSRC-bi-static-egress-lsp1] forward in-label 40 lsrid 1.1.1.1 tunnel-id 100

Regards,
Tarek

From: [email-masked]
When: 10:00 AM - 11:00 AM May 27, 2016
Subject: MPLS and TE tunnels YANG data model meeting
Location: webex

Refreshing invite for MPLS and TE tunnels YANG data model meeting. Please forward to anyone I missed.

-- Do not delete or change any of the following text. --

Join WebEx meeting<https://cisco.webex.com/ciscosales/j.php?MTID=mc05982f2d3c4042df20c2df56f3cc127>
Meeting number: 201 966 692
Meeting password: 3jwMRXEd

If you are a host, go here<https://cisco.webex.com/ciscosales/j.php?MTID=me7f65462eb251d205c8e21668e514ee7> to view host information.

Join by phone
+1-408-525-6800 Call-in toll number (US/Canada)
+1-866-432-9903 Call-in toll-free number (US/Canada)
Access code: 201 966 692
Numeric meeting password: 21794172
Global call-in numbers<https://cisco.webex.com/ciscosales/globalcallin.php?serviceType=MC&ED=351497332&tollFree=1> | Toll-free calling restrictions<https://www.webex.com/pdf/tollfree_restrictions.pdf>

Can't join the meeting? Contact support.<https://cisco.webex.com/ciscosales/mc>

IMPORTANT NOTICE: Please note that this WebEx service allows audio and other information sent during the session to be recorded, which may be discoverable in a legal matter. By joining this session, you automatically consent to such recordings. If you do not consent to being recorded, discuss your concerns with the host or do not join the session..

---

From: "Tarek Saad (tsaad)" <[email-masked]>
Date: Fri, 27 May 2016 15:35:07 +0000

Correcting mpls WG alias,

From: Tarek Saad <[email-masked]>
Date: Friday, May 27, 2016 at 11:33 AM
To: "Chenxia (D)" <[email-masked]>, Himanshu Shah <[email-masked]>, "Wen, Bin" <[email-masked]>, Vishnu Pavan Beeram <[email-masked]>, Raqib Jones <[email-masked]>, "Rakesh Gandhi (rgandhi)" <[email-masked]>, "Kamran Raza (skraza)" <[email-masked]>, "[email-masked]" <[email-masked]>, Igor Bryskin <[email-masked]>, "Zhangxian (Xian)" <[email-masked]>, Paweł Brzozowski <[email-masked]>, Anurag Sharma <[email-masked]>, Xufeng Liu <[email-masked]>, Paweł Kaczmarek <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "mpls@ietf" <mpls@ietf>
Subject: Re: MPLS and TE tunnels YANG data model meeting

Regards,
Tarek

Friday May 27, 2016:
===================
Agenda:

A. SR-TE:
=========
Explicit path:

Tunnel:

Loss:

Bandwidth:

Option #2:

LSP(name=foo-reverse):
bidirectional
reverse
association ID = 1001

Option #3:

MBB for Static:

LSP(foo, mbb-sibling1):

LSP(foo, mbb-sibling2):

T0: traffic on LSP(foo1)

Regards,
Tarek

From: [email-masked]

Join by phone

---

From: Iftekhar Hussain <[email-masked]>
Date: Fri, 27 May 2016 21:39:41 +0000

Hi Tarek and All,

Just catching up.  Couple of quick question. Apologies if it has already been discussed.

·         Static LSP option #2 below, do you mean LSP-ID instead of “tunnel ID”?

·         How is the operational state of bidirectional LSP modeled?

·         Can you please send a pointer to the SR-TE tunnel model?

Thanks,
Iftekhar

From: Tarek Saad (tsaad) [mailto:[email-masked]]
Sent: Friday, May 27, 2016 8:35 AM
To: Chenxia (D); Himanshu Shah; Wen, Bin; Vishnu Pavan Beeram; Raqib Jones; Rakesh Gandhi (rgandhi); Kamran Raza (skraza); [email-masked]; Igor Bryskin; Zhangxian (Xian); Paweł Brzozowski; Anurag Sharma; Xufeng Liu; Paweł Kaczmarek
Cc: [email-masked]; [email-masked]
Subject: Re: [Teas] MPLS and TE tunnels YANG data model meeting

From: Tarek Saad <[email-masked]<mailto:[email-masked]>>
Date: Friday, May 27, 2016 at 11:33 AM
To: "Chenxia (D)" <[email-masked]<mailto:[email-masked]>>, Himanshu Shah <[email-masked]<mailto:[email-masked]>>, "Wen, Bin" <[email-masked]<mailto:[email-masked]>>, Vishnu Pavan Beeram <[email-masked]<mailto:[email-masked]>>, Raqib Jones <[email-masked]<mailto:[email-masked]>>, "Rakesh Gandhi (rgandhi)" <[email-masked]<mailto:[email-masked]>>, "Kamran Raza (skraza)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Igor Bryskin <[email-masked]<mailto:[email-masked]>>, "Zhangxian (Xian)" <[email-masked]<mailto:[email-masked]>>, Paweł Brzozowski <[email-masked]<mailto:[email-masked]>>, Anurag Sharma <[email-masked]<mailto:[email-masked]>>, Xufeng Liu <[email-masked]<mailto:[email-masked]>>, Paweł Kaczmarek <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "mpls@ietf" <mpls@ietf>
Subject: Re: MPLS and TE tunnels YANG data model meeting

Regards,
Tarek

Friday May 27, 2016:
===================
Agenda:

A. SR-TE:
=========
Explicit path:

Tunnel:

Loss:

Bandwidth:

Option #2:

LSP(name=foo-reverse):
bidirectional
reverse
association ID = 1001

Option #3:

MBB for Static:

LSP(foo, mbb-sibling1):

LSP(foo, mbb-sibling2):

T0: traffic on LSP(foo1)

Regards,
Tarek

From: [email-masked]<mailto:[email-masked]>
When: 10:00 AM - 11:00 AM May 27, 2016
Subject: MPLS and TE tunnels YANG data model meeting
Location: webex

Join by phone