Subject: Re: [Teas] IETF TE Topology YANG Model Design Meeting Notes - 2016-06-13

From: Xufeng Liu <[email-masked]>
Date: Wed, 22 Jun 2016 20:29:58 +0000

Participants:
Igor, Xufeng, Pavan, Sergio, Mateusz, Manali, Dieter, Tarek, Oscar, Anurag

- Preparing draft update
  > Dieter described multi-layer and transitional link.

3.2. TE Node
...
ADD:
Multi-layer TE nodes providing switching functions at multiple network layers are an example where a physical node can be decomposed into multiple logical TE nodes (fractions of a node). Some of these (logical) TE nodes may reside in the client layer TE topology while the remaining TE nodes belong to the server layer TE topology.

ADD:
3.4.  Transitional TE Link for Multi-layer Topologies
Networks are typically composed of multiple network layers where one or multiple signals in the client layer network can be multiplexed and encapsulated into a server layer signal. The server layer signal can be carried in the server layer network across multiple nodes until the server layer signal is terminated and the client layer signals reappear in the node that terminates the server layer signal. Examples of multi-layer networks are: IP over MPLS over Ethernet, low order ODUk signals multiplexed into a high order ODUl (l>k) carried over an OCh signal (optical transport network).
TE links as defined in 3.3. can be used to represent links within a network layer. In case of a multi-layer network, nodes and TE links only allow representation of each network layer as a separate TE topology Each of these single layer TE topologies would be isolated from their client and their server layer TE topology, if present (the highest and the lowest network layer in the hierarchy only have a single adjacent layer below or above, respectively). Multiplexing of client layer signals and encapsulating them into a server layer signal requires a function that is provided inside a node (typically realized in hardware). This function is also called layer transition.
One of the key requirements for path computation is to be able to calculate a path between two endpoints across a multi-layer network based on the TE topology representing this multi-layer network. This means that an additional TE construct is needed that represents potential layer transitions in the multi-layer TE-topology that connects the TE-topologies representing each separate network layer. The so-called transitional TE link is such a construct and it represents the layer transition function residing inside a node that is decomposed into multiple logical nodes that are represented as TE nodes. Hence, a transitional TE link connects a client layer node with a server layer node. A TE link as defined in 3.3. has LTPs of exactly the same kind on each link end whereas the transitional TE link has client layer LTPs on the client side of the transitional link and in most cases a single server layer LTP on the server side. It should be noted that transitional links are a helper construct in the multi-layer TE topology and they only exist as long as they are not in use (as they represent potential connectivity). When the server layer trail has been established between the server layer LTP of two transitional links in the server layer network, the resulting client layer link in the data plane will be represented as a normal TE link in the client layer topology. The transitional TE links will re-appear when the server layer trail has been torn down.
Figure: to be added

  > To add more descriptions to node-id.

- Discussed inter-domain Access link
  > Agreed to add an attribute "plug-id" on an access link, to facilitate the topology merge of a customized TE topology and the  client's native TE topology.
  > Debated the attribute type: uint32, uri, or string?
  > Will ask WG for comments.

- Router ID
  > Fix the format to use the type "dotted-quad".

- Discussed event notification
  > We currently have notifications for node and link. There is a comment about if we need more.
  > Agreed to use pub-sub mechanism as much as we can. Hopefully we don't need any more. Will confirm.

Thanks,

- Xufeng

Note: Please drop me an email if you need an invite for joining the weekly call.

From: Xufeng Liu
Sent: Friday, June 17, 2016 2:24 PM
To: 'Xufeng Liu' <[email-masked]>; 'Vishnu Pavan Beeram' <[email-masked]>; 'Igor Bryskin' <[email-masked]>; 'Oscar Gonzalez De Dios' <[email-masked]>; 'Tarek Saad' <[email-masked]>; 'Himanshu Shah' <[email-masked]>; 'Lou Berger' <[email-masked]>; 'BRUNGARD, DEBORAH A (ATTLABS)' <[email-masked]>; 'Susan Hares' <[email-masked]>; 'Zafar Ali (zali)' <[email-masked]>; 'Khaddam, Mazen (CCI-Atlanta)' <[email-masked]>; 'Tony Le' <[email-masked]>; 'BELOTTI, SERGIO (SERGIO)' <[email-masked]>; 'Beller, Dieter (Dieter)' <[email-masked]>; 'Rajan Rao' <[email-masked]>; 'Zhangxian (Xian)' <[email-masked]>; [email-masked]' <[email-masked]>; 'Belotti, Sergio (Nokia - IT)' <[email-masked]>; 'Anurag Sharma' <[email-masked]>
Cc: [email-masked]' <[email-masked]>
Subject: IETF TE Topology YANG Model Design Meeting Notes - 2016-06-13

Participants:
Igor, Xufeng, Pavan, Sergio, Mateusz, Manali, Dieter, Anurag, Tarek, Oscar

- Connectivity Matrix
  > Continued last week's discussion on label restrictions.
  > Agreed on model changes:

       |     +--rw connectivity-matrix* [id]
       |     |  +--rw id                         uint32
       |     |  +--rw from
       |     |  |  +--rw tp-ref?   leafref
@@ -209,6 +209,11 @@ augment /nw:networks/nw:network/nw:node:
       |     |  +--rw to
       |     |  |  +--rw tp-ref?   leafref
       |     |  +--rw is-allowed?                boolean
+      |     |  +--rw label-restriction* [inclusive-exclusive label-start]
+      |     |  |  +--rw inclusive-exclusive    enumeration
+      |     |  |  +--rw label-start            binary
+      |     |  |  +--rw label-end?             binary
+      |     |  |  +--rw range-bitmap?          binary
       |     |  +--rw max-link-bandwidth?        decimal64
       |     |  +--rw max-resv-link-bandwidth?   decimal64
       |     |  +--rw unreserved-bandwidth* [priority]
@@ -262,6 +267,11 @@ augment /nw:networks/nw:network/nw:node:
       |  |  |  +--ro to
       |  |  |  |  +--ro tp-ref?   leafref
       |  |  |  +--ro is-allowed?                boolean
+      |  |  |  +--ro label-restriction* [inclusive-exclusive label-start]
+      |  |  |  |  +--ro inclusive-exclusive    enumeration
+      |  |  |  |  +--ro label-start            binary
+      |  |  |  |  +--ro label-end?             binary
+      |  |  |  |  +--ro range-bitmap?          binary
       |  |  |  +--ro max-link-bandwidth?        decimal64
       |  |  |  +--ro max-resv-link-bandwidth?   decimal64
       |  |  |  +--ro unreserved-bandwidth* [priority]
@@ -326,6 +336,11 @@ augment /nw:networks/nw:network/nw:node:
       |     |  +--ro to
       |     |  |  +--ro tp-ref?   leafref
       |     |  +--ro is-allowed?                boolean
+      |     |  +--ro label-restriction* [inclusive-exclusive label-start]
+      |     |  |  +--ro inclusive-exclusive    enumeration
+      |     |  |  +--ro label-start            binary
+      |     |  |  +--ro label-end?             binary
+      |     |  |  +--ro range-bitmap?          binary
       |     |  +--ro max-link-bandwidth?        decimal64
       |     |  +--ro max-resv-link-bandwidth?   decimal64
       |     |  +--ro unreserved-bandwidth* [priority]
@@ -371,6 +386,11 @@ augment /nw:networks/nw:network/nw:node:
          |  +--rw protection-type?          identityref
          |  +--rw termination-capability* [link-tp]
          |     +--rw link-tp              leafref
+         |     +--rw label-restriction* [inclusive-exclusive label-start]
+         |     |  +--rw inclusive-exclusive    enumeration
+         |     |  +--rw label-start            binary
+         |     |  +--rw label-end?             binary
+         |     |  +--rw range-bitmap?          binary

- Continued to discuss optmization options (cost, delay)
  > Model changes:

@@ -337,6 +337,24 @@ module ietf-te-topology {
   /*
    * Identities
    */
+  identity te-optimization-criterion {
+    description
+      "Base identity for TE optimization criterion.";
+    reference
+      "RFC3272: Overview and Principles of Internet Traffic
+       Engineering.";
+  }
+
+  identity cost {
+    base te-optimization-criterion;
+    description "Optimized on cost.";
+  }
+
+  identity delay {
+    base te-optimization-criterion;
+    description "Optimized on delay.";
+  }

+  identity not-optimized {
+    base te-optimization-criterion;
+    description "Optimization is not applied.";
+  }

@@ -180,7 +180,8 @@ augment /nw:networks/nw:network:
       |  |     +--rw start?               yang:date-and-time
       |  |     +--rw schedule-duration?   string
       |  |     +--rw repeat-interval?     string
-      |  +--rw preference?   uint8
+      |  +--rw preference?               uint8
+      |  +--rw optimization-criterion?   identityref
       +--ro state
          +--ro schedules
          |  +--ro schedule* [schedule-id]
@@ -188,7 +189,8 @@ augment /nw:networks/nw:network:
          |     +--ro start?               yang:date-and-time
          |     +--ro schedule-duration?   string
          |     +--ro repeat-interval?     string
-         +--ro preference?   uint8
+         +--ro preference?               uint8
+         +--ro optimization-criterion?   identityref

- Prepare draft
  > Dieter to describe multi-layer and transitional link.

Thanks,

- Xufeng

---

From: Xufeng Liu <[email-masked]>
Date: Wed, 22 Jun 2016 20:31:04 +0000

Sorry. The date should be 2016-06-20

From: Xufeng Liu
Sent: Wednesday, June 22, 2016 4:30 PM
To: Xufeng Liu <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>; Igor Bryskin <[email-masked]>; Oscar Gonzalez De Dios <[email-masked]>; Tarek Saad <[email-masked]>; Himanshu Shah <[email-masked]>; Lou Berger <[email-masked]>; BRUNGARD, DEBORAH A (ATTLABS) <[email-masked]>; Susan Hares <[email-masked]>; Zafar Ali (zali) <[email-masked]>; Khaddam, Mazen (CCI-Atlanta) <[email-masked]>; Tony Le <[email-masked]>; BELOTTI, SERGIO (SERGIO) <[email-masked]>; Beller, Dieter (Dieter) <[email-masked]>; Rajan Rao <[email-masked]>; Zhangxian (Xian) <[email-masked]>; [email-masked]; Belotti, Sergio (Nokia - IT) <[email-masked]>; Anurag Sharma <[email-masked]>
Cc: [email-masked]
Subject: RE: IETF TE Topology YANG Model Design Meeting Notes - 2016-06-13

Participants:

- Preparing draft update
  > Dieter described multi-layer and transitional link.

3.2    . TE Node
...
ADD:

ADD:

- Router ID

Thanks,

- Xufeng

From: Xufeng Liu
Sent: Friday, June 17, 2016 2:24 PM
To: 'Xufeng Liu' <[email-masked]<mailto:[email-masked]>>; 'Vishnu Pavan Beeram' <[email-masked]<mailto:[email-masked]>>; 'Igor Bryskin' <[email-masked]<mailto:[email-masked]>>; 'Oscar Gonzalez De Dios' <[email-masked]<mailto:[email-masked]>>; 'Tarek Saad' <[email-masked]<mailto:[email-masked]>>; 'Himanshu Shah' <[email-masked]<mailto:[email-masked]>>; 'Lou Berger' <[email-masked]<mailto:[email-masked]>>; 'BRUNGARD, DEBORAH A (ATTLABS)' <[email-masked]<mailto:[email-masked]>>; 'Susan Hares' <[email-masked]<mailto:[email-masked]>>; 'Zafar Ali (zali)' <[email-masked]<mailto:[email-masked]>>; 'Khaddam, Mazen (CCI-Atlanta)' <[email-masked]<mailto:[email-masked]>>; 'Tony Le' <[email-masked]<mailto:[email-masked]>>; 'BELOTTI, SERGIO (SERGIO)' <[email-masked]<mailto:[email-masked]>>; 'Beller, Dieter (Dieter)' <[email-masked]<mailto:[email-masked]>>; 'Rajan Rao' <[email-masked]<mailto:[email-masked]>>; 'Zhangxian (Xian)' <[email-masked]<mailto:[email-masked]>>; [email-masked]' <[email-masked]<mailto:[email-masked]>>; 'Belotti, Sergio (Nokia - IT)' <[email-masked]<mailto:[email-masked]>>; 'Anurag Sharma' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]' <[email-masked]<mailto:[email-masked]>>
Subject: IETF TE Topology YANG Model Design Meeting Notes - 2016-06-13

Participants:

- Connectivity Matrix

- Prepare draft

Thanks,

- Xufeng