Subject: [Teas] Advancing some documents

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 1 Jun 2016 10:28:35 +0100

Hi chairs,

I think there are a few drafts that have been discussed on the mailing list and
which the authors believe are within scope for TEAS and would be better
progressed if adopted by the Working Group. Of course, all of these can continue
to be consolidated and are open for review and discussions on the mailing list,
but if you are able to share a plan for these documents that would be helpful:
Is anything further needed from the authors before these can advance?

draft-ceccarelli-teas-actn-framework 
draft-zhao-teas-pce-control-function 
draft-zhuang-teas-scheduled-resources

Thanks,
Adrian

---

From: Lou Berger <[email-masked]>
Date: Fri, 3 Jun 2016 18:46:39 -0400

Adrian,

Thanks question, see below.

> draft-ceccarelli-teas-actn-framework 
A poll on this will be out shortly.
> draft-zhao-teas-pce-control-function 
It would be good to get a little more on this one from the WG -- either
on list or in session. We individually are supportive of the work and
look forward to seeing in pursued in the WG.

> draft-zhuang-teas-scheduled-resources
The merges look good - but there's only been a few comments on the list
since it was updated.  So this falls into the same boat as the prior
draft. - We'd like to hear more from the WG before polling.

Thanks,
Lou and Pavan
> Thanks,
> Adrian
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Tue, 7 Jun 2016 09:24:50 -0400

Lou,

Regarding draft-zhao-teas-pce-control-function, there’s already been some
amount of discussion on the list (I know because I was a part of it) and
-01 was the result, which reflects that discussion. I’m not sure how much
else you would like to see happen as an individual draft. The draft
reflects activity that’s already taking part in the industry, and IMHO it
would be better served to happen under IETF auspices than as proprietary
extensions to PCEP, so the sooner a WG draft, the better.

Cheers,
Andy

---

From: Cyril Margaria <[email-masked]>
Date: Wed, 15 Jun 2016 09:38:43 -0400

Hi,

I am supporting the draft-zhao-teas-pce-control-function dcocument and look
forward to see it progress in the WG.
This is a good summary of the current architectures and discussions.

Best Regards,
Cyril

---

From: "King, Daniel" <[email-masked]>
Date: Wed, 15 Jun 2016 16:48:36 +0000

Hi All,

Just like to echo Cyril’s comments that the PCE-based control architecture is a really interesting topic and the authors have done great job of documenting recent discussions on and off the PCE list.

The current open source SDN controller platforms already implement some basic PCE architecture and PCEP extensions, but there is growing trend for more capability (TE automation, optimisation and resiliency) to be enabled using PCEP. Having this document that summarises architecture, applicability and capability - and possible gaps - is very useful. I would also like to see the document progress in the TEAS WG.

BR, Dan.

From: Teas [mailto:[email-masked]] On Behalf Of Cyril Margaria
Sent: 15 June 2016 14:39
To: Lou Berger <[email-masked]>
Cc: 'Adrian Farrel' ([email-masked]) <[email-masked]>; [email-masked]; TEAS WG <[email-masked]>
Subject: Re: [Teas] Advancing some documents

Hi,

I am supporting the draft-zhao-teas-pce-control-function dcocument and look forward to see it progress in the WG.
This is a good summary of the current architectures and discussions.
Best Regards,
Cyril

On 3 June 2016 at 18:46, Lou Berger <[email-masked]<mailto:[email-masked]>> wrote:
Adrian,

Thanks,
Lou and Pavan
> [email-masked]<mailto:[email-masked]>

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 15 Jun 2016 20:47:36 +0100

Yeah, thanks Dan.
 
One objective of this document is to try to anchor (architecturally) the many and varied approaches in different projects and IETF I-D all of which focus on some form of controller/orchestrator in which PCE plays a central role and where PCEP is proposed as a "southbound interface."
 
I think it is important that "we" take hold of this problem space and lead so that we are able to rationalise which mechanisms make sense and which do not, and so that we can keep technical oversight of PCE and PCEP.
 
So why is this I-D in TEAS? Well, when the previous use case and requirements drafts were doing the rounds, they were sent from PCE to TEAS because the space was considered to be wider and more general than simply a use of PCE. It seemed natural, therefore, to place this draft in TEAS where architecture work is done.
 
Adrian
 
From: Teas [mailto:[email-masked]] On Behalf Of King, Daniel
Sent: 15 June 2016 17:49
To: TEAS WG
Subject: Re: [Teas] Advancing some documents
 
Hi All,

                                                                                                                                                                                                        
BR, Dan. 

Hi, 

Thanks,
Lou and Pavan

---

From: Lou Berger <[email-masked]>
Date: Fri, 24 Jun 2016 08:41:37 -0400

Hi,

    So Pavan and I were hoping for more discussion, but given past face
to face and list comments, we think it's worth polling
pce-control-function.  -- I'll start the poll process in a moment...

Lou (and Pavan)

On 6/15/2016 12:48 PM, King, Daniel wrote:
>
> Hi All,
>
>  
>
> Just like to echo Cyril’s comments that the PCE-based control
> architecture is a really interesting topic and the authors have done
> great job of documenting recent discussions on and off the PCE list.
>
>  
>
> The current open source SDN controller platforms already implement
> some basic PCE architecture and PCEP extensions, but there is growing
> trend for more capability (TE automation, optimisation and resiliency)
> to be enabled using PCEP. Having this document that summarises
> architecture, applicability and capability - and possible gaps - is
> very useful. I would also like to see the document progress in the
> TEAS WG.
>
>                                                                                                                                                                                                        
>
>
> BR, Dan.
>
>  
>
> *From:*Teas [mailto:[email-masked]] *On Behalf Of *Cyril Margaria
> *Sent:* 15 June 2016 14:39
> *To:* Lou Berger <[email-masked]>
> *Cc:* 'Adrian Farrel' ([email-masked]) <[email-masked]>;
> [email-masked]; TEAS WG <[email-masked]>
> *Subject:* Re: [Teas] Advancing some documents
>
>  
>
> Hi,
>
>
> I am supporting the draft-zhao-teas-pce-control-function dcocument and
> look forward to see it progress in the WG.
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>