Subject: Re: [Teas] Spencer Dawkins' Yes on draft-ietf-teas-pce-central-control-04: (with COMMENT)

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 4 Sep 2017 10:47:25 +0100

Thanks Spencer,

[snip]

> In
> https://tools.ietf.org/html/draft-ietf-teas-pce-central-control-04#section-3.1.1,
> the description is short, which could be fine, but meant I was guessing at a
> lot of high-level details that I could dig out of
> https://tools.ietf.org/html/draft-ietf-pce-stateful-pce-21 for myself, but it
> might be helpful to include a couple of points, like whether the PCCs in this
> technology are (always?) LSRs participating in the IGP (OSPF or IS-IS), and
> whether the PCEs are (always?) either LSRs or servers also participating in the
> IGP, and whether the IGP is (always?) used to set up LSPs, for readers who have
> a (G)MPLS or MPLS-TE network now, to figure out how it maps at a high level to
> what they already have. I’m guessing from
> https://tools.ietf.org/html/draft-ietf-pce-stateful-pce-21#section-5.5, but I’m
> guessing.

I have added...
        <t>In this mode of operation, the PCE may construct its TED in a number of ways as 
           described in <xref target="RFC4655"/> including (but not limited to) participating
           in the IGP or receiving information from a network element via BGP-LS 
           <xref target="RFC7752" />.</t>

> I’m not quite sure what to do with this part of the security considerations:
> 
>    In
>    short, while the interactions with a PCE-based controller are not
>    substantially different to those in any other SDN architecture, the
>    security implications of SDN have not been fully discussed or
>    described.  Therefore, protocol and applicability work around
>    solutions for this architecture must take proper account of these
>    concerns.
> 
>    It is expected that each new document that is produced for a specific
>    use case will also include considerations of the security impacts of
>    the use of a PCE-based central controller on the network type and
>    services being managed.
> 
> If I’m reading this literally, it’s saying that we haven’t finished discussing
> SDN security considerations in general yet, so each new document will consider
> the security impact of a PCE-based central controller on the network type and
> services being managed as an SDN. Is that what was meant?

Yes. You read it right.
A subtext might be "Don't try to lean on any pre-existing SDN work to pass the buck on PCE-CC security, because you'll probably fall on your face."

> If I’m reading the manageability considerations section correctly, perhaps it’s
> worth pointing out what the extension story is for the IGPs that will be used
> in some of the technologies discussed earlier in the document, if that’s part
> of this work as well.

Yes.
Added a sentence to the second paragraph of this section...
        This may require
        protocol extensions for the mechanisms listed in this paragraph.

Cheers,
Adrian

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 4 Sep 2017 09:42:55 -0500

Hi, Adrian,

>            <xref target="RFC7752" />.</t>

I wouldn't mind more explanation, but this already helps a lot - enough
that I understand the text now.

> A subtext might be "Don't try to lean on any pre-existing SDN work to pass
> the buck on PCE-CC security, because you'll probably fall on your face."
>

Thanks for confirming my worst suspicions. :-)

And the subtext for that might be "Spencer hopes someone looks at this
exchange and says, you know, we really SHOULD be thinking about SDN
security in the general case, what would it take to make that happen?", but
that''s not your problem any longer :D

>         protocol extensions for the mechanisms listed in this paragraph.

Perfect. And thanks for all of the above ...

Spencer