Subject: [Teas] Warren Kumari's No Objection on draft-ietf-teas-actn-framework-14: (with COMMENT)

From: Warren Kumari <[email-masked]>
Date: Tue, 22 May 2018 12:38:35 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-teas-actn-framework-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-teas-actn-framework/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I have a few nits to further improve readability:

Section 1:
"Traffic Engineered (TE) networks have a variety of mechanisms to facilitate
separation of data plane and control plane" s/facilitate separation/facilitate
the separation/ ?

"This document describes a set of management and control functions used to
operate one or more TE networks to construct virtual networks that can be
represented to customers" The word "represented" here sounds odd, but I don't
really have an alternative -- perhaps just "presented" ? Represented is
probably technically correct, but it feels like there should be a more
appropriate one...

Section 3.4:
"In addition, some networks may operate a control plane and as such it is not
practical for the customer to directly interface with network elements." Can
you please clarify that you mean a TE (or similar) control plane -- I believe
that *all* networks have some sort of control plane (and so the "some networks"
is false / misleading).

---

From: Leeyoung <[email-masked]>
Date: Wed, 23 May 2018 23:10:07 +0000

Hi Warren,

Thanks for providing good comments for the document. Please see inline for our response to your comments.

Please let us know if our responses are all good to you.

Thanks & Best regards,

Young and Daniele,

-----Original Message-----
From: Warren Kumari [mailto:[email-masked]]
Sent: Tuesday, May 22, 2018 2:39 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Vishnu Beeram <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Warren Kumari's No Objection on draft-ietf-teas-actn-framework-14: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

COMMENT:

Section 1:

"Traffic Engineered (TE) networks have a variety of mechanisms to facilitate separation of data plane and control plane" s/facilitate separation/facilitate the separation/ ?

DC&YL>> Yes, agree. We will correct as you suggested.

"This document describes a set of management and control functions used to operate one or more TE networks to construct virtual networks that can be represented to customers" The word "represented" here sounds odd, but I don't really have an alternative -- perhaps just "presented" ? Represented is probably technically correct, but it feels like there should be a more appropriate one...

DC&YL>> We will replace "represented" with "presented".

Section 3.4:

"In addition, some networks may operate a control plane and as such it is not practical for the customer to directly interface with network elements." Can you please clarify that you mean a TE (or similar) control plane -- I believe that *all* networks have some sort of control plane (and so the "some networks"

is false / misleading).

DC&YL>> Here in this sentence, what we were saying is that “some networks may operate a centralized controller, whether it is TE or non-TE, and as such it is also not practical

for the customer to directly interface with network elements. As unclear, and as the first sentence already says this, we think the best is to remove this sentence. Hope that is clearer.

---

From: Warren Kumari <[email-masked]>
Date: Wed, 23 May 2018 19:32:15 -0400

Thanks -- all of these work well for me.

Thank you!
W

On Wed, May 23, 2018 at 7:10 PM Leeyoung <[email-masked]> wrote:

> Cc: [email-masked]; Vishnu Beeram <
> [email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> Subject: Warren Kumari's No Objection on
> draft-ietf-teas-actn-framework-14: (with COMMENT)
>
>
>
> "Traffic Engineered (TE) networks have a variety of mechanisms to
> facilitate separation of data plane and control plane" s/facilitate
> separation/facilitate the separation/ ?
>
>
>
> *DC&YL>> Yes, agree. We will correct as you suggested. *
>
>
>
> represented to customers" The word "represented" here sounds odd, but I
> don't really have an alternative -- perhaps just "presented" ? Represented
> is probably technically correct, but it feels like there should be a more
> appropriate one...
>
>
>
> *DC&YL>> We will replace "represented" with "presented". *
>
>
>
> Section 3.4:
>
> "In addition, some networks may operate a control plane and as such it is
> not practical for the customer to directly interface with network
> elements." Can you please clarify that you mean a TE (or similar) control
> plane -- I believe that *all* networks have some sort of control plane (and
> so the "some networks"
>
> is false / misleading).
>
>
>
> *DC&YL>> Here in this sentence, what we were saying is that “some networks
> may operate a centralized controller, whether it is TE or non-TE, and as
> such it is also not practical*
>
> *for the customer to directly interface with network elements. As unclear,
> and as the first sentence already says this, we think the best is to remove
> this sentence. Hope that is clearer.*
>
>
>

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf