Subject: Re: [Teas] New Version Notification for draft-lee-teas-te-service-mapping-yang-07.txt

From: Lou Berger <[email-masked]>
Date: Tue, 1 May 2018 09:04:56 -0400

Hi Young,

see below.

On 4/5/2018 10:57 AM, Leeyoung wrote:
>
> Hi Pavan and Lou,
>
> We have updated the draft to incorporate Pavan's comment (during 
> London meeting) to generalize the model for TE.
>
> Regarding the mapping, we have added options for all three:
>
> -              VN (ACTN VN model)
>
> -              Single abstract node in TE topology (TE-topology model)
>
> -              List of tunnels (TE-tunnel model)
>
> See the changes as follows:
>
>          +---------+ +-------------+         +----------+
>
>          |  L3SM   | <------> | | <-----> | ACTN VN  |
>
>          +---------+          | |         |  Model   |
>
>                               | |         +----------+
>
>                               |             |
>
>          +---------+          | TE-Service |         +----------+
>
>          |  L2SM   | <------> |Mapping Model| <-----> | TE-Topo |
>
>          +---------+          | |         | Model |
>
>                               | |         +----------+
>
>                               |             |
>
>          +---------+          | |         +----------+
>
>          |  L1CSM  | <------> | | <-----> | TE-Tunnel|
>
>          +---------+          | |         | Model |
>
> +-------------+         +----------+
>
> Let us know what you think.
>

I think having a way to map from the LxSMs to  te topology makes a lot 
of sense.  Although, personally I would have looked at augmenting the 
existing models with te-topology-ids and te-tp-ids before defining a new 
module.  This said, what's really important is the opinion of WG 
contributors.  So I'd be more interested in hearing what others think of 
the approach.

Lou

> Best regards,
>
> Young & Dhruv
>
> -----------------------------------------------------------------------------------------------
>
> 4. YANG Data Tree
>
> module: ietf-te-service-mapping
>
>     +--rw te-service-mapping
>
>        +--rw service-mapping
>
>        |  +--rw mapping-list* [map-id]
>
>        |     +--rw map-id uint32
>
>        |     +--rw map-type? map-type
>
>        |     +--rw (service)?
>
>        |     |  +--:(l3vpn)
>
>        |     |  |  +--rw l3vpn-ref?        -> 
> /l3:l3vpn-svc/vpn-services/vpn-
>
> service/vpn-id
>
>        |     |  +--:(l2vpn)
>
>        |     |  |  +--rw l2vpn-ref?        -> 
> /l2:l2vpn-svc/vpn-services/vpn-
>
> service/vpn-id
>
>        |     |  +--:(l1vpn)
>
>        |     |     +--rw l1vpn-ref?        -> /l1:l1cs/service/service-
>
> list/subscriber-l1vc-id
>
>        |     +--rw (te)?
>
>        |        +--:(actn-vn)
>
>        |        |  +--rw actn-vn-ref?      -> /vn:actn/vn/vn-list/vn-id
>
>        |        +--:(te-topo)
>
>        |        |  +--rw vn-topology-id?   te-types:te-topology-id
>
>        |        |  +--rw abstract-node?    -> 
> /nw:networks/network/node/node-
>
> id
>
>        |        +--:(te-tunnel)
>
>        |           +--rw te-tunnel-list*   te:tunnel-ref
>
>        +--rw site-mapping
>
>           +--rw mapping-list* [map-id]
>
>              +--rw map-id         uint32
>
>              +--rw (service)?
>
>              |  +--:(l3vpn)
>
>              |  |  +--rw l3vpn-ref? -> /l3:l3vpn-svc/sites/site/site-id
>
>              |  +--:(l2vpn)
>
>              |  |  +--rw l2vpn-ref? -> /l2:l2vpn-svc/sites/site/site-id
>
>              |  +--:(l1vpn)
>
>              |     +--rw l1vpn-ref? -> /l1:l1cs/access/uni-list/UNI-ID
>
>              +--rw (te)?
>
>                 +--:(actn-vn)
>
>                 |  +--rw actn-vn-ref? -> /vn:actn/ap/access-point-
>
> list/access-point-id
>
>                 +--:(te)
>
>                    +--rw ltp?           te-types:te-tp-id
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 05, 2018 9:43 AM
> To: Dhruv Dhody <[email-masked]>; Giuseppe Fioccola 
> <[email-masked]>; Jeff Tantsura 
> <[email-masked]>; Daniele Ceccarelli 
> <[email-masked]>; Leeyoung <[email-masked]>
> Subject: New Version Notification for 
> draft-lee-teas-te-service-mapping-yang-07.txt
>
> A new version of I-D, draft-lee-teas-te-service-mapping-yang-07.txt
>
> has been successfully submitted by Young Lee and posted to the IETF 
> repository.
>
> Name: draft-lee-teas-te-service-mapping-yang
>
> Revision:              07
>
> Title:                     Traffic Engineering and Service Mapping 
> Yang Model
>
> Document date: 2018-04-05
>
> Group:                  Individual Submission
>
> Pages:                  19
>
> URL: 
> https://www.ietf.org/internet-drafts/draft-lee-teas-te-service-mapping-yang-07.txt
>
> Status: 
> https://datatracker.ietf.org/doc/draft-lee-teas-te-service-mapping-yang/
>
> Htmlized: 
> https://tools.ietf.org/html/draft-lee-teas-te-service-mapping-yang-07
>
> Htmlized: 
> https://datatracker.ietf.org/doc/html/draft-lee-teas-te-service-mapping-yang
>
> Diff: 
> https://www.ietf.org/rfcdiff?url2=draft-lee-teas-te-service-mapping-yang-07
>
> Abstract:
>
>    This document provides a YANG data model to map service model (e.g.,
>
>    L3SM) and Traffic Engineering model (e.g., TE Tunnel or ACTN VN
>
>    model). This model is referred to as TE service Mapping Model. This
>
>    model is applicable to the operation's need for a seamless control
>
>    and management of their VPN services with TE tunnel support.
>
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at 
> tools.ietf.org.
>
> The IETF Secretariat
>

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Wed, 2 May 2018 11:58:35 +0000

I think having a way to map from the LxSMs to  te topology makes a lot of sense.  Although, personally I would have looked at augmenting the existing models with te-topology-ids and te-tp-ids before defining a new module.  This said, what's really important is the opinion of WG contributors.  So I'd be more interested in hearing what others think of the approach.

[Michael] It is somewhat difficult to comment on the variants suggested in different draft versions without realistic examples. Figure 1 is a non-starter as this seems to assume that a single transport network is uses by two AS. This is (1) not the typical scenario in many network operators, (2) it would require a more detailed discussion on how the AS peer which each other (option A, B, C, etc.), and (3), it shows only L3SM, while the document intents to be applicable to L2SMs and L1CSM as well. These are about different technologies. In my opinion, an I-D that proposes a YANG model should at least include some basic explanation how it would be used in an actual network, in particular if the use is not obvious.

Michael

---

From: Fioccola Giuseppe <[email-masked]>
Date: Fri, 4 May 2018 08:19:14 +0000

Hi Lou, Young,
This is an interesting point. The augmentation for LxSM is possible but, in this case, it could not be the right way because it is a less flexible approach. In addition te-topology-ids and te-tp-ids are probably only optional information for the interface between Customer and Service Provider. So, in my opinion, it would be convenient to have a Service Mapping Yang Model.

Thanks,

Giuseppe

Da: Lou Berger [mailto:[email-masked]]
Inviato: martedì 1 maggio 2018 15:05
A: Leeyoung; Vishnu Pavan Beeram; [email-masked]
Cc: Dhruv Dhody; Fioccola Giuseppe; Jeff Tantsura; Daniele Ceccarelli
Oggetto: Re: New Version Notification for draft-lee-teas-te-service-mapping-yang-07.txt

Hi Young,
see below.

Hi Pavan and Lou,

We have updated the draft to incorporate Pavan's comment (during London meeting) to generalize the model for TE.

-              VN (ACTN VN model)

                              |             |         +----------+

                              |             |

                              |             |         +----------+

                              |             |

Lou

Best regards,

Young & Dhruv

4. YANG Data Tree

    +--rw te-service-mapping

       +--rw service-mapping

       |     +--rw map-id            uint32

       |     +--rw (service)?

       |     |  +--:(l3vpn)

       |     |  |  +--rw l3vpn-ref?        -> /l3:l3vpn-svc/vpn-services/vpn-

service/vpn-id

       |     |  +--:(l2vpn)

       |     |  |  +--rw l2vpn-ref?        -> /l2:l2vpn-svc/vpn-services/vpn-

service/vpn-id

       |     |  +--:(l1vpn)

list/subscriber-l1vc-id

       |     +--rw (te)?

       |        +--:(actn-vn)

       |        +--:(te-topo)

       |        |  +--rw abstract-node?    -> /nw:networks/network/node/node-

id

       |        +--:(te-tunnel)

       +--rw site-mapping

             +--rw map-id         uint32

             +--rw (service)?

             |  +--:(l3vpn)

             |  +--:(l2vpn)

             |  +--:(l1vpn)

             +--rw (te)?

                +--:(actn-vn)

list/access-point-id

                +--:(te)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Thursday, April 05, 2018 9:43 AM
To: Dhruv Dhody <[email-masked]><mailto:[email-masked]>; Giuseppe Fioccola <[email-masked]><mailto:[email-masked]>; Jeff Tantsura <[email-masked]><mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]><mailto:[email-masked]>; Leeyoung <[email-masked]><mailto:[email-masked]>
Subject: New Version Notification for draft-lee-teas-te-service-mapping-yang-07.txt

has been successfully submitted by Young Lee and posted to the IETF repository.

Revision:              07

Title:                     Traffic Engineering and Service Mapping Yang Model

Pages:                  19

URL:            https://www.ietf.org/internet-drafts/draft-lee-teas-te-service-mapping-yang-07.txt

Status:         https://datatracker.ietf.org/doc/draft-lee-teas-te-service-mapping-yang/

Htmlized:       https://tools.ietf.org/html/draft-lee-teas-te-service-mapping-yang-07

Htmlized:       https://datatracker.ietf.org/doc/html/draft-lee-teas-te-service-mapping-yang

Diff:           https://www.ietf.org/rfcdiff?url2=draft-lee-teas-te-service-mapping-yang-07

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie. 

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks. 

Rispetta l'ambiente. Non stampare questa mail se non è necessario.

---

From: Leeyoung <[email-masked]>
Date: Fri, 4 May 2018 16:57:16 +0000

Hi Lou,

I see your point. If we were to do only L3VPN per se, it would be OK to augment L3SM model to add TE related parameters. But here we have LxSM where x=1,2,3 and ACTN VN (in addition, there could be another service model we have not seen such as L0SM) and it would more scalable and flexible to have one TE Service Mapping Model to which all service models are covered as Giuseppe pointed out.

Another point is that in most cases the top level service orchestrator is dealing with many different services together and there may be correlations across different services it offers. In such case, having a TE-Service mapping model would make sense.

Just my thought.

Thanks.
Young

From: Fioccola Giuseppe [mailto:[email-masked]]
Sent: Friday, May 04, 2018 3:19 AM
To: Lou Berger <[email-masked]>; Leeyoung <[email-masked]>; [email-masked]
Cc: Dhruv Dhody <[email-masked]>; Jeff Tantsura <[email-masked]>; Daniele Ceccarelli <[email-masked]>; Vishnu Pavan Beeram <[email-masked]>
Subject: R: New Version Notification for draft-lee-teas-te-service-mapping-yang-07.txt

Hi Lou, Young,

Thanks,

Giuseppe

A: Leeyoung; Vishnu Pavan Beeram; [email-masked]<mailto:[email-masked]>

Hi Young,
see below.

Hi Pavan and Lou,

-              VN (ACTN VN model)

                              |             |         +----------+

                              |             |

                              |             |         +----------+

                              |             |

Lou

Best regards,

Young & Dhruv

4. YANG Data Tree

    +--rw te-service-mapping

       +--rw service-mapping

       |     +--rw map-id            uint32

       |     +--rw (service)?

       |     |  +--:(l3vpn)

service/vpn-id

       |     |  +--:(l2vpn)

service/vpn-id

       |     |  +--:(l1vpn)

list/subscriber-l1vc-id

       |     +--rw (te)?

       |        +--:(actn-vn)

       |        +--:(te-topo)

id

       |        +--:(te-tunnel)

       +--rw site-mapping

             +--rw map-id         uint32

             +--rw (service)?

             |  +--:(l3vpn)

             |  +--:(l2vpn)

             |  +--:(l1vpn)

             +--rw (te)?

                +--:(actn-vn)

list/access-point-id

                +--:(te)

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Thursday, April 05, 2018 9:43 AM
To: Dhruv Dhody <[email-masked]><mailto:[email-masked]>; Giuseppe Fioccola <[email-masked]><mailto:[email-masked]>; Jeff Tantsura <[email-masked]><mailto:[email-masked]>; Daniele Ceccarelli <[email-masked]><mailto:[email-masked]>; Leeyoung <[email-masked]><mailto:[email-masked]>
Subject: New Version Notification for draft-lee-teas-te-service-mapping-yang-07.txt

Revision:              07

Pages:                  19

Abstract:

The IETF Secretariat