Subject: [Teas] FW: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-17.txt

From: Leeyoung <[email-masked]>
Date: Wed, 8 May 2019 16:50:38 +0000

Hi, 

This revision incorporated Dieter's comments (exchanged privately --- see the attachment for this content of Dieter's comments). 

If there are still further comments before being ready for WG adoption, we'd appreciate your providing comments in a timely manner.  

Thanks & Best regards,
Young (on behalf of co-authors)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, May 8, 2019 11:43 AM
To: Daniele Ceccarelli <[email-masked]>; Satish Karunanithi <[email-masked]>; Leeyoung <[email-masked]>; Dhruv Dhody <[email-masked]>; Daniel King <[email-masked]>; Ricard Vilata <[email-masked]>; Ricard Vilalta <[email-masked]>
Subject: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-17.txt

A new version of I-D, draft-lee-teas-actn-pm-telemetry-autonomics-17.txt
has been successfully submitted by Young Lee and posted to the IETF repository.

Name:		draft-lee-teas-actn-pm-telemetry-autonomics
Revision:	17
Title:		YANG models for VN & TE Performance Monitoring Telemetry and Scaling Intent Autonomics
Document date:	2019-05-08
Group:		Individual Submission
Pages:		30
URL:            https://www.ietf.org/internet-drafts/draft-lee-teas-actn-pm-telemetry-autonomics-17.txt
Status:         https://datatracker.ietf.org/doc/draft-lee-teas-actn-pm-telemetry-autonomics/
Htmlized:       https://tools.ietf.org/html/draft-lee-teas-actn-pm-telemetry-autonomics-17
Htmlized:       https://datatracker.ietf.org/doc/html/draft-lee-teas-actn-pm-telemetry-autonomics
Diff:           https://www.ietf.org/rfcdiff?url2=draft-lee-teas-actn-pm-telemetry-autonomics-17

Abstract:
   This document provides YANG data models that describe performance
   monitoring telemetry and scaling intent mechanism for TE-tunnels and
   Virtual Networks (VN).

   The models presented in this draft allow customers to subscribe to
   and monitor their key performance data of their interest on the
   level of TE-tunnel or VN. The models also provide customers with the
   ability to program autonomic scaling intent mechanism on the level
   of TE-tunnel as well as VN.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-16.txt
From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]>
To: Leeyoung <[email-masked]>
Cc: TEAS WG Chairs <[email-masked]>, "King, Daniel" <[email-masked]>, Daniele Ceccarelli <[email-masked]>
Date: Thu, 25 Apr 2019 09:06:20 +0000

Hi Young,

here are some more comments as promised:

Other terms which are not defined are:

*       scaling intent (the description in section 4 is very poor and does not describe what scaling intent is all about),

*       network autonomics

The term performance monitoring (PM) is being used in transport networks for many years and typically relates to 15min/24h PM counters and PM history.
Streaming telemetry data is rather new for transport network equipment and care should be taken to distinguish streaming telemetry data  from classical PM data
unless the classical PM counters are streamed, which is also an option.

Regarding the scaling intent: I was expecting to find a description of "scaling intent" in order to understand what it means:

      Scaling intent configuration mechanism allows the client to
      configure automatic scale-in and scale-out mechanisms on both the
      TE-tunnel and the VN level. Various conditions can be set for auto-
      scaling based on the PM telemetry data.

   What are the "automatic scale-in and scale-out mechanisms"? What are the configuration parameters of these mechanisms? This is totally unclear to me:

      There are a number of parameters involved in the mechanism:

        . scale-out-intent or scale-in-intent: whether to scale-out or
           scale-in.

   The tree view in section 4 is not providing any clarity either:

      module: ietf-te-kpi-telemetry
        augment /te:te/te:tunnels/te:tunnel:
          +-rw te-scaling-intent
          |  +-rw scale-in-intent
          |  |  +-rw threshold-time?            uint32
          |  |  +-rw cooldown-time?             uint32
          |  |  +-rw scale-in-operation-type?   scaling-criteria-operation
          |  |  +-rw scaling-condition* [performance-type]
          |  |     +-rw performance-type           identityref
          |  |     +-rw threshold-value?           string
          |  |     +-rw te-telemetry-tunnel-ref?
                      -> /te:te/tunnels/tunnel/name
          |  +-rw scale-out-intent
          |     +-rw threshold-time?             uint32
          |     +-rw cooldown-time?              uint32
          |     +-rw scale-out-operation-type?   scaling-criteria-operation
          |     +-rw scaling-condition* [performance-type]
          |        +-rw performance-type           identityref
          |        +-rw threshold-value?           string
          |        +-rw te-telemetry-tunnel-ref?
                      -> /te:te/tunnels/tunnel/name

   The meaning of the attributes (e.g. cooldown-time, scale-in-operation-type) are not explained.

   My conclusion: this document is not ready yet for WG adoption. The concerns I raised at IETF104 wer not properly addressed.

   Thanks,
   Dieter

   On 18.04.2019 20:58, Dieter Beller wrote:

   Hi Young,

   here is my very first comment:

   The abstract reads:

      Abstract

         This document provides YANG data models that describe performance
         monitoring telemetry and scaling intent mechanism for TE-tunnels and
         Virtual Networks (VN).

         The models presented in this draft allow customers to subscribe to
         and monitor their key performance data of their interest on the
         level of TE-tunnel or VN. The models also provide customers with the
         ability to program autonomic scaling intent mechanism on the level
         of TE-tunnel as well as VN.

   When I tried to find the definition of the term "key performance data" I failed. The terminology section reads:

      1.1. Terminology

         Refer to [RFC8453<https://tools.ietf.org/html/rfc8453>], [RFC7926<https://tools.ietf.org/html/rfc7926>], and [RFC8309<https://tools.ietf.org/html/rfc8309>] for the key terms used
         in this document.

   The term "key performance data" is not defined in section 1.1 nor in the referenced RFSs!
   Frankly speaking, I have no clue what "key performance data" is.

   This is what I was criticizing when you presented the draft in Prague.

   More comments will follow.

   Thanks,
   Dieter

   On 18.04.2019 18:56, Dieter Beller wrote:

      Hi Young,

      I will have a look at the latest version. Unfortunately, I was not able to find the necessary time yet.

      Thanks,
      Dieter

      On 18.04.2019 18:27, Leeyoung wrote:

         Hi Pavan and Lou,

         To recap, the revision addressed all your comments in Prague meeting on the generalization of this draft so that it would be applicable in general contexts. And thanks to Tom, all other comments have been incorporated to improve the draft.

         The co-authors believe that this is ready for WG adoption. Please let us know if this is the case; otherwise, let us know what needs further to be done.

         Thanks & Best regards,
         Young (on behalf of co-authors)

         -----Original Message-----
         From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
         Sent: Thursday, April 18, 2019 11:18 AM
         To: Daniele Ceccarelli <[email-masked]><mailto:[email-masked]>; Satish Karunanithi <[email-masked]><mailto:[email-masked]>; Leeyoung <[email-masked]><mailto:[email-masked]>; Dhruv Dhody <[email-masked]><mailto:[email-masked]>; Daniel King <[email-masked]><mailto:[email-masked]>; Ricard Vilata <[email-masked]><mailto:[email-masked]>; Ricard Vilalta <[email-masked]><mailto:[email-masked]>
         Subject: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-16.txt

         A new version of I-D, draft-lee-teas-actn-pm-telemetry-autonomics-16.txt
         has been successfully submitted by Young Lee and posted to the IETF repository.

         Name:          draft-lee-teas-actn-pm-telemetry-autonomics
         Revision:      16
         Title:         YANG models for VN & TE Performance Monitoring Telemetry and Scaling Intent Autonomics
         Document date: 2019-04-18
         Group:         Individual Submission
         Pages:         29
         URL:            https://www.ietf.org/internet-drafts/draft-lee-teas-actn-pm-telemetry-autonomics-16.txt
         Status:         https://datatracker.ietf.org/doc/draft-lee-teas-actn-pm-telemetry-autonomics/
         Htmlized:       https://tools.ietf.org/html/draft-lee-teas-actn-pm-telemetry-autonomics-16
         Htmlized:       https://datatracker.ietf.org/doc/html/draft-lee-teas-actn-pm-telemetry-autonomics
         Diff:           https://www.ietf.org/rfcdiff?url2=draft-lee-teas-actn-pm-telemetry-autonomics-16

         Abstract:
            This document provides YANG data models that describe performance
            monitoring telemetry and scaling intent mechanism for TE-tunnels and
            Virtual Networks (VN).

            The models presented in this draft allow customers to subscribe to
            and monitor their key performance data of their interest on the
            level of TE-tunnel or VN. The models also provide customers with the
            ability to program autonomic scaling intent mechanism on the level
            of TE-tunnel as well as VN.

         Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

         The IETF Secretariat

         _______________________________________________
         Teas mailing list
         [email-masked]<mailto:[email-masked]>
         https://www.ietf.org/mailman/listinfo/teas

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Sun, 19 May 2019 23:57:53 -0500

Young,
Thanks for bringing the offline discussion to the list. Please discuss (on
the list) how the changes in the latest revision address all of Dieter's
comments.

Dieter,
Please do confirm on the list if there are no further open issues to
discuss.

Regards,
-Pavan

On Wed, May 8, 2019 at 11:50 AM Leeyoung <[email-masked]> wrote:

> Hi,
>
> This revision incorporated Dieter's comments (exchanged privately --- see
> the attachment for this content of Dieter's comments).
>
> If there are still further comments before being ready for WG adoption,
> we'd appreciate your providing comments in a timely manner.
>
> Thanks & Best regards,
> To: Daniele Ceccarelli <[email-masked]>; Satish
> Karunanithi <[email-masked]>; Leeyoung <[email-masked]>;
> Dhruv Dhody <[email-masked]>; Daniel King <[email-masked]>;
> Ricard Vilata <[email-masked]>; Ricard Vilalta <
> [email-masked]>
> Subject: New Version Notification for
> draft-lee-teas-actn-pm-telemetry-autonomics-17.txt
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-lee-teas-actn-pm-telemetry-autonomics-17.txt
> Status:
> https://datatracker.ietf.org/doc/draft-lee-teas-actn-pm-telemetry-autonomics/
> Htmlized:
> https://tools.ietf.org/html/draft-lee-teas-actn-pm-telemetry-autonomics-17
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-lee-teas-actn-pm-telemetry-autonomics
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-lee-teas-actn-pm-telemetry-autonomics-17
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
>
>
>
> ---------- Forwarded message ----------
> Cc: TEAS WG Chairs <[email-masked]>, "King, Daniel" <
> [email-masked]>, Daniele Ceccarelli <
> [email-masked]>
> Bcc:
> Subject: Re: [Teas] FW: New Version Notification for
> draft-lee-teas-actn-pm-telemetry-autonomics-16.txt
> Hi Young,
>
>    - scaling intent (the description in section 4 is very poor and does
>    not describe what scaling intent is all about),
>    - network autonomics
>
>
> The term performance monitoring (PM) is being used in transport networks
> for many years and typically relates to 15min/24h PM counters and PM
> history.
> Streaming telemetry data is rather new for transport network equipment and
> care should be taken to distinguish streaming telemetry data  from
> classical PM data
> Regarding the scaling intent: I was expecting to find a description of
> "scaling intent" in order to understand what it means:
>
> What are the "automatic scale-in and scale-out mechanisms"? What are the
> configuration parameters of these mechanisms? This is totally unclear to me:
>
> The meaning of the attributes (e.g. cooldown-time,
> scale-in-operation-type) are not explained.
>
>
> My conclusion: this document is not ready yet for WG adoption. The
> concerns I raised at IETF104 wer not properly addressed.
>
>
> Thanks,
> Dieter
>
>
>
>    and monitor their *key performance data* of their interest on the
> When I tried to find the definition of the term "*key performance data*"
> I failed. The terminology section reads:
>
> 1.1 <https://tools.ietf.org/html/draft-lee-teas-actn-pm-telemetry-autonomics-16#section-1.1>. Terminology   Refer to [RFC8453 <https://tools.ietf.org/html/rfc8453>], [RFC7926 <https://tools.ietf.org/html/rfc7926>], and [RFC8309 <https://tools.ietf.org/html/rfc8309>] for the key terms used
>    in this document.
>
>
> The term "*key performance data*" is not defined in section 1.1 nor in
> the referenced RFSs!
> Frankly speaking, I have no clue what "*key performance data*" is.
>
> From: [email-masked] [mailto:[email-masked] <[email-masked]>]
> To: Daniele Ceccarelli <[email-masked]> <[email-masked]>; Satish Karunanithi <[email-masked]> <[email-masked]>; Leeyoung <[email-masked]> <[email-masked]>; Dhruv Dhody <[email-masked]> <[email-masked]>; Daniel King <[email-masked]> <[email-masked]>; Ricard Vilata <[email-masked]> <[email-masked]>; Ricard Vilalta <[email-masked]> <[email-masked]>
> Teas mailing [email-masked]://www.ietf.org/mailman/listinfo/teas
>
>
> [email-masked]

---

From: Leeyoung <[email-masked]>
Date: Fri, 24 May 2019 17:00:31 +0000

Hi Pavan,

Thanks for initiating this effort.

Here’s how the revision incorporated Dieter’s comment. Please see “YL>>” for each comment.

Thanks.
Young

>> snipped---------------------------------------------------------------------------------------
Hi Young,

  *   scaling intent (the description in section 4 is very poor and does not describe what scaling intent is all about),
  *   network autonomics
YL>> In Section 1.1 we added the following terms:
Key Performance Data: This refers to a set of data the customer is
   interested in monitoring for their instantiated VNs or TE-tunnels.
   Key performance data and key performance indicators are inter-
   exchangeable in this draft.

   Scaling: This refers to the network ability to re-shape its own
   resources. Scale out refers to improve network performance by
   increasing the allocated resources, while scale in refers to
   decrease the allocated resources, typically because the existing
   resources are unnecessary.

   Scaling Intent: To declare scaling conditions, scaling intent is
   used. Specifically, scaling intent refers to the intent expressed by
   the client that allows the client to program/configure conditions of
   their key performance data either for scaling out or scaling in.
   Various conditions can be set for scaling intent on either VN or TE-
   tunnel level.

   Network Autonomics: This refers to the network automation capability
   that allows client to initiate scaling intent mechanisms and
   provides the client with the status of the adjusted network
   resources based on the client's scaling intent in an automated
   fashion.

YL>> In the Introduction section, we added the following paragraph to explain how we used PM in this draft:
The term performance monitoring being used in this document is
   different from the term that has been used in transport networks for
   many years. Performance monitoring in this document refers to
   subscription and publication of streaming telemetry data.
   Subscription is initiated by the client (e.g., CNC) while
   publication is provided by the network (e.g., MDSC/PNC) based on the
   client's subscription. As the scope of performance monitoring in
   this document is telemetry data on the level of client's VN or TE-
   tunnel, the entity interfacing the client (e.g., MDSC) has to
   provide VN or TE-tunnel level information. This would require
   controller capability to derive VN or TE-tunnel level performance
   data based on lower-level data collected via PM counters in the
   Network Elements (NE). How the controller entity derives such
   customized level data (i.e., VN or TE-tunnel level) is out of the
   scope of this document.

YL>> As added in Section 1.1,
Scaling Intent: To declare scaling conditions, scaling intent is
   used. Specifically, scaling intent refers to the intent expressed by
   the client that allows the client to program/configure conditions of
   their key performance data either for scaling out or scaling in.
   Various conditions can be set for scaling intent on either VN or TE-
   tunnel level.

        scale-in.

YL>> At the end of Section 4, we have the following text:

        scale-in.

     . performance-type: performance metric type (e.g., one-way-delay,

        one-way-delay-min, one-way-delay-max, two-way-delay, two-way-

        delay-min, two-way-delay-max, utilized bandwidth, etc.)

     . threshold-value: the threshold value for a certain performance-

        type that triggers scale-in or scale-out.

     . scaling-operation-type: in case where scaling condition can be

        set with one or more performance types, then scaling-operation-

        type (AND, OR, MIN, MAX, etc.) is applied to these selected

        performance types and its threshold values.

     . Threshold-time: the duration for which the criteria must hold

        true.

     . Cooldown-time: the duration after a scaling action has been

        triggered, for which there will be no further operation.

       +-rw te-scaling-intent

       |  +-rw scale-in-intent

       |  +-rw scale-out-intent

YL>> Please see the previous comments.

Thanks,
Dieter

The abstract reads:

Abstract

   Virtual Networks (VN).

   of TE-tunnel as well as VN.
When I tried to find the definition of the term "key performance data" I failed. The terminology section reads:
1.1<https://tools.ietf.org/html/draft-lee-teas-actn-pm-telemetry-autonomics-16#section-1.1>. Terminology

   in this document.

YL>> Add this in Section 1.1:
Key Performance Data: This refers to a set of data the customer is
   interested in monitoring for their instantiated VNs or TE-tunnels.
   Key performance data and key performance indicators are inter-
   exchangeable in this draft.

From: Vishnu Pavan Beeram [mailto:[email-masked]]
Sent: Sunday, May 19, 2019 11:58 PM
To: Leeyoung <[email-masked]>; Beller, Dieter (Nokia - DE) <[email-masked]>
Cc: TEAS WG <[email-masked]>
Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-17.txt

Young,
Thanks for bringing the offline discussion to the list. Please discuss (on the list) how the changes in the latest revision address all of Dieter's comments.

Dieter,
Please do confirm on the list if there are no further open issues to discuss.

Regards,
-Pavan

On Wed, May 8, 2019 at 11:50 AM Leeyoung <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

Thanks & Best regards,

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, May 8, 2019 11:43 AM
To: Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Satish Karunanithi <[email-masked]<mailto:[email-masked]>>; Leeyoung <[email-masked]<mailto:[email-masked]>>; Dhruv Dhody <[email-masked]<mailto:[email-masked]>>; Daniel King <[email-masked]<mailto:[email-masked]>>; Ricard Vilata <[email-masked]<mailto:[email-masked]>>; Ricard Vilalta <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-17.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---------- Forwarded message ----------
From: "Beller, Dieter (Nokia - DE/Stuttgart)" <[email-masked]<mailto:[email-masked]>>
To: Leeyoung <[email-masked]<mailto:[email-masked]>>
Cc: TEAS WG Chairs <[email-masked]<mailto:[email-masked]>>, "King, Daniel" <[email-masked]<mailto:[email-masked]>>, Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Bcc:
Date: Thu, 25 Apr 2019 09:06:20 +0000
Subject: Re: [Teas] FW: New Version Notification for draft-lee-teas-actn-pm-telemetry-autonomics-16.txt
Hi Young,

        scale-in.

       +-rw te-scaling-intent

       |  +-rw scale-in-intent

       |  +-rw scale-out-intent

Thanks,
Dieter

The abstract reads:

Abstract

   Virtual Networks (VN).

   of TE-tunnel as well as VN.
When I tried to find the definition of the term "key performance data" I failed. The terminology section reads:
1.1<https://tools.ietf.org/html/draft-lee-teas-actn-pm-telemetry-autonomics-16#section-1.1>. Terminology

   in this document.

Thanks,
Dieter

Thanks,
Dieter

Hi Pavan and Lou,

Thanks & Best regards,

-----Original Message-----

Revision:  16

Pages:            29

Abstract:

   Virtual Networks (VN).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

Teas mailing list