Subject: [Teas] Discussion on modelling container TE tunnels in YANG

From: Tarek Saad <[email-masked]>
Date: Fri, 24 May 2019 21:13:16 +0000

The team on “to” list met to discuss this subject topic. Notes from today’s discussion (please add if I missed):

Name collision between configured and ephemeral tunnels:
  This is a generic problem in NMDA.
  How to handle collisions between configured and ephemeral (or auto-created) objects of a list, if the list uses the object (string based) name as the key?
  Both configured and ephemeral can have the same object name but they are different objects – how to avoid such collision.
 Proposed solution:
   Option 1:
   Use a special character for ephemeral names – e.g. such names always are prepended by special character “#”
   Make the special character changeable by configuration – the default can be “#” and user can change if they desire..
  Others?
AI (Italo): to send email to netmod group.

Container TE tunnels discussion:

  *   Container tunnels are grouping of tunnels between same 2 endpoints to share incoming traffic towards the egress
  *   Member tunnels of a container tunnel can be auto-created/deleted on-demand and controlled by thresholds specified under the container
  *   Some attributes may apply on the container tunnel and inherited down to member tunnels of the container
  *   Q: Should model allow member tunnel to override inherited attributes from container tunnel?
  *   Q: Should all auto-created member tunnels of a container have the same prefix/suffix – i..e prefix/suffix can be configurable

Regards,
Tarek

---

From: tom petch <[email-masked]>
Date: Sun, 26 May 2019 11:54:30 +0000

<inline>

----- Original Message -----
From: "Tarek Saad" <[email-masked]>
Sent: Friday, May 24, 2019 10:13 PM
Subject: [Teas] Discussion on modelling container TE tunnels in YANG

The team on “to” list met to discuss this subject topic. Notes from
today’s discussion (please add if I missed):

Name collision between configured and ephemeral tunnels:
  This is a generic problem in NMDA.
  How to handle collisions between configured and ephemeral (or
auto-created) objects of a list, if the list uses the object (string
based) name as the key?
  Both configured and ephemeral can have the same object name but they
are different objects – how to avoid such collision.
 Proposed solution:
   Option 1:
   Use a special character for ephemeral names – e.g. such names always
are prepended by special character “#”
   Make the special character changeable by configuration – the default
can be “#” and user can change if they desire..
  Others?

<tp.

Tarek

I am not sure if I understand the context here but if the ephemeral is a
YANG name, then the constraint is

Each identifier starts with an uppercase or lowercase ASCII
   letter or an underscore character, followed by zero or more ASCII
   letters, digits, underscore characters, hyphens, and dots.

No #, anywhere.

More generally, the IETF has made extremely limited use of special
characters to separate a class of identifiers, because names in the
IETF - host, domain, SMI etc - have all used an extremely limited set of
characters, a tradition that YANG has followed, wisely IMHO.  If you are
interfacing with humans, then limit yourself to what humans used to
seeing, aA to zZ, 0 to 9 and practically nothing else (7-bit ASCII is
far too complex:-).

X- has been used and I would suggest something more on those lines, but
it must be an either or; too often these semantic boundaries turn out to
be fuzzy and it all ends in confusion - I do not understand the context
enough to know what the future holds here.

On inheritance, below, the general principle, which users may expect, is
that the inherited object can acquire properties but not overwrite
inherited ones - but then YANG set out not to have inheritance or be
otherwise objec-oriented.

Tom Petch

  *   Container tunnels are grouping of tunnels between same 2 endpoints
to share incoming traffic towards the egress
  *   Member tunnels of a container tunnel can be auto-created/deleted
on-demand and controlled by thresholds specified under the container
  *   Some attributes may apply on the container tunnel and inherited
down to member tunnels of the container
  *   Q: Should model allow member tunnel to override inherited
attributes from container tunnel?
  *   Q: Should all auto-created member tunnels of a container have the
same prefix/suffix – i..e prefix/suffix can be configurable

Regards,
Tarek

------------------------------------------------------------------------
--------

> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>