Subject: [Teas] AD review: draft-ietf-teas-yang-te-types

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wed, 1 May 2019 21:14:11 +0000

Hi Authors,

I was just getting ready to start Last Call so as to have both this document and te-topo go together. Scanning the document, I noted the Security section is not sufficient. It needs to use the template of RFC8407 Guidelines for YANG Documents. Refer to draft-ietf-teas-yang-te-topo.

As soon as you update, I'll start Last Call.

Thanks-
Deborah

---

From: Tarek Saad <[email-masked]>
Date: Wed, 1 May 2019 22:42:47 +0000

Hi Deborah,

Thanks for your review. This I-D document only defines reusable groupings and common types (i.e. it does not define any writable, readable schema or rpc operations); hence, we’ve only included a summary indicating this in the security considerations section – similar to what’s in RFC6991.
The guideline(s) in RFC8407 are specific to module(s) that are introducing the writable schema and hence can introduce certain risk(s).
Please let us know if you still think what we have in the security section is not enough and we’ll try to update accordingly.

Regards,
Tarek

From: Teas <[email-masked]> on behalf of "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Wednesday, May 1, 2019 at 5:14 PM
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Teas] AD review: draft-ietf-teas-yang-te-types

Hi Authors,

As soon as you update, I’ll start Last Call.

Thanks-
Deborah

---

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Thu, 2 May 2019 11:36:42 +0000

Hi Tarek,

All current documents being processed need to use the template i.e. the first two paragraphs of the template are applicable. And add the sentence you have below regarding the modules if the remainder is not.

Deborah

Sent from my iPhone

On May 1, 2019, at 6:42 PM, Tarek Saad <[email-masked]<mailto:[email-masked]>> wrote:

Hi Deborah,

Regards,
Tarek

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of "BRUNGARD, DEBORAH A" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, May 1, 2019 at 5:14 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] AD review: draft-ietf-teas-yang-te-types

Hi Authors,

Thanks-
Deborah

---

From: Tarek Saad <[email-masked]>
Date: Thu, 2 May 2019 14:12:54 +0000

Thank you Deborah.

I just uploaded new version @ https://tools.ietf.org/html/draft-ietf-teas-yang-te-types-09 to address this. Please let us know if there are any other concerns.

Regards,
Tarek

From: "BRUNGARD, DEBORAH A" <[email-masked]>
Date: Thursday, May 2, 2019 at 7:36 AM
To: Tarek Saad <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [Teas] AD review: draft-ietf-teas-yang-te-types

Hi Tarek,

Deborah
Sent from my iPhone

Regards,
Tarek

Hi Authors,

Thanks-
Deborah