Subject: [Teas] WG I-D Status

From: Dhruv Dhody <[email-masked]>
Date: Wed, 22 Apr 2020 12:07:52 +0530

Hi Chairs, WG,

Please find the status -

==

A Yang Data Model for VN Operation (draft-ietf-teas-actn-vn-yang-08)
Updates:
  Mainly YANG guidelines update
  All earlier issues resolved
Next Steps:
  Yang Doctors Review

==

YANG models for VN/TE Performance Monitoring Telemetry and Scaling
Intent Autonomics (draft-ietf-teas-actn-pm-telemetry-autonomics-02)
Updates:
  Mainly YANG guidelines update
Next Step:
  Solicit more reviews

==

Traffic Engineering (TE) and Service Mapping Yang Model
(draft-ietf-teas-te-service-mapping-yang-03)
Updates:
  Mapping to Network Yang Models added (L3NM and L2NM)
  YANG guidelines update
Question to the WG:
  Is this the right place to include mapping to the network model as well?

==

Thanks!
Dhruv

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Wed, 22 Apr 2020 22:04:24 -0500

Dhruv, Hi!

Thanks for the status updates!
Please do send out a separate email to the list discussing the latest
changes to the TE Service-Mapping Yang model (mapping to the NM models).
Has there been any coordination/interaction with the authors of the L3/L2
NM models?

Regards,
-Pavan

On Wed, Apr 22, 2020 at 1:38 AM Dhruv Dhody <[email-masked]> wrote:

> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Dhruv Dhody <[email-masked]>
Date: Thu, 23 Apr 2020 08:43:46 +0530

Hi Pavan,

On Thu, Apr 23, 2020 at 8:34 AM Vishnu Pavan Beeram
<[email-masked]> wrote:
> Please do send out a separate email to the list discussing the latest changes to the TE Service-Mapping Yang model (mapping to the NM models).

I plan to do that after the interim meeting.

> Has there been any coordination/interaction with the authors of the L3/L2 NM models?

Yes, this has been done after discussions with Oscar/Samier and the
update has been reviewed by them.

Best regards & stay safe,
- Dhruv

---

From: tom petch <[email-masked]>
Date: Fri, 24 Apr 2020 10:33:51 +0000

From: Teas <[email-masked]> on behalf of Dhruv Dhody <[email-masked]>
Sent: 22 April 2020 07:37
To: TEAS WG Chairs; TEAS WG ([email-masked])
Subject: [Teas] WG I-D Status

Hi Chairs, WG,

Please find the status -

==

<tp>
Looking at -08 I struggle to see a resolution of some of the issues I raised 3Jul2019.

YANG deserves a reference in Introduction

YANG should be upper case, not yang

1,3 places te-types in teas-yang-te
The module imports it from teas-yang-te-types

identity  .. computatione-failed

disjoint I cannot find in RFC8453 - a reference would be helpful

ltp likewise

vn-id seems underspecified.  Has it semantics or is it just a number?  Are there restrictions on the range?  Many I-D create a raft of YANG types 
which seem to complicate the model - here I wonder if a vn-id  type would help.

Tom Petch

Next Steps:
  Yang Doctors Review

==

==

==

Thanks!
Dhruv