Subject: [Teas] TEAS WG Document Status Reports

From: Tarek Saad <[email-masked]>
Date: Tue, 21 Apr 2020 21:39:08 +0000

Hi WG,

Below is status reports for the below documents.

Regards,
Tarek (for the document co-authors)

1. draft-ietf-teas-yang-te-23
Current Status:

  *   Version -21 was reviewed by YANG Dr. and received comments

  *   Authors addressed all comments in version -23 (already uploaded).
  *   Team meeting regularly to address open issues – tracked on https://github.com/tsaad-dev/te/issues
  *   Will publish new version -24 before asking for WGLC
Open Issues:
  *   None.
Next Steps:.

  *   Authors will followup with YANG Dr. to make sure no further comments
  *   Will request a Working Group Last Call after completing the above

2. draft-ietf-teas-yang-rsvp-11
Current Status:

  *   Version -10 was reviewed by YANG Dr. and received comments

  *   Authors published version -12 which addressed all outstanding comments
  *   Authors followed up with YANG Dr. reviewer on closing comments
Open Issues:

  *   None
Next Steps:

  *   Proceed to WGLC

3. draft-ietf-teas-yang-rsvp-te-07
Current Status:

  *   Version -07 was reviewed by YANG Dr. and received comments
Open Issues:

  *   Authors working on addressing YANG Dr. comments
Next Steps:

  *   Folllow-up with YANG Dr. reviewer to close on comments
  *   Proceed to WGLC after addressing

4. draft-ietf-teas-yang-te-mpls
Current Status:

  *   Authors discussing augmentation of this module for MPLS-TP
  *   A new module and model is expected
Open Issues:

  *   Close on MPLS-TP modeling
Next Steps:

  *   Publish a new revision
  *   Ask for YANG Dr. review

---

From: tom petch <[email-masked]>
Date: Mon, 27 Apr 2020 16:29:11 +0000

From: Teas <[email-masked]> on behalf of Tarek Saad <tsaad=[email-masked]>
Sent: 21 April 2020 22:39

Regards,

<tp>
I think that there is quite a bit wrong with this I-D from an administrative viewpoint some of which may be more debatable than others.

It is VERRY  BIGGG which makes it hard to digest which for me is not helped by having 52 pages of uninterrupted tree diagram at the start (or is that intended to discourage anyone from going further?).  I see other authors taking two variations.  One is to put the entire module tree diagram at the end as an appendix.  The other is to include bite size chunks with sections of text.  You sort of do that s.3 but for me there is too little tree diagram in those sections.  Look for example at draft-ietf-opsawg-l3sm-l3nm which is only 122 pages but which I think gets a better balance in its section 6 of interspersing text with tree diagram and making it possible to follow.

Less debatably, 
- the prefix in the YANG does not match prefix in IANA Considerations.
- the Security Considerations are out of date..
- the device module would be better In a separate section
- s.4 lists [4872] twice

Tom Petch 

  *   None
Next Steps:

  *   Proceed to WGLC

  *   Publish a new revision

---

From: tom petch <[email-masked]>
Date: Mon, 27 Apr 2020 16:32:34 +0000

p.s.
got a couple of bounce messages to my last post, 
Igor Bryskin
Xufeng Liu

Tom Petch
(and now I am going to get more:-(

________________________________________
From: Teas <[email-masked]> on behalf of tom petch <[email-masked]>
Sent: 27 April 2020 17:29
To: Tarek Saad; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Teas] TEAS WG Document Status Reports  yang-te

---

From: tom petch <[email-masked]>
Date: Tue, 28 Apr 2020 10:40:25 +0000

<tp>
this I-D is BIGG so I expect that I will be noticing things for months to come so here are some more

Editors/Authors are listed in four places, top, bottom and both YANG modules and the lists differ

IANA Considerations has no Registrant Contact for the uri

tree diagram lacks reference to RFC8340

downstream-info
when origin-type != egress
Applicable to ingress LSP only
is a mismatch - when will allow transit

enum link-down
"Link-up flooding trigger"
mismatch

advertized-level-areas
" List of areas .. is advertised in"
mismatch, I think the list name is wrong
(stupid autocorrect:-)

tom petch

Regards,

<tp>

Less debatably,

Tom Petch

  *   None
Next Steps:

  *   Proceed to WGLC

  *   Publish a new revision

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas