Subject: [Teas] I-D Action: draft-ietf-teas-pce-native-ip-08.txt

From: [email-masked]
Date: Mon, 01 Jun 2020 19:25:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Traffic Engineering Architecture and Signaling WG of the IETF.

        Title           : PCE in Native IP Network
        Authors         : Aijun Wang
                          Boris Khasanov
                          Quintin Zhao
                          Huaimo Chen
	Filename        : draft-ietf-teas-pce-native-ip-08.txt
	Pages           : 13
	Date            : 2020-06-01

Abstract:
   This document defines the framework for traffic engineering within
   native IP network, using multiple BGP sessions strategy and PCE
   -based central control architecture.  The procedures described in
   this document are experimental.  The experiment is intended to enable
   research for the usage of PCE in native IP scenarios.  For this
   purpose, this document describe the Central Control Dynamic Routing
   (CCDR) framework and the PCEP extension is specified in
   [I-D.ietf-pce-pcep-extension-native-ip].

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-teas-pce-native-ip/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-teas-pce-native-ip-08
https://datatracker.ietf.org/doc/html/draft-ietf-teas-pce-native-ip-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-teas-pce-native-ip-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Aijun Wang" <[email-masked]>
Date: Tue, 2 Jun 2020 10:33:48 +0800

Hi, Lou and Dhruv:

The update version addresses mainly the comments from Dhruv. Please review
it.
Further comments and suggestions are also welcome
 
If no other comments, can we ship this document out of the WG then?

Best Regards.

Aijun Wang
China Telecom

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 代表
[email-masked]
发送时间: 2020年6月2日 10:25
收件人: [email-masked]
抄送: [email-masked]
主题: [Teas] I-D Action: draft-ietf-teas-pce-native-ip-08.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the Traffic Engineering Architecture and
Signaling WG of the IETF.

Abstract:

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 2 Jun 2020 16:00:16 +0530

Hi Aijun,

Thank you for handling most of my technical comments.

Non-blocking note - I would encourage the authors to keep thinking
about improving the deployment consideration section. I just noted
some points from the top of my head (it was not meant to be an
exhaustive list), I hope it could help you to think about adding more
clarity on the scope of the experiment, provide high-level detail and
maybe point to the PCEP extension for actual details.

Thanks!
Dhruv

---

From: "Aijun Wang" <[email-masked]>
Date: Wed, 3 Jun 2020 09:21:43 +0800

Hi, Dhruv:

We will update the deployment consideration section continuously in the following stages. 
And we can also keep in mind that the existing mechanisms described in RFCs about PCE and their application in MPLS network can be reused in the application of PCE in native IP network.

Adding the central control to the existing network is the trend of network evolution. CCDR solution described in this document can improve the E2E performance of native IP network that controlled by one administrator, and reuse the capabilities of existing deployed network devices in large extend. 

Thanks again for your comments and suggestions on this draft. We can discuss more on the protocol extension draft later.

Best Regards

Aijun Wang
China Telecom

> -----邮件原件-----
> 发件人: Dhruv Dhody [mailto:[email-masked]]
> 发送时间: 2020年6月2日 18:30
> 收件人: Aijun Wang <[email-masked]>
> 抄送: Lou Berger <[email-masked]>; TEAS WG ([email-masked]) <[email-masked]>
> 主题: Re: [Teas] I-D Action: draft-ietf-teas-pce-native-ip-08.txt
> 
> Hi Aijun,
> 
> Non-blocking note - I would encourage the authors to keep thinking about
> improving the deployment consideration section. I just noted some points
> from the top of my head (it was not meant to be an exhaustive list), I hope it
> could help you to think about adding more clarity on the scope of the
> experiment, provide high-level detail and maybe point to the PCEP extension
> for actual details.
> 
> Thanks!
> Dhruv
> 
> 
> > The update version addresses mainly the comments from Dhruv. Please
> > review it.
> > Please note that it may take a couple of minutes from the time of
> > submission until the htmlized version and diff are available at tools.ietf.org.
> >

---

From: Lou Berger <[email-masked]>
Date: Sun, 7 Jun 2020 17:39:28 -0400

Authors,

     Please let the WG know when you have your final revision ready for 
submission to the IESG.  Note, please ensure the idnits issues (see 
https://tools.ietf.org/idnits?url=https://tools.ietf.org/id/draft-ietf-teas-pce-native-ip-08.txt) 
are corrected in this final version.

Lou

---

From: "Aijun Wang" <[email-masked]>
Date: Mon, 8 Jun 2020 09:50:16 +0800

Hi, Lou:

I have updated the draft to correct the idnits issues that raised by the idnits tools:
1) Use the reference in the abstract part------use the name of mentioned draft directly.
2) Editorial nits for one reference----correct it.

It is ready now for the submission to the IESG.

Thanks in advance for your efforts.

Best Regards

Aijun Wang
China Telecom

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Lou
> Berger
> 发送时间: 2020年6月8日 5:39
> 收件人: Aijun Wang <[email-masked]>; 'Dhruv Dhody'
> <[email-masked]>
> 抄送: 'TEAS WG' <[email-masked]>
> 主题: Re: [Teas] 答复: I-D Action: draft-ietf-teas-pce-native-ip-08.txt
> 
> Authors,
> 
> > And we can also keep in mind that the existing mechanisms described in
> RFCs about PCE and their application in MPLS network can be reused in the
> application of PCE in native IP network.
> >
> > Adding the central control to the existing network is the trend of network
> evolution. CCDR solution described in this document can improve the E2E
> performance of native IP network that controlled by one administrator, and
> reuse the capabilities of existing deployed network devices in large extend.
> >
> > Thanks again for your comments and suggestions on this draft. We can
> discuss more on the protocol extension draft later.
> >
> >
> > Best Regards
> >
> > Aijun Wang
> > China Telecom
> >
> >> -----邮件原件-----