Subject: [Teas] [non-zip]RE: A question about draft-ietf-teas-te-service-mapping-yang

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 14 Apr 2021 01:26:59 +0000

Hi Adrian,

I understood what’s difference between what you and I see.

I don’t object the following Scenario 1) and 3) at all, but I have seen Scenario 2) with te-service-mapping-yang as a first scenario, once VN service emerges/is exposed to consumer.

If this is not general requirement for providers like us, we only use the current version of te-service-mapping-yang as LxSM augmentation even if LxSM augmentation is omitted in the future version.

Scenario 1)

Consumer

              VPN' as a service

------------+--------------+----LxSM-------

              | VPN'instance |     LxNM

Provider     +--------------+     MDSC

              |  VN instance |

              +--------------+

Scenario 2)

Consumer

              VPN' as a service

-----------+--------+---+--------+--LxSM’--MDSC-

             |  VPN    | + |    VN   |   LxNM

Provider   |instance|    |instance|

             +--------+    +--------+

Scenario 3)

               VPN' as a service

Consumer      +--------------+    LxSM

                | VPN'instance |    LxNM

-------------+--------------+----MDSC--------

                |  VN instance |

Provider      +--------------+

[AF2] When the VN is provided as a service to the consumer, the operation of the VN belongs to the consumer.

If the consumer decides to operate a VPN over the VN then the consumer is responsible for realising the VPN over the VN.

That means that the consumer runs the VN Orchestrator. In this case, the LxNM is present in the consumer's management space, and it is augmented by the mapping model to coordinate with the resources in the VN. But the LxSM is still unaware of the tunnels and network resources.

[AF2] I think I still disagree ☹

When the VN is exposed as a service, it is the customer's job to manage that VN. In particular, it is the customer's job to orchestrate the VN to support the VPN service.

The LxSM is how the customer configures and requests a VPN service.

The LxNM is how the orchestrator operates the network to support the VPN service.

That means the LxNM is used by the VN orchestrator to manage the VN.

In my opinion, that means that the LxSM never has knowledge of the underlying network resources, but the LxNM does have that knowledge.

[KO3] I can’t still understand why the consumer run the VN Orchestrator in cases of Scenario 2) and 3). What do you mean “the operation of the VN”, “manage that VN” and “orchestrate the VN”? If you are saying that the consumer create a different VN on top of the provided VN using VN orchestrator, I agree. But, if the case that the consumer just uses the provided VN like provided VPN, the consumer doesn’t need the VN Orchestrator. Am I something misunderstanding?

Thanks,

Kenichi

-----Original Message-----
From: Adrian Farrel <[email-masked]>
Sent: Tuesday, April 13, 2021 6:46 PM
To: 大垣 健一 <[email-masked]>; 'Oscar González de Dios' <[email-masked]>; 'Dhruv Dhody' <[email-masked]>
Cc: [email-masked]; 'TEAS WG' <[email-masked]>; 宮坂 拓也 <[email-masked]>; 福井 良平 <[email-masked]>
Subject: RE: [Teas] A question about draft-ietf-teas-te-service-mapping-yang

Hello again 😊

> But

> what was NOT included in the draft is any detail on a) how the network

> is “traffic engineered” b) which charateristics must this traffic

> engineering have and c) which traffic of the VPN goes into which

> tunnel…. One of the main reasons to leave that out was to avoid the “boiling the ocean”

> problem and limit the scope to opsawg. TE… would be dealt of course in

> TEAS ☺

OK, and those three objectives (a, b, c) are reasonable things to put into the network model. Just not, IMHO, into the customer service model.

[KO] As Adrian described below, when VN is a service and our customer uses the VN as a service, why is the VN put into the network model reasonable? Am I something misunderstanding?

"In this case, in my opinion, the cooked topology delivered to the customer is in the form of a service already. It might be a VN or it might be a set of connectivity services (i.e., tunnels). In this case, the delivery of a service over a service is highly ambiguous and I don’t think it falls within the operator’s capabilities to achieve it. The cooked topology is for the customer to use as they see fit."

[AF] I think the key here is to understand the layering. So when you say *the* network model I think there may be some ambiguity.

I see...

VPN

------- LxSM model -- Customer ask for a VPN operated over the VN

------- LxNM model -- VN orchestrator plans and provisions the VPN over the VN VN

------- VN service model -- Customer asks for a VN over the operator network

------- VN network model -- Operator's network orchestrator provisions the VN

[KO2] If this layering is correct, meaning VN as a service is not commonly used by an end-customer like our current VPN users, I agree.

In this case, the LxNM is operating in the customer's management space. The operator is unaware of the VPN and is unaware of how the VN is being used by the customer.

We must be careful to not think that the LxSM is the interface between customer and operator. It is the interface between consumer and provider which, in this case, are both within the customer's control.

[KO2] What do you mean by "are both within the customer's control"? What "are both within the customer's control"

[AF2] When the VN is provided as a service to the consumer, the operation of the VN belongs to the consumer.

If the consumer decides to operate a VPN over the VN then the consumer is responsible for realising the VPN over the VN.

That means that the consumer runs the VN Orchestrator. In this case, the LxNM is present in the consumer's management space, and it is augmented by the mapping model to coordinate with the resources in the VN. But the LxSM is still unaware of the tunnels and network resources.

[AF2]Talking to someone else yesterday, they suggested that the VN may be created by the operator to enable services for a customer, but that the VN is not exposed to the customer. It is a way for the operator to "partition" their network and provide service guarantees to the customer.

I think this is OK, but in this case the consumer is entirely unaware of the VN. When the consumer asks for a VPN service they do not see any difference if there is a VN or no VN. That is, the LxSM model is not augmented by the mapping model.

The operator may need features to map the VPN service onto the VN, and this shows up in the LxNM via the mapping model.

>>> Now, perhaps we should consider the ACTN use case where a VN has

>>> been built for and delivered to the customer. In this case, the

>>> question arises as to whether the LxVPN is supported over the VN or

>>> supported over the provider's network using the resources of the VN.

>>> In my view of this, the LxVPN is supported over the VN: it is the

>>> VN's management system that realises the VPN using TE tunnels in the

>>> VN, and the VN with it's management system and TE tunnels is treated

>>> just like a real network.

[KO] I think this might be technically correct, but VN service and VN's management system have never commercially existed yet, and there are only LxVPN's management systems. Under this situation, operators should desire the existing LxVPN's management systems to utilize/map VN resources for the existing LxVPN service, when the VN service has emerged. Thus, I believe te-service-mapping-yang should exist.

[AF] I'm having trouble following this.

I think you are saying that (today) no one sells a VN, and (in consequence) there is no such thing as a management system for a VN. I can believe that.

But then you say that it is important to be able to map the VPN onto the VN resources. This I can't understand because a VN is a service, and you have said that service doesn't exist. In particular, the customer will not be aware of the VN resources because they are not aware of the VN service.

[KO2] You are right. I just indicated a possible next step, not current situation.

I may require a shortcut solution for a) and A,B,C,D), once VN service with actn-vn-yang , for example, emerges.

As you wrote, VN service should exist behind LxNM optimally and not be exposed to any end-customer. However, once we decide that VN service is exposed to an end-customer like a large enterprise user, this becomes a case.

[AF2] I think I still disagree ☹

When the VN is exposed as a service, it is the customer's job to manage that VN. In particular, it is the customer's job to orchestrate the VN to support the VPN service.

The LxSM is how the customer configures and requests a VPN service.

The LxNM is how the orchestrator operates the network to support the VPN service.

That means the LxNM is used by the VN orchestrator to manage the VN.

In my opinion, that means that the LxSM never has knowledge of the underlying network resources, but the LxNM does have that knowledge.

Best,

Adrian

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 15 Apr 2021 21:18:48 +0100

Thanks for continuing this discussion, Kenichi. I believe it is helping me to understand the differences as well.

What I find very significant is that in all your figures you place the VN insider the Provider space.

In the case of “VN as a service” (Yes, we agree that no one is offering this as a service to external customers yet, but perhaps it is offered as a service to other divisions of the same company? In that case, the “consumer” should be treated as a separate administrative organisation.) the VN is *realised* inside the Provider space, but it is handed over to the Consumer as a separate network that the Consumer operates. I would draw…

         +----------+

         | VPN as a | CNC-1 (Controller for VPN)

         | service  |  :

         +----------+-CMI-LxSM-VPN service request-----

         |          |  :

         |   VPN    | MDSC-1 VPN Orchestrator (LxNM)

         | instance |  : 

         |          |  :       CNC-2 (Controller for VN)

         |          |  :         :

Consumer +----------+-MPI-------CMI VN service request-

         |          |  :         : 

---------|   VN     | PNC-1 (VN) :

         | instance |          MDSC-2 VN Orchestrator

         |          |            :  

Provider +----------+-----------MPI--------------------

         | Physical |            : 

         | Network  |          PNC-2 (Phys network)

         +----------+

A bit complicated 😊 But this is the consequence of providing a service on top of another service

In the other situations, where the VN is entirely inside the Provider network, the Consumer is actually unaware that there is a VN. The Consumer just asks for a VPN service to be provided by the Provider. If the Provider chooses to build a VN to support the Consumer’s VPN that is a private matter for the Provider – It is a bit like the Provider deciding to make some network slices to support different customer requests.

Essentially, where a VN is used, this figure remains exactly the same except that the line separating the Consumer and the Provider can be moved upwards when the VN is hidden from the Consumer.

Of course, an implementation may bundle MDSC-1 with CNC-2 into a single code component. Similarly, PNC-1 and MDSC-2 may be bundled together.

Best,

Adrian

From: Ogaki, Kenichi <[email-masked]> 
Sent: 14 April 2021 02:27
To: [email-masked]; 'Oscar González de Dios' <[email-masked]>; 'Dhruv Dhody' <[email-masked]>
Cc: [email-masked]; 'TEAS WG' <[email-masked]>; [email-masked]; [email-masked]
Subject: [non-zip]RE: [Teas] A question about draft-ietf-teas-te-service-mapping-yang

Hi Adrian,

 

Scenario 1) 

Consumer

              VPN' as a service

              | VPN'instance |     LxNM

              |  VN instance |

              +--------------+

Scenario 2)

Consumer

              VPN' as a service

             |  VPN    | + |    VN   |   LxNM

             +--------+    +--------+

Scenario 3)

               VPN' as a service

                | VPN'instance |    LxNM

                |  VN instance |

 

Thanks,

Kenichi

-----Original Message-----
From: Adrian Farrel <[email-masked] <mailto:[email-masked]> > 
Sent: Tuesday, April 13, 2021 6:46 PM
To: 大垣 健一 <[email-masked] <mailto:[email-masked]> >; 'Oscar González de Dios' <[email-masked] <mailto:[email-masked]> >; 'Dhruv Dhody' <[email-masked] <mailto:[email-masked]> >
Cc: [email-masked] <mailto:[email-masked]> ; 'TEAS WG' <[email-masked] <mailto:[email-masked]> >; 宮坂 拓也 <[email-masked] <mailto:[email-masked]> >; 福井 良平 <[email-masked] <mailto:[email-masked]> >
Subject: RE: [Teas] A question about draft-ietf-teas-te-service-mapping-yang

Hello again 😊

I see...

VPN

Best,

Adrian

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 16 Apr 2021 02:44:22 +0000

Hi Adrian,

Thank you for continuous discussion.

In the case of “VN as a service” (Yes, we agree that no one is offering this as a service to external customers yet, but perhaps it is offered as a service to other divisions of the same company? In that case, the “consumer” should be treated as a separate administrative organisation.) the VN is *realised* inside the Provider space, but it is handed over to the Consumer as a separate network that the Consumer operates.

[KO4] Yes, I believe this is the first usecase.

[KO4] This is my scenario 1). I agree this should be solved the extension/augmentation of the current LxSM with additional characteristics constraints as you draw.
The question is why my scenario 2) re-drawn below is not allowed?
Especially, once VN as a service is preliminary offered inside a Provider like us, the VPN service division somewhat wants to control and be aware how the underlying network is characterized even if this is abstracted.
Even now, our account SE is commonly requested a kind of affinity as Oscar wrote from our customer, and puts them into the provisioning order as possible, also sometimes is required to explain how network is composed to the customer.
When a provider begins to commit the characteristics provided by VN, this should escalate. This may be only Japanese customer’s case…

                                  +----------+
         CNC-1 (Controller for VN)| VPN'as a | CNC-1 (Controller for VPN)
            :                     | service  |  :
            :                     +----------+-CMI-LxSM-VPN service request---
                                                  w/ te-service-mapping
            :                     |          |  :
            :                     |   VPN    | MDSC-1 VPN Orchestrator (LxNM)
            :                     | instance |  :
            :                     |          |  :
            :                     |          |  :
Consumer --CMI VN service request-+----------+-MPI-------
            :                     |          |  :
---------   :                     |   VN     | PNC-1 (VN)
          MDSC-2 VN Orchestrator  | instance |
            :                     |          |
Provider --MPI--------------------+----------+---------
            :                     | Physical |
          PNC-2 (Phys network)    | Network  |
                                  +----------+

Thanks,
Kenichi

From: Adrian Farrel <[email-masked]>
Sent: Friday, April 16, 2021 5:19 AM
To: 大垣 健一 <[email-masked]>; 'Oscar González de Dios' <[email-masked]>; 'Dhruv Dhody' <[email-masked]>
Cc: [email-masked]; 'TEAS WG' <[email-masked]>; 宮坂 拓也 <[email-masked]>; 福井 良平 <[email-masked]>
Subject: RE: [non-zip]RE: [Teas] A question about draft-ietf-teas-te-service-mapping-yang

         +----------+

         | service  |  :

         |          |  :

         | instance |  :

         |          |  :         :

         |          |  :         :

         |          |            :

         | Physical |            :

         +----------+

Best,
Adrian

Hi Adrian,

Scenario 1)

Consumer

              VPN' as a service

              | VPN'instance |     LxNM

              |  VN instance |

              +--------------+

Scenario 2)

Consumer

              VPN' as a service

             |  VPN    | + |    VN   |   LxNM

             +--------+    +--------+

Scenario 3)

               VPN' as a service

                | VPN'instance |    LxNM

                |  VN instance |

Thanks,

Kenichi

-----Original Message-----
From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, April 13, 2021 6:46 PM
To: 大垣 健一 <[email-masked]<mailto:[email-masked]>>; 'Oscar González de Dios' <[email-masked]<mailto:[email-masked]>>; 'Dhruv Dhody' <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; 'TEAS WG' <[email-masked]<mailto:[email-masked]>>; 宮坂 拓也 <[email-masked]<mailto:[email-masked]>>; 福井 良平 <[email-masked]<mailto:[email-masked]>>
Subject: RE: [Teas] A question about draft-ietf-teas-te-service-mapping-yang

Hello again 😊

I see...

VPN

Best,

Adrian