Subject: [Teas] A slice is not an enhanced VPN [Was: draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)]

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 23 May 2021 19:10:16 +0100

Hi Med,

As I work through the latest revision, I came back to this email to try to clarify this. 

I re-read 6.3 to see whether this document was responsible for supporting the misunderstanding you say is recurrent. I don’t think it is: 6.3 is the only place in the document that mentions enhanced VPNs, and it does so in a way that is suggesting that this is just an architectural approach. That means it feels out of place to put a sentence in 6.3.

But we can include something like this in the general definition and specification of what a slice is.

I’m a bit wary of saying “By the way, a slice is not a pipe” [1] because sometimes this can be a distraction, and it is very hard to make a complete set of things that are not a network slice.

But if you’d like to suggest a sentence and a home for it, we can fold it in.

Best,

Adrian

[1] https://en.wikipedia.org/wiki/The_Treachery_of_Images

 

From: [email-masked] <[email-masked]> 
Sent: 05 May 2021 14:22
To: [email-masked]; [email-masked]
Subject: RE: [Teas] draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)

Re-,

I agree with the scope but my comment is actually not to dig into more technical realization details or call for favorite options to implement a slice (all that is deployment-specific in my mind). The comment is to clarify the recurrent “misunderstanding” that a slice is a VPN (or a VPN+).

I’m confident this message can be conveyed in one short sentence.   

Cheers,

Med

De : Teas [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : mercredi 5 mai 2021 15:00
À : BOUCADAIR Mohamed TGI/OLN <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> 
Objet : Re: [Teas] draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)

Hi Med,

I’m currently working up some text to provide a definition of a network slice service and to clarify the endpoint definitions.

This text will be based on material that was on the list some while back.

I don’t think this document should dig too deep into VPN+ or ACTN. An enhanced VPN is not identical to a slice, and an CAN VN is not identical to a slice. However, ACTN and VPN+ both provide ways to realise/deliver network slices. I think that applicability statements should explain what can and can’t be done using those technologies, while this document should just note that they are possible architectural approaches.

There are, of course, very many ways to achieve network slicing dependent on the underlying technology. We need to be careful about this document:

*	Blessing any one approach
*	Trying to catalogue all possible approaches.

Other documents can try to establish consensus for particular approaches.

Best,

Adrian

From: [email-masked] <mailto:[email-masked]>  <[email-masked] <mailto:[email-masked]> > 
Sent: 05 May 2021 13:39
To: [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Subject: draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+) 

Adrian, 

I wonder whether you are planning to add some text to include the clarification discussed below. 

Thank you. 

Cheers,

Med

De : Teas [mailto:[email-masked]] De la part de [email-masked] <mailto:[email-masked]> 
Envoyé : mercredi 3 mars 2021 14:28
À : [email-masked] <mailto:[email-masked]> ; [email-masked] <mailto:[email-masked]> 
Objet : [Teas] Network Slice vs. VPN(+) RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Hi Adrian, all, 

Picking this item from the message below as I think this is a point that is worth to be clarified and discussed in the framework/definition document. We need to explain the differences between the two concepts. There are some “hints” in the framework I-D, but we need to be explicit. 

VPN(+) is no more than an IETF technology to implement a network slice. As such, a network slice can be implemented without relying upon a VPN/VPN+. That’s deployment-specific. An example of possible implementations (with IETF technologies) would be to define PDBs + SFCs or running a dedicated MT-IGP instance (with optimized tweaking such as exclude links exposing long delays) + resource-based access, and so on. 

Ah, let’s not forget that a network slice as defined in the definition I-D is not only about connectivity.

BTW, we do still have some inconsistencies between the documents: 

*	The definition I-D acks that an IETF network slice is not only about connectivity. 
*	The framework I-D seems to be more connectivity-centric. 

We need to fix this as well. 

Cheers,

Med

De : Teas [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : jeudi 25 février 2021 11:52
À : 'Young Lee' <[email-masked] <mailto:[email-masked]> >; 'Luis M. Contreras' <[email-masked] <mailto:[email-masked]> >
Cc : 'Joel M. Halpern' <[email-masked] <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]> ; 'Eric Gray' <[email-masked] <mailto:[email-masked]> >; 'John E Drake' <jdrake=[email-masked] <mailto:jdrake=[email-masked]> >; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked] <mailto:[email-masked]> >; BOUCADAIR Mohamed TGI/OLN <[email-masked] <mailto:[email-masked]> >
Objet : Re: [Teas] network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

[...]

But my opinion of all of this is coloured by thinking about enhanced VPNs (VPN+) [3] and IETF network slices as the same thing.

[...]

[1] https://mailarchive.ietf.org/arch/msg/teas/ibycGzi5cxJUJSvRxm9OsQdDqn8/

[2] RFC 4026

[3] draft-ietf-teas-enhanced-vpn

_________________________________________________________________________________________________________________________
 
Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
 
This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.
_________________________________________________________________________________________________________________________
 
Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
 
This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.
_________________________________________________________________________________________________________________________
 
Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
 
This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 26 May 2021 08:54:58 +0000

Hi Adrian,

:-)

What actually prompted me was your message below “But my opinion of all of this is coloured by thinking about enhanced VPNs (VPN+) [3] and IETF network slices as the same thing.” and this text in the draft:

   An enhanced VPN can be used to provide enhanced connectivity services
   between customer sites (a concept similar to an IETF Network Slice)
                          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   and can be used to create the infrastructure to underpin network
   slicing.

I would delete part of the text identified above + update the generic definition to focus on slicing specifics.

Thanks.

Cheers,
Med

De : Teas [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : dimanche 23 mai 2021 20:10
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]>
Cc : [email-masked]
Objet : [Teas] A slice is not an enhanced VPN [Was: draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)]

Hi Med,

Best,
Adrian

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: 05 May 2021 14:22
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE: [Teas] draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)

Re-,

Cheers,
Med

De : Teas [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : mercredi 5 mai 2021 15:00
À : BOUCADAIR Mohamed TGI/OLN <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Objet : Re: [Teas] draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)

Hi Med,

There are, of course, very many ways to achieve network slicing dependent on the underlying technology. We need to be careful about this document:
-          Blessing any one approach
-          Trying to catalogue all possible approaches.
Other documents can try to establish consensus for particular approaches.

Best,
Adrian

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: 05 May 2021 13:39
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: draft-ietf-teas-ietf-network-slices: Network Slice vs. VPN(+)

Adrian,

Thank you.

Cheers,
Med

De : Teas [mailto:[email-masked]] De la part de [email-masked]<mailto:[email-masked]>
Envoyé : mercredi 3 mars 2021 14:28
À : [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Objet : [Teas] Network Slice vs. VPN(+) RE: network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

Hi Adrian, all,

Cheers,
Med

De : Teas [mailto:[email-masked]] De la part de Adrian Farrel
Envoyé : jeudi 25 février 2021 11:52
À : 'Young Lee' <[email-masked]<mailto:[email-masked]>>; 'Luis M. Contreras' <[email-masked]<mailto:[email-masked]>>
Cc : 'Joel M. Halpern' <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; 'Eric Gray' <[email-masked]<mailto:[email-masked]>>; 'John E Drake' <jdrake=[email-masked]<mailto:jdrake=[email-masked]>>; 'Rokui, Reza (Nokia - CA/Ottawa)' <[email-masked]<mailto:[email-masked]>>; BOUCADAIR Mohamed TGI/OLN <[email-masked]<mailto:[email-masked]>>
Objet : Re: [Teas] network Slice Endpoint in draft-ietf-teas-ietf-network-slice-definition-00

[...]

[...]