Subject: Re: [Teas] SFC and slicing

From: Kiran Makhijani <[email-masked]>
Date: Tue, 1 Jun 2021 17:21:31 -0700

Hi Daniele,
Apologies. I am asking a bit for a late clarification.  There are 2 ways to
read the figure you had attached earlier. I was not sure which one is
correct -

(a) A 5G-style E2E slice that has 3 parts (RAN, transport and core): In
this case cloud-orchestrator and transport-controller should be unrelated.
I mean the transport (-IETF) slice should not be concerned with SFs in
core-slice.
or,
(b) It has 2 parts (RAN and the rest): then the cloud orchestrator is
acting as a resource manager.  It could interact with the transport
controller directly or through the OSS. Both should be possible.

Ideally, SFs should be controlled from the NSC, since we consider it to be
both resource and connectivity aware. I would expect NSC to discover such
capabilities from underlying infrastructure and assign SFs appropriately.
This gives NSC better control & monitoring for service assurance. But then,
using NFV which has its own resource manager as an example, it is easier
for NSC to coordinate with a resource manager (maybe another type of SBI)
for SF changes. If  OSS control SFs, then they get pinned into the
infrastructure and there is no abstraction.

Just thinking out loud that there are several possibilities, and difficult
to capture everything in the current document.

-Kiran

On Mon, May 31, 2021 at 4:35 AM Daniele Ceccarelli <daniele.ceccarelli=
[email-masked]> wrote:

> Hi Igor,
>
>
>
> I don’t disagree with you on that. I agree on the fact that the access
> points are fixed and TE and SF can’t be solved separately, my point is that
> I think it could make more sense to retrieve information about TE from the
> SBI (from the network) and about SF from the NBI (i.e. from other
> components dealing with SFs, e.g. the cloud orchestrator)…and then used
> together in conjunction.
>
>
>
> I’m only questioning if it’s worth getting also the SF from the transport
> controller, forcing it to deal with a whole new set of information which is
> already available in the OSS.
>
>
>
> Cheers,
> Daniele
>
>
>
>
>
> *From:* Igor Bryskin <i_bryskin=[email-masked]>
> *Sent:* den 27 maj 2021 16:05
> *To:* Jeff Tantsura <[email-masked]>; [email-masked]; Adrian
> Farrel <[email-masked]>; Daniele Ceccarelli <
> [email-masked]>
> *Subject:* Re: [Teas] SFC and slicing
>
>
>
> Daniele,
>
>
>
> But location of  IETF slice access points is (likely to be) fixed, while
> location of SFs in required SFC may be not. My point is that you can not
> reduce SF-aware TE problem into two separate TE and SF awareness problems
> that could be solved separately in separate time frames with first
> addressing TE (connectivity) and some time later adding somehow selection
> of SF locations. As Jeff pointed out, this would work short term for
> pragmatic reasons (to show that something got done). Long term, I believe,
> SF aware TE should be addressed holistically.
>
>
>
> Cheers,
>
> Igor
>
>
>
> On Thursday, May 27, 2021, 05:13:02 AM EDT, Daniele Ceccarelli <
> daniele.ceccarelli=[email-masked]> wrote:
>
>
>
>
>
> That makes sense, an probably “awareness” is the key word here.
>
>
>
> In reply to Igor’s comment: I meant exactly the opposite, most of the
> network/service functions will be virtualized with the possibility to
> deploy them in a wide variety of sites (antenna site, hub site, central
> office, regional data centers etc.) and finding the best compromise between
> SF location and TE characteristics is absolutely a valid use case.
>
>
>
> The question I’m asking is whether it makes sense to add complexity to the
> transport orchestrator asking it to retrieve that information from the
> network or it is an info that can be passed to it as input.
>
> An example of request to the transport orchestrator could be:
>
> “I need to create a service with non fixed end points with these given
> SLO, the sites where I can place my workload are A, B, C and D”. When the
> optimal path is identified the chosen sites are returned to the cloud
> orchestrator to deploy the network functions. In this case the PCE has all
> the inputs to perform the dual optimization without duplicating into the
> transport orchestrator all the functionalities already present in other
> components of the solution.
>
>
>
> Both approaches would work from a technical perspective, it’s just a
> matter of understanding what makes more sense.
>
>
>
> Cheers,
> Daniele
>
>
>
>
>
> *From:* Jeff Tantsura <[email-masked]>
> *Sent:* den 26 maj 2021 20:51
> *To:* [email-masked]; Adrian Farrel <[email-masked]>; Daniele
> Ceccarelli <[email-masked]>; Igor Bryskin <
> [email-masked]>
> *Subject:* Re: [Teas] SFC and slicing
>
>
>
> Daniele is correct wrt today’ deployments.
>
> I do think, similarly to Igor’ comments below,
> looking at further disaggregation (X-haul) and moving towards the edge,
> where location and proximity of SFs  becomes crucial to be able to provide
> optimized workload placement while still meeting the SLOs requested, common
> view of transport and service topologies would be needed and eventually
> would be interdependent.
>
> Pragmatically (and in line with Adrian proposal) - I think we should
> continue progressing connectivity centric work independently, while in
> parallel working on  SF awareness  and  end2end workflows/data-models.
>
>
>
> Cheers,
>
> Jeff
>
> On May 26, 2021, 10:43 AM -0700, Igor Bryskin <
> i_bryskin=[email-masked]>, wrote:
>
> Hi Daniele,
>
>
>
> If I understood you correctly, you believe that SFs must be visible only
> to the orchestrator (entity responsable for the e2e service) and should not
> be considered in the IETF slices.
>
>
>
> I have two problems with this:
>
> 1) scalability: the number of slices that need to be stitched together
> would depend on number of SFs in the SFC;
>
> 2) The very choice of SF location could be optimized depending on SLOs
> between adjacent SFs. You seem to believe that SF location is always fixed.
> I heard people talking about duel optimization path computation algorithms
> selecting best possible compromise between SF location and TE
> characteristics of transport connecting them into chains.
>
>
>
> Cheers,
>
> Igor
>
>
>
> On Wednesday, May 26, 2021, 11:58:40 AM EDT, Daniele Ceccarelli <
> daniele.ceccarelli=[email-masked]> wrote:
>
>
>
>
>
> Hi Adrian, Igor,
>
>
>
> I was trying to think where this augmented (meaning: connectivity +
> service functions) model would be used.
>
>
>
> The architecture that seems to be the most widely adopted is the one shown
> in picture below. I would say that the NSC is a functionality of the
> transport orchestrator (pass me the term transport), but that component in
> many cases, if not all, will only be capable to see connectivity and not
> service functions, which most likely will be managed by the cloud
> orchestrator…hence I see it hardly applicable to interface B.
>
> At the same time I don’t think this model would be used over interface A,
> there I would see something more TMF like.
>
>
>
> What’s your opinion? Where do you think model would fit? A? B? Both?
>
>
>
>
>
>
> BR
> Daniele
>
>
>
> *From:* Teas <[email-masked]> *On Behalf Of* Igor Bryskin
> *Sent:* den 24 maj 2021 16:45
> *To:* [email-masked]; Adrian Farrel <[email-masked]>
> *Subject:* Re: [Teas] SFC and slicing
>
>
>
> Right. I suppose we need to hear from operators. Specifically, focusing on
> the delay SLO I'd like to ask:
>
> 1. Is it possible that requested SFs in an SFC need to be time
> synchronized in a client specific way?
>
> 2. If e2e delays D, how the network is supposed to spend the delay budget
> between SFs in the requested SFC:
>
> a) arbitrarily;
>
> b) evenly.
>
> c) in proportion specified by the client
>
>
>
>
>
> Cheers,
>
> Igor
>
>
>
>
>
> On Monday, May 24, 2021, 08:49:31 AM EDT, Adrian Farrel <
> [email-masked]> wrote:
>
>
>
>
>
> It’s an interesting question : “What would happen if the different parts
> of the SFC needed different SLOs?”  But that is an “if”. I wonder whether
> we can decide whether this is likely.
>
>
>
> Consider an end-to-end flow. We can easily decide on the end-to-end SLOs.
> For example, there may be an end-to-end latency requirement. But it seems
> unlikely that there is a special latency requirement between a pair of SFs.
> Is there an example, where the SF-to-SF SLO needs to be specific?
>
>
>
> Thanks,
>
> Adrian
>
>
>
> *From:* Igor Bryskin <[email-masked]>
> *Sent:* 24 May 2021 13:22
> *To:* [email-masked]; [email-masked]
> *Subject:* Re: [Teas] SFC and slicing
>
>
>
> Hi Adrian,
>
> Thanks for giving to this some thoughts.
>
> I see a problem with the suggested plan if it turns out along the road
> that in a requested by a client SFC SF1-> SF2->...->SFn different sets  of
> SLOs  are required for each/some SFi->SFj links, as well as e2e across the
> slice. I suggested one way to address this by describing slices as SF aware
> abstract topologies.
>
> Cheers,
>
> Igor
>
> Get Outlook for Android
> <https://protect2.fireeye.com/v1/url?k=513a5706-0ea16fd4-513a179d-866132fe445e-e8d21cc567bd8f43&q=1&e=da75fd5d-9f07-47b6-96bf-3011c6879f6d&u=https%3A%2F%2Faka.ms%2Fghei36>
>
>
> ------------------------------
>
> *From:* Teas <[email-masked]> on behalf of Adrian Farrel <
> [email-masked]>
> *Sent:* Sunday, May 23, 2021 1:40:11 PM
> *To:* [email-masked] <[email-masked]>
> *Cc:* [email-masked] <[email-masked]>
> *Subject:* [Teas] SFC and slicing
>
>
>
> Hi,
>
> Igor raised the question of "reconciling" the IETF work on service function
> chaining and network slicing.
>
> Some of the early discussions on network slicing considered not just
> connectivity resources (buffers and bandwidth), but also other resources
> that might be found in the network (like storage and compute). I was one of
> the people suggesting this, and I know there were others. This would
> certainly go some way to bridge the gap to SFC.
>
> However, my understanding is that the design team (and others in the WG)
> wanted to push ahead with the definitions for the connectivity resources
> first, and consider adding other resources later.
>
> I think this is wise. We have taken quite a long time to get to this point
> (especially if you consider the early network slicing BoF), and it is
> certainly the case that the first deployment drive is for connectivity
> resources. Perhaps we should sort that out first.
>
> That said, I don't think that adding other service descriptions would be
> hard. It feels like the definition of further SLOs and SLEs.
>
> If we want to continue this discussion, we should probably involve the SFC
> working group to see how they feel about it. But anyone who is interested
> in
> this could certainly begin work on specifying the SLOs and SLEs that they
> will want to see added to the NBI.
>
> Best,
> Adrian
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
> _______________________________________________
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas
>

---

From: Daniele Ceccarelli <[email-masked]>
Date: Fri, 4 Jun 2021 11:40:53 +0000

Hi Kiran,

It’s (a) since the 3 orchestrators are functionalities, which one can then have in a single or multiple products.

>Ideally, SFs should be controlled from the NSC

This is the part I disagree with. I fully share the awareness part to optimize allocation of the network functions and the connectivity with them (see the discussion with Igor and Jeff) but I don’t think we need to re-build a Cloud Orchestrator, that’s something that already exists and it’s widely deployed.
Again, if you want to have a single product that has both NSC and Cloud Orchestrator functionalities, that’s absolutely legitimate, but having Cloud orchestration functionalities in the NSC is a mistake. That wouldn’t mean just create/delete a VNF, that would imply VNFM, NFVO functionalities, life cycle management…I don’t think we want to go there.

I appreciate your “thinking out loud” mode, which is mine as well.

BR
Daniele

From: Teas <[email-masked]> On Behalf Of Kiran Makhijani
Sent: den 2 juni 2021 02:22
To: Daniele Ceccarelli <daniele.ceccarelli=[email-masked]>
Cc: Adrian Farrel <[email-masked]>; Jeff Tantsura <[email-masked]>; Igor Bryskin <i_bryskin=[email-masked]>; [email-masked]
Subject: Re: [Teas] SFC and slicing

Hi Daniele,
Apologies. I am asking a bit for a late clarification.  There are 2 ways to read the figure you had attached earlier. I was not sure which one is correct -

(a) A 5G-style E2E slice that has 3 parts (RAN, transport and core): In this case cloud-orchestrator and transport-controller should be unrelated. I mean the transport (-IETF) slice should not be concerned with SFs in core-slice.
or,
(b) It has 2 parts (RAN and the rest): then the cloud orchestrator is acting as a resource manager.  It could interact with the transport controller directly or through the OSS. Both should be possible.

Ideally, SFs should be controlled from the NSC, since we consider it to be both resource and connectivity aware. I would expect NSC to discover such capabilities from underlying infrastructure and assign SFs appropriately. This gives NSC better control & monitoring for service assurance. But then, using NFV which has its own resource manager as an example, it is easier for NSC to coordinate with a resource manager (maybe another type of SBI) for SF changes. If  OSS control SFs, then they get pinned into the infrastructure and there is no abstraction.

Just thinking out loud that there are several possibilities, and difficult to capture everything in the current document.

-Kiran

On Mon, May 31, 2021 at 4:35 AM Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:[email-masked]>> wrote:
Hi Igor,

I don’t disagree with you on that. I agree on the fact that the access points are fixed and TE and SF can’t be solved separately, my point is that I think it could make more sense to retrieve information about TE from the SBI (from the network) and about SF from the NBI (i.e. from other components dealing with SFs, e.g. the cloud orchestrator)…and then used together in conjunction.

I’m only questioning if it’s worth getting also the SF from the transport controller, forcing it to deal with a whole new set of information which is already available in the OSS.

Cheers,
Daniele

From: Igor Bryskin <i_bryskin=[email-masked]<mailto:[email-masked]>>
Sent: den 27 maj 2021 16:05
To: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Adrian Farrel <[email-masked]<mailto:[email-masked]>>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] SFC and slicing

Daniele,

But location of  IETF slice access points is (likely to be) fixed, while location of SFs in required SFC may be not. My point is that you can not reduce SF-aware TE problem into two separate TE and SF awareness problems that could be solved separately in separate time frames with first addressing TE (connectivity) and some time later adding somehow selection of SF locations. As Jeff pointed out, this would work short term for pragmatic reasons (to show that something got done). Long term, I believe, SF aware TE should be addressed holistically.

Cheers,
Igor

On Thursday, May 27, 2021, 05:13:02 AM EDT, Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>> wrote:

In reply to Igor’s comment: I meant exactly the opposite, most of the network/service functions will be virtualized with the possibility to deploy them in a wide variety of sites (antenna site, hub site, central office, regional data centers etc.) and finding the best compromise between SF location and TE characteristics is absolutely a valid use case.

The question I’m asking is whether it makes sense to add complexity to the transport orchestrator asking it to retrieve that information from the network or it is an info that can be passed to it as input.

“I need to create a service with non fixed end points with these given SLO, the sites where I can place my workload are A, B, C and D”. When the optimal path is identified the chosen sites are returned to the cloud orchestrator to deploy the network functions. In this case the PCE has all the inputs to perform the dual optimization without duplicating into the transport orchestrator all the functionalities already present in other components of the solution.

Both approaches would work from a technical perspective, it’s just a matter of understanding what makes more sense.

Cheers,
Daniele

From: Jeff Tantsura <[email-masked]<mailto:[email-masked]>>
Sent: den 26 maj 2021 20:51
To: [email-masked]<mailto:[email-masked]>; Adrian Farrel <[email-masked]<mailto:[email-masked]>>; Daniele Ceccarelli <[email-masked]<mailto:[email-masked]>>; Igor Bryskin <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] SFC and slicing

I do think, similarly to Igor’ comments below,
looking at further disaggregation (X-haul) and moving towards the edge, where location and proximity of SFs  becomes crucial to be able to provide optimized workload placement while still meeting the SLOs requested, common view of transport and service topologies would be needed and eventually would be interdependent.

Pragmatically (and in line with Adrian proposal) - I think we should continue progressing connectivity centric work independently, while in parallel working on  SF awareness  and  end2end workflows/data-models.

Cheers,

Jeff

On May 26, 2021, 10:43 AM -0700, Igor Bryskin <i_bryskin=[email-masked]<mailto:i_bryskin=[email-masked]>>, wrote:

Hi Daniele,

If I understood you correctly, you believe that SFs must be visible only to the orchestrator (entity responsable for the e2e service) and should not be considered in the IETF slices.

1) scalability: the number of slices that need to be stitched together would depend on number of SFs in the SFC;

2) The very choice of SF location could be optimized depending on SLOs between adjacent SFs. You seem to believe that SF location is always fixed. I heard people talking about duel optimization path computation algorithms selecting best possible compromise between SF location and TE characteristics of transport connecting them into chains.

Cheers,

Igor

On Wednesday, May 26, 2021, 11:58:40 AM EDT, Daniele Ceccarelli <daniele.ceccarelli=[email-masked]<mailto:daniele.ceccarelli=[email-masked]>> wrote:

Hi Adrian, Igor,

I was trying to think where this augmented (meaning: connectivity + service functions) model would be used.

The architecture that seems to be the most widely adopted is the one shown in picture below. I would say that the NSC is a functionality of the transport orchestrator (pass me the term transport), but that component in many cases, if not all, will only be capable to see connectivity and not service functions, which most likely will be managed by the cloud orchestrator…hence I see it hardly applicable to interface B.

At the same time I don’t think this model would be used over interface A, there I would see something more TMF like.

BR
Daniele

From: Teas <[email-masked]<mailto:[email-masked]>> On Behalf Of Igor Bryskin
Sent: den 24 maj 2021 16:45
To: [email-masked]<mailto:[email-masked]>; Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Teas] SFC and slicing

Right. I suppose we need to hear from operators. Specifically, focusing on the delay SLO I'd like to ask:

1. Is it possible that requested SFs in an SFC need to be time synchronized in a client specific way?

2. If e2e delays D, how the network is supposed to spend the delay budget between SFs in the requested SFC:

a) arbitrarily;

b) evenly.

Cheers,

Igor

On Monday, May 24, 2021, 08:49:31 AM EDT, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:

It’s an interesting question : “What would happen if the different parts of the SFC needed different SLOs?”  But that is an “if”. I wonder whether we can decide whether this is likely.

Consider an end-to-end flow. We can easily decide on the end-to-end SLOs. For example, there may be an end-to-end latency requirement. But it seems unlikely that there is a special latency requirement between a pair of SFs. Is there an example, where the SF-to-SF SLO needs to be specific?

Thanks,

Adrian

From: Igor Bryskin <[email-masked]<mailto:[email-masked]>>
Sent: 24 May 2021 13:22
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Teas] SFC and slicing

Hi Adrian,

I see a problem with the suggested plan if it turns out along the road that in a requested by a client SFC SF1-> SF2->...->SFn different sets  of SLOs  are required for each/some SFi->SFj links, as well as e2e across the slice. I suggested one way to address this by describing slices as SF aware abstract topologies.

Cheers,

Igor

Get Outlook for Android<https://protect2.fireeye.com/v1/url?k=513a5706-0ea16fd4-513a179d-866132fe445e-e8d21cc567bd8f43&q=1&e=da75fd5d-9f07-47b6-96bf-3011c6879f6d&u=https%3A%2F%2Faka.ms%2Fghei36>

________________________________

From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Sent: Sunday, May 23, 2021 1:40:11 PM
To: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: [Teas] SFC and slicing

Hi,

If we want to continue this discussion, we should probably involve the SFC
working group to see how they feel about it. But anyone who is interested in
this could certainly begin work on specifying the SLOs and SLEs that they
will want to see added to the NBI.

Best,
Adrian

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas