Subject: [Teas] Publication has been requested for draft-ietf-teas-gmpls-signaling-smp-07

From: Vishnu Beeram via Datatracker <[email-masked]>
Date: Wed, 16 Jun 2021 22:55:24 -0700

Vishnu Beeram has requested publication of draft-ietf-teas-gmpls-signaling-smp-07 as Proposed Standard on behalf of the TEAS working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-teas-gmpls-signaling-smp/

---

From: tom petch <[email-masked]>
Date: Fri, 18 Jun 2021 15:48:05 +0000

From: Teas <[email-masked]> on behalf of Vishnu Beeram via Datatracker <[email-masked]>
Sent: 17 June 2021 06:55

<tp>
Sigh late again or perhaps an early IETF Last Call comment.

IANA allocates TBD1 and TBD2 which never appear in the body of the document.  There are references to new sub-codes which is where I think that TBD should also appear, for clarity.

Also, they will not be new for long so I would drop the 'new' in that part of the text.

And to remove all doubt I would spell out in IANA Considerations that the new allocations are for Sub-code 25 (Notify Error)  of the Error Code registry. (Or if not, then spell out where they are)!

And, since the IETF has abolished the page number, I would suggest the use of subsections to break this up into referencable  parts of less than a page, as in 
the current section 4 which in my format is 2 1/2 pages long.

Tom Petch
_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Fri, 18 Jun 2021 14:10:06 -0500

Tom, Hi!

Thanks! It is not too late. The authors would have sufficient opportunities
to make improvements as it goes through the IESG processing stage.
The following suggested changes should address the comment on IANA
assignments.

Regards,
-Pavan

----
In Section 4:

**
OLD:
   When a lower priority protecting LSP is preempted, the intermediate
   node that performed preemption MUST send a Notify message with a new
   sub-code "Shared resources unavailable" under "Notify Error" code
   (see [RFC4872]) to the end nodes of that protecting LSP.

NEW:
   When a lower priority protecting LSP is preempted, the intermediate
   node that performed preemption MUST send a Notify message with error
   code "Notify Error" (25) (see [RFC4872]) and error sub-code "Shared
   resources unavailable" (TBA1) to the end nodes of that protecting LSP.

**

OLD:
   When the shared resources become available, a Notify message with a
   new sub-code "Shared resources available" under "Notify Error" code
   MUST be generated by the intermediate node.

NEW:
   When the shared resources become available, a Notify message with
   error code "Notify Error" (25) and error sub-code "Shared resources
   available" (TBA2) MUST be generated by the intermediate node.

**

In Section 6:

OLD:
   This document requests IANA to define two new sub-code values under
   "Notify Error" code in Resource Reservation Protocol (RSVP)
   parameters.

      Value        Description              Reference
      ----- ---------------------------- ---------------
      TBD1  Shared resources unavailable (this document)
      TBD2  Shared resources available   (this document)

NEW:
   IANA maintains a registry called "Resource Reservation Protocol
   (RSVP) Parameters" with a subregistry called "Error Codes and
   Globally-Defined Error Value Sub-Codes".  Within this subregistry
   there is a definition of the "Notify Error" error code (25).
   The definition lists a number of error value sub-codes that may be
   used with this error code.  IANA is requested to allocate further
   error value sub-codes for use with this error code as described in
   this document.

      Value        Description              Reference
      ----- ---------------------------- ---------------
      TBA1  Shared resources unavailable (this document)
      TBA2  Shared resources available   (this document)
**

On Fri, Jun 18, 2021 at 10:48 AM tom petch <[email-masked]> wrote:

> Vishnu Beeram has requested publication of
> draft-ietf-teas-gmpls-signaling-smp-07 as Proposed Standard on behalf of
> the TEAS working group.
>
> Please verify the document's state at
> https://datatracker.ietf.org/doc/draft-ietf-teas-gmpls-signaling-smp/
>
> <tp>
> IANA allocates TBD1 and TBD2 which never appear in the body of the
> document.  There are references to new sub-codes which is where I think
> that TBD should also appear, for clarity.
>
> And to remove all doubt I would spell out in IANA Considerations that the
> new allocations are for Sub-code 25 (Notify Error)  of the Error Code
> registry. (Or if not, then spell out where they are)!
>
> And, since the IETF has abolished the page number, I would suggest the use
> of subsections to break this up into referencable  parts of less than a
> page, as in

---

From: tom petch <[email-masked]>
Date: Sat, 19 Jun 2021 17:16:03 +0000

From: Vishnu Pavan Beeram <[email-masked]>
Sent: 18 June 2021 20:10

Tom, Hi!

Thanks! It is not too late. The authors would have sufficient opportunities to make improvements as it goes through the IESG processing stage.
The following suggested changes should address the comment on IANA assignments.

<tp>

Looks good.

Tom Petch

Regards,
-Pavan

----
In Section 4:

**
OLD:

NEW:

**

OLD:

NEW:

**

In Section 6:

OLD:

NEW:

On Fri, Jun 18, 2021 at 10:48 AM tom petch <[email-masked]<mailto:[email-masked]>> wrote:
From: Teas <[email-masked]<mailto:[email-masked]>> on behalf of Vishnu Beeram via Datatracker <[email-masked]<mailto:[email-masked]>>
Sent: 17 June 2021 06:55

<tp>

Tom Petch
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teas

---

From: Jeong-dong Ryoo <[email-masked]>
Date: Mon, 21 Jun 2021 14:45:40 +0900 (KST)

Tom and Pavan, 

Thank you for the comments and the suggested text to resolve the IANA-related issues.
We (authors) will reflect them into the next version along with breaking up the long text in Section 4. 

Pavan, 
Can we upload a revised draft at this stage, or are we supposed to wait for any step to finish?

Best regards,

Jeong-dong

-----Original Message-----
From:  "tom petch" <[email-masked]>
To:     "Vishnu Pavan Beeram" <[email-masked]>; 
Cc:     "[email-masked]" <[email-masked]>;  "[email-masked]" <[email-masked]>;  "[email-masked]" <[email-masked]>;  "[email-masked]" <[email-masked]>; 
Sent:  2021-06-20 (일) 02:16:24 (UTC+09:00)
Subject: Re: [Teas] Publication has been requested for draft-ietf-teas-gmpls-signaling-smp-07

Tom, Hi!

<tp>

Looks good.

Tom Petch

Regards,
-Pavan

----
In Section 4:

**
OLD:

NEW:

**

OLD:

NEW:

**

In Section 6:

OLD:

NEW:

<tp>

Tom Petch

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Mon, 21 Jun 2021 18:39:13 +0000

Jeong-dong, Hi!

You can take care of the suggested edits along with any other comments that may be raised during the AD Evaluation phase.

Regards,
-Pavan

From: Jeong-dong Ryoo <[email-masked]>
Date: Monday, June 21, 2021 at 12:45 AM
To: [email-masked] <[email-masked]>, tom petch <[email-masked]>
Cc: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>, Vishnu Pavan Beeram <[email-masked]>
Subject: RE: Re: [Teas] Publication has been requested for draft-ietf-teas-gmpls-signaling-smp-07
[External Email. Be cautious of content]

Tom and Pavan,

Pavan,

Best regards,

Jeong-dong

-----Original Message-----
From:  "tom petch" <[email-masked]>
To:     "Vishnu Pavan Beeram" <[email-masked]>;
Cc:     "[email-masked]" <[email-masked]>;  "[email-masked]" <[email-masked]>;  "[email-masked]" <[email-masked]>;  "[email-masked]" <[email-masked]>;
Sent:  2021-06-20 (일) 02:16:24 (UTC+09:00)
Subject: Re: [Teas] Publication has been requested for draft-ietf-teas-gmpls-signaling-smp-07

Tom, Hi!

<tp>

Looks good.

Tom Petch

Regards,
-Pavan

----
In Section 4:

**
OLD:

NEW:

**

OLD:

NEW:

**

In Section 6:

OLD:

NEW:

Please verify the document's state at https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-teas-gmpls-signaling-smp/__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKdjj7JMP$<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-ietf-teas-gmpls-signaling-smp/__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKdjj7JMP$>

<tp>

Tom Petch
_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKZ6C3KHJ$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKZ6C3KHJ$>

_______________________________________________
Teas mailing list
[email-masked]<mailto:[email-masked]>
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKZ6C3KHJ$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKZ6C3KHJ$>

_______________________________________________
Teas mailing list
[email-masked]
https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKZ6C3KHJ$<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/teas__;!!NEt6yMaO-gk!Rffp1MY9B_15acA-aD2kNsREN67GiUMy5MUTupI0a-Dr38FB1yciS-mdKZ6C3KHJ$>

Juniper Business Use Only