Subject: Re: [Teas] Review of draft-ietf-teas-ietf-network-slices-09

From: Krzysztof Szarkowicz <[email-masked]>
Date: Fri, 1 Apr 2022 09:59:34 +0200

Hi Joel,

Indeed, I agree with your observations.

Please see inline as well.

//Krzysztof

> On 2022 -Mar-31, at 18:43, Joel M. Halpern <[email-masked]> wrote:
> 
> I hope I misread the below.  Top posting what I understood.
> 
> There seems to be a discussion about an impact on SLO due to sometimes getting more service than I asked for.  My understanding of SLOs is
> a) the provider would be perfectly within their rights to police the customer to within the bandwidth commitment.)

[Krzysztof] Ack. This is what I see SPs are doing.

> b) If you want to restrict the service from giving you better service, you include that in the SLO.  For example, one can have both a delay bounn and a delay variation bound.

[Krzysztof] Ack.

> So I do not see what problem is being discussed.

[Krzysztof] The problem discussed is the correlation between SLO (like bandwidth, latency, jitter, …) and ‘isolation requirement’. As I see it, if SLO is fulfilled by slice service provider, then we are OK. And, in that case, ‘isolation requirement’ indicated eventually by the customer is irrelevant, because by fulfilling SLO, service provider shows that appropriate (to fulfill SLO) isolation precautions have been taken during realization of the slice service request.

> 
> then there is a digression into hard and soft slicing.  To the degree that is still in the VPN+ drafts, I consider that a problem for that draft.  the service is defined in terms of the observables and specifiables.  Hard slicing is neither.  It does not even rise to the level of an SLE, as it is not a well-defined expectation.  We should simply stay away from it.

[Krzysztof] Strong Ack from my side here.

> 
> Yours,
> Joel
> 
> 
> On 3/31/2022 12:34 PM, Krzysztof Szarkowicz wrote:
>> Hi Adrian,
>> Please see inline.
>> Cheers,
>> Krzysztof
>>> On 2022 -Mar-28, at 22:52, Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
>>> Thanks Krysztof,
>>> [snip]
>>>>> Section 5.3.1
>>>>> 
>>>>> In 5G the 'higher level operation system' is often referred to as
>>>>> SMO (Service Management & Orchestration). Might be SMO
>>>>> could be mentioned as an example?
>>>> Do you have a reference for that I could use?
>>> [Krzysztof] https://orandownloadsweb.azurewebsites.net/specifications <https://orandownloadsweb.azurewebsites.net/specifications>, -> O-RAN.WG1.Slicing-Architecture-v06.00. SMO is responsible for overall slice management in RAN, including requests towards transport domain to create transport slices between RAN components.
>>> 
>>> OK. I’ll go and read that.
>>>>> Section 7:
>>>>> 
>>>>> I am not quite sure, what is the aim, how the customer will
>>>>> express the intend here? Will the architecture document define
>>>>> some 'isolation grades' ('isolation levels', whatever is the good
>>>>> term)? I.e. something like that
>>>>> 
>>>>> 'isolation level A' - zero impact from other slices
>>>>> 'isolation level B' - minimal impact from other slices (impact
>>>>> within SLO limits)
>>>>> 'isolation level C' - medium impact from other slices (rare
>>>>> occasions of exceeding SLO limits)
>>>>> 'isolation level D' - ....
>>>>> 
>>>>> Otherwise, how the customer will express the expectations
>>>>> regarding isolation, without pointing to realization? Also,
>>>>> customer specifies SLO, so why customer should bother about
>>>>> isolation at all? Isn't it internal thing to provider to decide, what
>>>>> sort of isolation techniques to use to ensure requested SLO is
>>>>> achieved?
>>>> Somewhat re-opening an old discussion.
>>>> 
>>>> 1. How the isolation SLE is expressed is an interesting discussion,
>>>> but fortunately not one for this document.
>>>> 2. You mentioned, above, an SLE for link types. But surely the
>>>> customer only cares that their SLOs are met, not which types of
>>>> link are used? If the SLOs are well-enough spec’d then the
>>>> operator can choose any links so long as the SLOs are met.
>>>> 3. With isolation, the customer may want more than “meet my SLOs.”
>>>> They might want, “and don’t let me notice the impact of other
>>>> services even if my SLOs are still being met.”
>>> [Krzysztof] If the SLOs are meet, then customer didn’t noticed impact of other services, IMHO. Otherwise, how the customer notices the impact?
>>> Suppose I have a regular order with my baker to deliver three bread rolls to my house every morning.
>>> Every day, my baker (who is a nice lady) delivers four bread rolls.
>>> One day, however, I have a new neighbour and I notice that I only receive three rolls in the morning.
>>> Then my neighbour goes on vacation and cancels their order and I notice that I start receiving four rolls again.
>>> My SLO is being met all through this, but I have noticed an impact because of my neighbour.
>> [Krzysztof] Not sure, how it applies to the slice service. Assume, I ordered (paying $) the slice service with CIR/PIR=1Gbps/2Gbps. Based on my observations, I always stay with 1Gbps/2Gbps limits, so my requested SLO is fulfilled. Even if the SP has available capacity to serve my slice service e.g. with 3Gbps, there is no incentive from SP to do it, as likely there is next level of the service (priced at $$ level, instead of $), where I can achieve 3Gbps. So, instead of giving 3Gbps for free, the SP goal would be to let me pay $$ to get 3Gbps.
>>> There may be a learning moment for the service provider to never over-deliver on an SLO.
>>>> 
>>>> 3.
>>>> 4. An example to think about is how a financial institution may
>>>> contract to have their traffic carried by a service provider.
>>>> They might put in place very stringent SLOs (and penalties) that
>>>> force the provider to use isolation. Or they might insist on
>>>> isolation.
>>>> 5. Another example to think about is government organisations that
>>>> not only demand SLOs, but demand that their traffic is isolated
>>>> from the traffic of the common people.
>>> [Krzysztof] OK, so more detailed definition of ‘isolation SLE’ is out of scope for this doc. It would be interesting to see the discussion, how this SLE can be expressed by the customer, without pointing to realization (i.e., without saying ‘use dedicated links for my slice’, or ‘use dedicated lambdas in DWDM for my slice’, or ‘use dedicated queues for my slice’, ‘use dedicated VPN for my slice’, etc.). Or, it is just binary (‘isolated’, ’not isolated) SLE, living the decision to the operator, what does it mean ’isolated’ from the realization perspective (operator might say, if the SLOs are meet, it means the service is ‘isolated’, regardless what is the realization).
>>> 
>>> Yes, that will be interesting to observe. What you have described in your “id est” is known as “hard slicing” (although, since the customer doesn’t know about the underlay technology, they are likely to say ‘use dedicated resources’). I believe that there is a spectrum (hard to soft) and it may be this spectrum that is expressed.
>>> You may find the discussion in section 3.2 of draft-ietf-teas-enhanced-vpn to be enlightening.
>> [Krzysztof] Yes, I know the enhanced-vpn draft. Saying that, I still don’t see how the customer will formulate the isolation requirements to SP, without pointing to realization. I.e., do we expect to define ‘hard’, ‘mid-hard’, ‘mid-soft’ or ’soft’ (or whatever.) isolation grades (draft says: “A customer may request different degrees of isolation ranging from soft isolation to hard isolation.", and define exactly what these grades mean (without pointing to realization)?
>>> Cheers,
>>> Adrian
>> _______________________________________________
>> Teas mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/teas

---

From: "Simon Spraggs (sspraggs)" <[email-masked]>
Date: Mon, 4 Apr 2022 08:24:29 +0000

+1, to me slicing is all about offering a set of SLOs, if the SP chooses to allow a customer to burst above the SLO it is up to them, however the SP only needs to offer the SLO to meet their commitment. We see this in the real world today, some SPs allow customers to burst above their committed SLOs, while others have mechanisms to implement an SLO using a hard limited which can't be broken.
As mentioned below given there are no real clear definitions of hard slices or clear designs to implement them, as such mention should be avoided in this document. 
Cheers Simon

On 01/04/2022, 09:30, "Teas on behalf of Krzysztof Szarkowicz" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Joel,

    //Krzysztof

    [Krzysztof] Ack.