Subject: [Teep] Call for adoption

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 2 Apr 2018 18:07:32 +0000

All,

There was strong interest and consensus at the TEEP f2f IETF 101 meeting in London for adopting
https://datatracker.ietf.org/doc/draft-pei-opentrustprotocol/  as a draft protocol.

This is a call for adoption as a working group draft .  If you have any concerns or objections please respond
by April 16th.

Warm regards, Nancy

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 02 Apr 2018 15:05:21 -0400

On Monday, April 02, 2018 06:07:32 PM Nancy Cam-Winget wrote:
> This is a call for adoption as a working group draft .  If you have any
> concerns or objections please respond by April 16th.
> 
> Warm regards, Nancy

I've reviewed the document.  It's clear that a lot of effort has gone into it 
and I think it's generally a good basis for a working group draft, but (you 
knew that was coming, right?):

If I am reading the document correctly, it seems to exclude device owners from 
managing the security of their own devices and I think that's problematic.

The core of the issue is embedded in the definition of a trusted execution 
environment (Page 6, TEE definition):

> ... Assuance that only authorized code can run in the TEE ...

The question is authorized by who?  The draft as it exists constrains this to 
trust roots installed during manufacturing:

> 12.3.  Attestation Hierarchy
> 
>    The attestation hierarchy and seed required for TAM protocol
>    operation must be built into the device at manufacture.  Additional
>    TEEs can be added post-manufacture using the scheme proposed, but it
>    is outside of the current scope of this document to detail that.

While it doesn't preclude adoption of the document as a starting point for the 
working group, I believe this scope limitation needs to be corrected.  
Ultimately the owner of the device needs to be able to manage their trust 
hierarchy.  Even if most users will be content to leave this to the 
manufacturer/OEM, it should be possible to opt-out of the vendor supplied 
trust system if local policy requires it.

Scott K

---

From: Dave Thaler <[email-masked]>
Date: Mon, 2 Apr 2018 19:09:04 +0000

-----Original Message-----
From: TEEP <[email-masked]> On Behalf Of Scott Kitterman
Sent: Monday, April 2, 2018 12:05 PM
To: [email-masked]
Subject: Re: [Teep] Call for adoption

> There was strong interest and consensus at the TEEP f2f IETF 101

> meeting in London for adopting

> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatat

> racker.ietf.org%2Fdoc%2Fdraft-pei-opentrustprotocol%2F&data=02%7C01%7Cdthaler%40microsoft.com%7C69eddba8d40b440c7ff308d598ccb4d2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636582927334097740&sdata=NYiK5Ftle9jw4OpcEMGkSLZMuc76WJACW5%2BlMUEb9xA%3D&reserved=0  as a draft protocol.

> This is a call for adoption as a working group draft .  If you have

> any concerns or objections please respond by April 16th.

> Warm regards, Nancy

I've reviewed the document.  It's clear that a lot of effort has gone into it and I think it's generally a good basis for a working group draft, but (you knew that was coming, right?):

If I am reading the document correctly, it seems to exclude device owners from managing the security of their own devices and I think that's problematic.

>    is outside of the current scope of this document to detail that.

While it doesn't preclude adoption of the document as a starting point for the working group, I believe this scope limitation needs to be corrected.

Ultimately the owner of the device needs to be able to manage their trust hierarchy.  Even if most users will be content to leave this to the manufacturer/OEM, it should be possible to opt-out of the vendor supplied trust system if local policy requires it.

As an individual (not as chair), I strongly agree with you.   There are different use cases we walked through at IETF and the protocol ought to be usable in various use cases, and some use cases indeed have the TAM run by the device owner not the manufacturer.

Dave

Scott K

_______________________________________________

TEEP mailing list

[email-masked]<mailto:[email-masked]>

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep&data=02%7C01%7Cdthaler%40microsoft.com%7C69eddba8d40b440c7ff308d598ccb4d2%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636582927334097740&sdata=n3i55Ie7zo2P7A%2F9fy3gY1VUxAVWQSSdXLAsbj7otrA%3D&reserved=0

---

From: Jeremy O'Donoghue <[email-masked]>
Date: Mon, 2 Apr 2018 21:20:52 +0000

Hi Nancy,

From the perspective of interoperability with work at GlobalPlatform, the removal of the Root SD between draft 5 and draft 6 is probably a show-stopper, since all of the work done to date at GlobalPlatform has been constructed on a hierarchy which includes Root SD - under the architecture of GlobalPlatform TEE management framework, such an entity is generally required in a GlobalPlatform TEE to provide the isolation requirements between TAMs.

I don’t have a detailed impact analysis at this point, but I fear that it might make close alignment of the work at IETF and GlobalPlatform in this area extremely difficult. I urge Teep to reconsider this change.

Minor changes such as the change from “TSM” to “TAM” have mild impact, but can be accommodated as there is no actual change to underlying functionality.

Best regards
Jeremy

On 2 Apr 2018, at 19:07, Nancy Cam-Winget (ncamwing) <[email-masked]<mailto:[email-masked]>> wrote:

All,

Warm regards, Nancy
_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teep

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 5 Apr 2018 22:15:51 +0000

Hi Scott,

Thanks for that feedback….and yes, the notion is to get a base document that we can use as a starting point to build upon and ensure that the use cases of interest are addressed.

Your points are well taken and we put them as items that need to be addressed if you are OK moving forward with this draft as the starting point.

Best, Nancy

On 4/2/18, 12:05 PM, "TEEP on behalf of Scott Kitterman" <[email-masked] on behalf of [email-masked]> wrote:

    

    

    
    Scott K
    
    [email-masked]

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 5 Apr 2018 22:41:11 +0000

Hi Jeremy,
Thanks for the feedback and for highlighting this change.

There was much discussion as to the relationship between applications, security domains  and the TAMs.  Though I am not sure we reached a hard conclusion, by my read, it is something the group will need to get consensus as we move forward in solidifying the protocol(s)….and I believe can be brought back and cleaned up from a given draft.  That is, we need some starting point from which to work….

I would like to hear from others on their perspective on the need for a RootSD and to the readiness of a draft (in using version 6 of  https://datatracker.ietf.org/doc/draft-pei-opentrustprotocol/).

Best, Nancy

From: TEEP <[email-masked]> on behalf of Jeremy O'Donoghue <[email-masked]>
Date: Monday, April 2, 2018 at 2:22 PM
To: "Nancy (ncamwing)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [Teep] Call for adoption

Hi Nancy,

Best regards
Jeremy

All,

Warm regards, Nancy

---

From: Dave Thaler <[email-masked]>
Date: Fri, 6 Apr 2018 00:50:55 +0000

I don’t have an opinion since I don’t understand the whole Root SD concept (and I don’t believe it was really explained in the doc).
Looking at draft 5 (and even draft 4), the term “root SD” only appears in section 5.5 which is clearly a “sample” not restrictive in a normative sense,
where it showed Sub SD’s under Root SD’s.  However, section 5.3 said “From a SD ownership perspective SD tree is flat and there
is only one level” and it looks to me that the sample diagram in draft 6 was fixed to match that statement in draft 4.

Jeremy, are you saying that draft 4 was also bad because of that statement?

Can anyone explain the hierarchical notion in question here in layman’s terms that everyone can understand?

Dave

From: TEEP <[email-masked]> On Behalf Of Jeremy O'Donoghue
Sent: Monday, April 2, 2018 2:21 PM
To: Nancy Cam-Winget (ncamwing) <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teep] Call for adoption

Hi Nancy,

Best regards
Jeremy

All,

There was strong interest and consensus at the TEEP f2f IETF 101 meeting in London for adopting
https://datatracker.ietf.org/doc/draft-pei-opentrustprotocol/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-pei-opentrustprotocol%2F&data=02%7C01%7Cdthaler%40microsoft.com%7C75f351e4b7ad4b0d11fd08d598dfc7f6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636583009259187091&sdata=PzZ4LB2Xb03suibMA7aCniogJdyrheM%2FDTlYW698Fts%3D&reserved=0>  as a draft protocol.

Warm regards, Nancy
_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teep<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep&data=02%7C01%7Cdthaler%40microsoft.com%7C75f351e4b7ad4b0d11fd08d598dfc7f6%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636583009259187091&sdata=K%2FsT1Uby8R83MxBHSO9M7xskO3y6eTKXrlSjP3VADVU%3D&reserved=0>

---

From: Mingliang Pei <[email-masked]>
Date: Fri, 6 Apr 2018 01:14:52 +0000

Hi Jeremy,

Thank you for your feedback and I can clarify that there is no change on root SD and no interoperability issue with what GP has had. It was merely a diagram bug fix in the section 5.5, in fact. The bug fix was pointed out to me by our recent GP editor Andy 😊 I will let Andy chime in on this to further assure you here.

Note that the protocol has been assuming that SD levels in OTrP are assumed to be flat, and there will be no tree hierarchy needed. Notice that Root SD isn’t mentioned anywhere else in the document except that diagram. So we are good.

I would like to also mention that I had discussion of all changes with GP editors and made the new editor aware of the change before we publish the revision. We all considered the changes in revision are necessary, including a few to address some questions raised in GP’s early draft discussion such as multiple algorithm support and OCSP stapling chaining support. We would like to continue this collaboration and take input as we make further revisions later.

Thank you again for your support and help,

Ming

From: TEEP <[email-masked]> on behalf of Jeremy O'Donoghue <[email-masked]>
Date: Monday, April 2, 2018 at 2:22 PM
To: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: [EXT] Re: [Teep] Call for adoption

Hi Nancy,

Best regards
Jeremy

All,

There was strong interest and consensus at the TEEP f2f IETF 101 meeting in London for adopting
https://datatracker.ietf.org/doc/draft-pei-opentrustprotocol/<https://clicktime.symantec.com/a/1/hOyRlaWBVkC_pz6veCgj_m9UihzI_GmhEEkUZPNwJiY=?d=IWF4dL74Y41kWa1IL3BIHD3BzDEN4klh70-E3-XLNCIrKfN2N3D5fQGlpQwNQ6eJTPIp1tqc3lIqdfNbn0j2poguKy2tNPO8PAacLS6aBuN7I5A3TZB72hhBfE-JyDOBO2A0sTmXxiHlEW8cO-ZJKE37bZZU1YmF1cP8g4cbki2-BLoizQjMaJ4r1QzYmlxKoN-d431A75Her1W-F4oKcA4W2p88nORpj_dCKlVdd-FQHxUYHHcPxbCdGMW81ioQPDBWfNO_FDvIy5yqqWTI8pNsegJmogiT9Epo2o-kC94ZV5fOd3367gNvdA5MiZdcjPI43KCjGDE0EWgYTqS_vOKmlMp_D3Tk48IN7KxqKduhV2f_q8NSH8zAuYo%3D&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-pei-opentrustprotocol%2F>  as a draft protocol.

Warm regards, Nancy
_______________________________________________
TEEP mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/teep<https://clicktime.symantec.com/a/1/PtcmRC8QxColEd9ND0jhPkr8PpZV92nutTyNpYoImBQ=?d=IWF4dL74Y41kWa1IL3BIHD3BzDEN4klh70-E3-XLNCIrKfN2N3D5fQGlpQwNQ6eJTPIp1tqc3lIqdfNbn0j2poguKy2tNPO8PAacLS6aBuN7I5A3TZB72hhBfE-JyDOBO2A0sTmXxiHlEW8cO-ZJKE37bZZU1YmF1cP8g4cbki2-BLoizQjMaJ4r1QzYmlxKoN-d431A75Her1W-F4oKcA4W2p88nORpj_dCKlVdd-FQHxUYHHcPxbCdGMW81ioQPDBWfNO_FDvIy5yqqWTI8pNsegJmogiT9Epo2o-kC94ZV5fOd3367gNvdA5MiZdcjPI43KCjGDE0EWgYTqS_vOKmlMp_D3Tk48IN7KxqKduhV2f_q8NSH8zAuYo%3D&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep>

---

From: Scott Kitterman <[email-masked]>
Date: Fri, 06 Apr 2018 14:21:25 -0400

I went back and looked at the WG charter, and it says this about WG 
deliverables:

> .. The first document is on architecture, describing the involved entities,
> their relationships, assumptions, the keying framework, and relevant use
> cases. Second, a solution document that includes the above-described
> functionality in a protocol will be developed. ...

On the data tracker, I see an expired draft, draft-liu-opentrustprotocol-
usecase-01, that (at least based on the title, I confess I didn't read it yet) 
seems to relate to the first WG deliverable.

I think that once the first document was done, I would be much more 
comfortable with a draft like this one that addresses a subset of the 
documented use cases.  I believe there is a technical risk associated with not 
doing the first thing first.

The security model of this draft appears to me to be inherently tied to the 
idea of baking specific keys into a system during the manufacturing process.  
For this use case, I can understand that approach, but that seems unlikely to 
be sufficient for end-user organizations to assert control, since, by 
definition, such keys would be outside their trust boundary.

Without an overall keying framework and use cases from the first document, I 
don't see how the WG can move forward with this solution without excessive 
risk that it will have to be completely reworked once an framework for all use 
cases is developed.

I guess that's a long no.  I think the WG ought to do what the charter says is 
the first document first.

Scott K

On Thursday, April 05, 2018 10:15:51 PM Nancy Cam-Winget wrote:
> Hi Scott,
> 
> Thanks for that feedback….and yes, the notion is to get a base document that
> we can use as a starting point to build upon and ensure that the use cases
> of interest are addressed.
 
> Your points are well taken and we put them as items that need to be
> addressed if you are OK moving forward with this draft as the starting
> point.
 
> Best, Nancy
> 
> On 4/2/18, 12:05 PM, "TEEP on behalf of Scott Kitterman"
> <[email-masked] on behalf of [email-masked]> wrote:
 
>     > https://datatracker.ietf.org/doc/draft-pei-opentrustprotocol/  as a
>     > draft
>     > protocol. 
>     > any
 and I think it's generally a good basis for a working group
> draft, but (you knew that was coming, right?):
>     
 managing the security of their own devices and I think that's
> problematic. 
>     While it doesn't preclude adoption of the document as a starting point
 working group, I believe this scope limitation needs to be
> corrected. Ultimately the owner of the device needs to be able to manage
> their trust hierarchy.  Even if most users will be content to leave this to
> the manufacturer/OEM, it should be possible to opt-out of the vendor
> supplied trust system if local policy requires it.
>     
>     Scott K
>

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 9 Apr 2018 22:18:15 +0000

Hi Scott,
You are correct that the charter also speaks to providing an architecture draft; however, the intent is for the architecture to be in its own document.  It is also the case that many groups in the IETF work on these documents in parallel.....as is also the case that a draft, while may be adopted as a working group document, will evolve (e.g. change) to ensure all use cases are addressed.

Warm regards, Nancy

On 4/6/18, 11:21 AM, "Scott Kitterman" <[email-masked]> wrote:

    

    

    Scott K

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 9 Apr 2018 22:18:17 +0000

Hi Jeremy and Ming,

From what I read, I don’t see strong argument against adoption.  Rather, as an item to address in an adopted wg draft (as this one), we must be clear in terminology and intent especially as we define the role of the “SD” and its relationship…..although, perhaps some of that clarification could also be made in the architecture draft?

Thanks, Nancy.

From: Mingliang Pei <[email-masked]>
Date: Thursday, April 5, 2018 at 6:14 PM
To: Jeremy O'Donoghue <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [EXT] Re: [Teep] Call for adoption

Hi Jeremy,

Ming

Hi Nancy,

Best regards
Jeremy

All,

Warm regards, Nancy

---

From: Mingliang Pei <[email-masked]>
Date: Mon, 9 Apr 2018 22:22:24 +0000

Hi Nancy, agreed. We will include the clarifications in the architecture draft. Thanks,

Ming

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Monday, April 9, 2018 at 3:18 PM
To: Mingliang Pei <[email-masked]>, Jeremy O'Donoghue <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [EXT] Re: [Teep] Call for adoption

Hi Jeremy and Ming,

Thanks, Nancy.

Hi Jeremy,

Ming

Hi Nancy,

Best regards
Jeremy

All,

Warm regards, Nancy

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 09 Apr 2018 23:11:01 +0000

So where's the architecture draft?  The charter does say that one is 'first'.

Scott K

On April 9, 2018 10:18:15 PM UTC, "Nancy Cam-Winget (ncamwing)" <[email-masked]> wrote:
>Hi Scott,
>You are correct that the charter also speaks to providing an
>architecture draft; however, the intent is for the architecture to be
>in its own document.  It is also the case that many groups in the IETF
>work on these documents in parallel.....as is also the case that a
>draft, while may be adopted as a working group document, will evolve
>(e.g. change) to ensure all use cases are addressed.
>
>Warm regards, Nancy
>
>>     I've reviewed the document.  It's clear that a lot of effort has
>gone
>    > into it 
>>     If I am reading the document correctly, it seems to exclude
>device
>    > owners from 
>>     The question is authorized by who?  The draft as it exists
>constrains
>    > this to 
>>     >    TEEs can be added post-manufacture using the scheme
>proposed, but
>    >     >    it
>>     While it doesn't preclude adoption of the document as a starting
>point
>    > for the

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Wed, 25 Apr 2018 22:07:33 +0000

[sorry, this got stuck in my draft box]

Hi Scott,
We discussed the architecture and the need to adopt an architecture draft by the end of April....
As I understand, Ming, Hannes and Dave were going to work on such a document and will let them comment on that timeline.

Thanks, Nancy

On 4/9/18, 4:11 PM, "Scott Kitterman" <[email-masked]> wrote:

    Scott K

---

From: Mingliang Pei <[email-masked]>
Date: Thu, 26 Apr 2018 00:22:18 +0000

Yes, Scott and Nancy, we are working on the architecture draft and target end of April. The protocol document has described part of architecture introduction and key relationships. We don't expect much deviation in architecture and protocol from that as the group has discussed and supported.

Thanks, 

Ming

On 4/25/18, 3:08 PM, "TEEP on behalf of Nancy Cam-Winget (ncamwing)" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Scott,
    
    Thanks, Nancy

        
        Scott K
        
        On April 9, 2018 10:18:15 PM UTC, "Nancy Cam-Winget (ncamwing)" <[email-masked]> wrote:
        >>     > https://clicktime.symantec.com/a/1/Kbu4mKxTROZUXjN_fWGlS_K6fMHyH1sbkEpRPiLh7s8=?d=xiTrx46goYR9PXZgtILqyHOIAk0obqjQz-oRUXridN9z5LVBTsuvGIb662wQgcMAgU00lOt34-6DoYbN8gYz1LJY0PSefIo44KCn3YcvFEyGfKkXV7BoZddUFZ_mCKEZHhC0m6NrDHD9VLCTACOd1Cs0rviTBr0kojoep94TpZcNb_ksL2DvaGNSlXRjPfCuBpoBdCy--_WDzI6BZGGcaWIrmMTsZON-KoCp8_wuOXymONt-C5joNASPeqMQquXL8wzOS8icCNIElWOhWvBIpvbZxNfdOihmpKEpi5KtMLdbvFWbYnLoLDynztimZonoE17k3soyOBwh0rs-nlh871v5w176nWYdRMRVrmSVIDeimeLW&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-pei-opentrustprotocol%2F 
        >as a
        >    >     > draft
        >    >     > protocol. 
        >    >     https://clicktime.symantec.com/a/1/178SAHTpZ1pVsc5wWAHg-cR4D578_We9RwlLdug2xiE=?d=xiTrx46goYR9PXZgtILqyHOIAk0obqjQz-oRUXridN9z5LVBTsuvGIb662wQgcMAgU00lOt34-6DoYbN8gYz1LJY0PSefIo44KCn3YcvFEyGfKkXV7BoZddUFZ_mCKEZHhC0m6NrDHD9VLCTACOd1Cs0rviTBr0kojoep94TpZcNb_ksL2DvaGNSlXRjPfCuBpoBdCy--_WDzI6BZGGcaWIrmMTsZON-KoCp8_wuOXymONt-C5joNASPeqMQquXL8wzOS8icCNIElWOhWvBIpvbZxNfdOihmpKEpi5KtMLdbvFWbYnLoLDynztimZonoE17k3soyOBwh0rs-nlh871v5w176nWYdRMRVrmSVIDeimeLW&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep
        >    >     
        >    > 
        >    > https://clicktime.symantec.com/a/1/178SAHTpZ1pVsc5wWAHg-cR4D578_We9RwlLdug2xiE=?d=xiTrx46goYR9PXZgtILqyHOIAk0obqjQz-oRUXridN9z5LVBTsuvGIb662wQgcMAgU00lOt34-6DoYbN8gYz1LJY0PSefIo44KCn3YcvFEyGfKkXV7BoZddUFZ_mCKEZHhC0m6NrDHD9VLCTACOd1Cs0rviTBr0kojoep94TpZcNb_ksL2DvaGNSlXRjPfCuBpoBdCy--_WDzI6BZGGcaWIrmMTsZON-KoCp8_wuOXymONt-C5joNASPeqMQquXL8wzOS8icCNIElWOhWvBIpvbZxNfdOihmpKEpi5KtMLdbvFWbYnLoLDynztimZonoE17k3soyOBwh0rs-nlh871v5w176nWYdRMRVrmSVIDeimeLW&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep
        >    
        >    https://clicktime.symantec.com/a/1/178SAHTpZ1pVsc5wWAHg-cR4D578_We9RwlLdug2xiE=?d=xiTrx46goYR9PXZgtILqyHOIAk0obqjQz-oRUXridN9z5LVBTsuvGIb662wQgcMAgU00lOt34-6DoYbN8gYz1LJY0PSefIo44KCn3YcvFEyGfKkXV7BoZddUFZ_mCKEZHhC0m6NrDHD9VLCTACOd1Cs0rviTBr0kojoep94TpZcNb_ksL2DvaGNSlXRjPfCuBpoBdCy--_WDzI6BZGGcaWIrmMTsZON-KoCp8_wuOXymONt-C5joNASPeqMQquXL8wzOS8icCNIElWOhWvBIpvbZxNfdOihmpKEpi5KtMLdbvFWbYnLoLDynztimZonoE17k3soyOBwh0rs-nlh871v5w176nWYdRMRVrmSVIDeimeLW&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep
        >    
        
        _______________________________________________
        TEEP mailing list
        [email-masked]
        https://clicktime.symantec.com/a/1/178SAHTpZ1pVsc5wWAHg-cR4D578_We9RwlLdug2xiE=?d=xiTrx46goYR9PXZgtILqyHOIAk0obqjQz-oRUXridN9z5LVBTsuvGIb662wQgcMAgU00lOt34-6DoYbN8gYz1LJY0PSefIo44KCn3YcvFEyGfKkXV7BoZddUFZ_mCKEZHhC0m6NrDHD9VLCTACOd1Cs0rviTBr0kojoep94TpZcNb_ksL2DvaGNSlXRjPfCuBpoBdCy--_WDzI6BZGGcaWIrmMTsZON-KoCp8_wuOXymONt-C5joNASPeqMQquXL8wzOS8icCNIElWOhWvBIpvbZxNfdOihmpKEpi5KtMLdbvFWbYnLoLDynztimZonoE17k3soyOBwh0rs-nlh871v5w176nWYdRMRVrmSVIDeimeLW&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep

    _______________________________________________
    TEEP mailing list
    [email-masked]
    https://clicktime.symantec.com/a/1/178SAHTpZ1pVsc5wWAHg-cR4D578_We9RwlLdug2xiE=?d=xiTrx46goYR9PXZgtILqyHOIAk0obqjQz-oRUXridN9z5LVBTsuvGIb662wQgcMAgU00lOt34-6DoYbN8gYz1LJY0PSefIo44KCn3YcvFEyGfKkXV7BoZddUFZ_mCKEZHhC0m6NrDHD9VLCTACOd1Cs0rviTBr0kojoep94TpZcNb_ksL2DvaGNSlXRjPfCuBpoBdCy--_WDzI6BZGGcaWIrmMTsZON-KoCp8_wuOXymONt-C5joNASPeqMQquXL8wzOS8icCNIElWOhWvBIpvbZxNfdOihmpKEpi5KtMLdbvFWbYnLoLDynztimZonoE17k3soyOBwh0rs-nlh871v5w176nWYdRMRVrmSVIDeimeLW&u=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep

---

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thu, 26 Apr 2018 15:57:59 +0000

Hearing (or reading) no strong objections, “draft-pei-opentrustprotocol” is adopted by the WG.

A few comments have already been provided that can be addressed in subsequent versions some can also be clarified in the architecture draft.

Ming: when you get a chance, please submit the draft with the name:  draft-ietf-teep-opentrustprotocol

Your chairs, Dave and Nancy

From: "[email-masked]" <[email-masked]>
Date: Monday, April 2, 2018 at 11:07 AM
To: "[email-masked]" <[email-masked]>
Subject: Call for adoption

All,

Warm regards, Nancy

---

From: Mingliang Pei <[email-masked]>
Date: Thu, 26 Apr 2018 17:46:20 +0000

Thank you Nancy, Dave and all for your support, comments and suggestions.

Yes, I will rename the draft to “draft-ietf-teep-opentrustprotocol” and resubmit it very soon.

Thanks, again,

Ming

From: TEEP <[email-masked]> on behalf of "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Thursday, April 26, 2018 at 8:58 AM
To: "[email-masked]" <[email-masked]>
Subject: [EXT] Re: [Teep] Call for adoption

All,

There was strong interest and consensus at the TEEP f2f IETF 101 meeting in London for adopting
https://datatracker.ietf.org/doc/draft-pei-opentrustprotocol/<https://clicktime.symantec.com/a/1/gRKJSsq7kQhfqIKwz5wHUYr68TvGP5gAqpJNYBP-b7k=?d=8WYzqysvQkd-X_pG-TDgQWMOhCT_hZ1FSVct6-8Ei0YXDodJ-BlC1HRZVDivUH6gtXKkOaBplQ4cm5LXvKuOoc75nlsRDpZ0rTVUq3fI7jVSXjtiB2k5l62ztuPK_5u9S0O3mA7XFXurjMVspCv9uWGRny0TCxWJTwmktVrcQ-LZsoLDB69BN4KytF_Po_2Z2uln01QFKhgSZXUOR-YCo0fpFWZNBDKlXao5KGMKu-LMjD9wwhzQSXXsEgOk-r_0Vzw4CArYfYfPSqkGXkT1bJegLFfBHZZ6RGWMovT3TJ8Z2EohP6RQgIWuG16Z_L_WaaiTJKC75JKHUnWLAF4IObMDfaL4frUNdI7SaFJEk1Nym6ab&u=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-pei-opentrustprotocol%2F>  as a draft protocol.

Warm regards, Nancy