Subject: [Teep] Yet another take on TEEP signatures

From: Anders Rundgren <[email-masked]>
Date: Sun, 20 May 2018 06:22:49 +0200

As some of you know, I'm not overly convinced that shrouding your precious data in Base64Url is a great solution.

In the TEEP case, it has effectively forced you adding an artificial SD object over the signed TBS object.

However, there seems to be a cool way combining Detached JWS with a pretty simple JSON canonicalization scheme:

https://github.com/w3c/payment-request/issues/714

Anders

---

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 22 May 2018 09:41:44 -0500

> https://github.com/w3c/payment-request/issues/714

How does this work relate to the "Cleartext JOSE" BoF proposal that
was propsed for London but withdrawn before the IESG/IAB BoF call?

(IIRC one of the conclusions from the discussion at that time was
that the JOSE list would be a good place to discuss the topic.)

-Ben

---

From: Anders Rundgren <[email-masked]>
Date: Tue, 22 May 2018 17:42:20 +0200

> was propsed for London but withdrawn before the IESG/IAB BoF call?

Good question!

It is effectively an alternative solution to the same basic problem (base64 encoding messages is a nuisance).

The primary advantages over https://tools.ietf.org/html/draft-erdtman-jose-cleartext-jws-00 include:
- Uses the existing JWS standard "as is"
- Can be used without any changes to JSON serializers or parsers

> that the JOSE list would be a good place to discuss the topic.)

Since the mentioned draft haven't got a single comment since it was published 2 months ago, the JOSE list doesn't seem like the right forum which is why I rather posted this in TEEP who could benefit from a signature solution that doesn't interfere with applications.

I hope to have a public on-line demo running by Friday.

Cheers,
Anders

---

From: Mingliang Pei <[email-masked]>
Date: Wed, 23 May 2018 19:01:27 -0400

Hi Anders,

Thanks for your comments; yes, I didn't forget your suggestions. We understood that a detached signature would make the message more intuitive and friendly. On the other hand, more importantly, I consider it is more important to leverage existing standards that have been endorsed for ease of interoperability in implementation without overarching into the messaging signing format itself in this protocol spec. If detached JSON signing can get endorsed as a standard format in future we can add a message profiling draft at the time to also support the new signing format. For now, I would suggest that we stay with format that is compliant with the current JWS and JWE for better interoperability.

Thanks,

Ming

​Sent with ProtonMail Secure Email.​

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On May 22, 2018 7:41 AM, Benjamin Kaduk <[email-masked]> wrote:

> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep

---

From: Anders Rundgren <[email-masked]>
Date: Fri, 25 May 2018 09:08:09 +0200

On 2018-05-24 01:01, Mingliang Pei wrote:
> Hi Anders,
> 
> Thanks for your comments; yes, I didn't forget your suggestions. We understood that a detached signature would make the message more intuitive and friendly. 

Right, in your case it would also remove a *redundant message layer*.

The only "non-standard" feature is a canonicalization scheme while JWS is used exactly as described in RFC 7515.

Since usable standards seldom gain by being created in "absolute vacuum", I would be very happy working with you and the TEEP WG to make this a reality.

The core piece needed (canonicalization) is already available for ECMAscript, Java, Python3 and .NET.

Documentation: https://github.com/cyberphone/jws-jcs#combining-detached-jws-with-jcs-json-canonicalization-scheme
On-line demo: https://mobilepki.org/jws-jcs/home

In case you would reconsider this as a viable option, I could imagine meeting at IETF-102.

Thanx
Anders

On the other hand, more importantly, I consider it is more important to leverage existing standards that have been endorsed for ease of interoperability in implementation without overarching into the messaging signing format itself in this protocol spec. If detached JSON signing can get endorsed as a standard format in future we can add a message profiling draft at the time to also support the new signing format. For now, I would suggest that we stay with format that is compliant with the current JWS and JWE for better interoperability.