Subject: [Teep] CDDL for OTrP

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 1 Aug 2019 18:56:17 +0000

Hi all,

In draft-tschofenig-teep-otrp-v2-00 I tried to describe OTrP protocol in CDDL because the promise of CDDL is that the description is independent of the serialization (into JSON and CBOR) - in our case.

Unfortunately, I couldn't get this to work fully because the current CDDL description still contains COSE-specific elements.

Is there someone in this group with enough CDDL experience to tell me how I can make the description in such a way that it is applicable to JSON/CBOR serialization? If that's not possible, then the question is whether CDDL is indeed the best way to describe the protocol.

Ciao
Hannes
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 1 Aug 2019 21:15:39 +0200

On Aug 1, 2019, at 20:56, Hannes Tschofenig <[email-masked]> wrote:
> 
> Is there someone in this group with enough CDDL experience to tell me how I can make the description in such a way that it is applicable to JSON/CBOR serialization?

Yes.

> If that’s not possible, then the question is whether CDDL is indeed the best way to describe the protocol.  

If you can provide a sufficient set of examples, I can provide CDDL.
(Right now, I don’t understand the somewhat malformed CDDL in the draft, so having actual CBOR, possibly in diagnostic notation, would help.)

Grüße, Carsten

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 1 Aug 2019 19:18:19 +0000

Thanks for offering help, Carsten.

I will work on some examples and post them to the list

-----Original Message-----
From: Carsten Bormann <[email-masked]>
Sent: Donnerstag, 1. August 2019 12:16
To: Hannes Tschofenig <[email-masked]>
Cc: [email-masked]
Subject: Re: [Teep] CDDL for OTrP

Yes.

Grüße, Carsten

---

From: Henk Birkholz <[email-masked]>
Date: Fri, 2 Aug 2019 10:25:17 +0200

Hi all,

providing JSON instances can also help. We can infer most types from the 
existing version, I think - or you just fix them later.

Your specific question (parsability of current CDDL aside) was about 
CDDL for JOSE: starting with a rather complete set of instances there 
should help.

Viele Grüße,

Henk

On 8/1/19 9:15 PM, Carsten Bormann wrote:
> _______________________________________________
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep
>