Subject: [Teep] Tutorial and Hackathon

From: Hannes Tschofenig <[email-masked]>
Date: Tue, 13 Aug 2019 08:23:39 +0000

Hi all,

at the Montreal meeting we briefly talked about the idea of organizing a tutorial followed by a hackathon for SUIT and TEEP.
A few discussions later we came up with the following story.

Thomas Schmidt (HAW Hamburg) offered to host the event in Berlin. As a date around Jan/Feb 2020 looks more realistic to prepare all the necessary material. The idea was to create a virtual machine with the development environment pre-installed and to make it available to the interested participants well in advance so that we don't have to waste time with tool/IDE problems. This virtual machine image would primarily be used for embedded development. For the TEEP story a separate setup will be needed to support TrustZone/SGX-based devices (since the development environments are different). The virtual machine setup for embedded development would be tailored to a specific embedded hardware and we haven't decided yet what hardware to use. The SUIT hackathon demo boards used in earlier IETF Hackathons may be an reasonable choice. Thoughts are nevertheless welcome. At the tutorial we would get participants up to speed on the most recent protocol/manifest format and the already written tools (e.g., the Python tool to create a manifest) so that time at the hackathon is spent as productive as possible.

We thought it makes sense to cover both SUIT and TEEP in a single event because both groups plan to the manifest format and some of the use cases overlap.

Russ suggested to conclude the event with a virtual interim meeting (maybe an hour long) to discuss the lessons learned.

As you can see, the event is focused on hands-on work and hence we will not offer remote participation possibilities. If you are not interested in writing code this event is likely not very useful for you.

We need your feedback:

  *   Would you like to participate in such an event?
  *   In case you know already, what topic would you like to explore at the event?
  *   Is the Jan/Feb 2020 timeframe good for you?
  *   Is your interest in TEEP, SUIT, or both?
  *   Do you have additional suggestions for getting most out of this event?

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: <[email-masked]>
Date: Tue, 13 Aug 2019 13:07:38 +0000

Hannes,

As you know I already made the first step at Hackathon in Montreal when I brought a VM that I used to run the DDoS based on IoT devices. So, if there will be a VM with development tools I can add to it my python tools so all can check their devices. I can provide to Thomas all my tools to be also included in the VM. I have a problem though; it will require an additional travel to Berlin outside of the IETF formal meetings and it might create a problem for some people under the current travel restrictions. As it has to be F2F maybe we can do it a day before IETF 107 in Vancouver? Thoughts? Thank you

./Sorin

From: TEEP <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Tuesday, August 13, 2019 4:24 AM
To: [email-masked]; [email-masked]
Cc: Thomas C. Schmidt
Subject: [Teep] Tutorial and Hackathon

[EXTERNAL EMAIL]
Hi all,

We need your feedback:

Ciao
Hannes

---

From: Russ Housley <[email-masked]>
Date: Tue, 13 Aug 2019 12:29:39 -0400

I'd like to move forward on the joint tutorial session and interim meeting.  For my calendar, late January is better than February.

Russ

> On Aug 13, 2019, at 4:23 AM, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi all, 
>  
> Thomas Schmidt (HAW Hamburg) offered to host the event in Berlin. As a date around Jan/Feb 2020 looks more realistic to prepare all the necessary material. The idea was to create a virtual machine with the development environment pre-installed and to make it available to the interested participants well in advance so that we don’t have to waste time with tool/IDE problems. This virtual machine image would primarily be used for embedded development. For the TEEP story a separate setup will be needed to support TrustZone/SGX-based devices (since the development environments are different). The virtual machine setup for embedded development would be tailored to a specific embedded hardware and we haven’t decided yet what hardware to use. The SUIT hackathon demo boards used in earlier IETF Hackathons may be an reasonable choice. Thoughts are nevertheless welcome. At the tutorial we would get participants up to speed on the most recent protocol/manifest format and the already written tools (e.g., the Python tool to create a manifest) so that time at the hackathon is spent as productive as possible.
>  
> Would you like to participate in such an event?
> In case you know already, what topic would you like to explore at the event?
> Is the Jan/Feb 2020 timeframe good for you?
> Is your interest in TEEP, SUIT, or both?
> Do you have additional suggestions for getting most out of this event?
>  
> Ciao
> Hannes
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 14 Aug 2019 08:28:21 +0000

Hi Sorin,

Thanks for your feedback. I believe your tools would be helpful in the context of the TEEP work but less so for the SUIT work (but maybe I am wrong). It is certainly something to think about as we are preparing the virtual machine image.

Regarding the date: the thinking was that we should try it as early as possible but still leaving us enough time. The challenge with attaching the event to the IETF meeting is simply that there are so many other activities attached to it. While the hackathon at the IETF meeting is great (and I always enjoy attending it) it turns out getting so busy that it is difficult to get the actual coding done because there are so many distractions. With a complex topic as embedded development and TEEs I believe having a much, much smaller group would actually be beneficial for folks. The SUIT hackathon in Berlin was we did last year was such an example. It was very focused and we accomplished a lot.

Ciao
Hannes

From: [email-masked] <[email-masked]>
Sent: Dienstag, 13. August 2019 15:08
To: Hannes Tschofenig <[email-masked]>; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: Tutorial and Hackathon

Hannes,

./Sorin

From: TEEP <[email-masked]<mailto:[email-masked]>> On Behalf Of Hannes Tschofenig
Sent: Tuesday, August 13, 2019 4:24 AM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Thomas C. Schmidt
Subject: [Teep] Tutorial and Hackathon

[EXTERNAL EMAIL]
Hi all,

We need your feedback:

Ciao
Hannes

---

From: Emmanuel Baccelli <[email-masked]>
Date: Wed, 14 Aug 2019 10:46:20 +0200

FYI here's a link to the previous SUIT hackathon/interim which we organized
last year, that Hannes mentions.
https://github.com/suit-wg/Hackathon-Interim-Berlin
So the idea would be to go prepend to this format some sort of tutorial, to
be discussed, then.
Right?

On Wed, Aug 14, 2019 at 10:28 AM Hannes Tschofenig <
[email-masked]> wrote:

> Hi Sorin,
>
>
>
> Thanks for your feedback. I believe your tools would be helpful in the
> context of the TEEP work but less so for the SUIT work (but maybe I am
> wrong). It is certainly something to think about as we are preparing the
> virtual machine image.
>
>
>
> Regarding the date: the thinking was that we should try it as early as
> possible but still leaving us enough time. The challenge with attaching the
> event to the IETF meeting is simply that there are so many other activities
> attached to it. While the hackathon at the IETF meeting is great (and I
> always enjoy attending it) it turns out getting so busy that it is
> difficult to get the actual coding done because there are so many
> distractions. With a complex topic as embedded development and TEEs I
> believe having a much, much smaller group would actually be beneficial for
> folks. The SUIT hackathon in Berlin was we did last year was such an
> example. It was very focused and we accomplished a lot.
>
>
>
> Ciao
>
> Hannes
>
>
>
>
>
> *From:* [email-masked] <[email-masked]>
> *Sent:* Dienstag, 13. August 2019 15:08
> *To:* Hannes Tschofenig <[email-masked]>; [email-masked];
> [email-masked]
> *Cc:* [email-masked]
> *Subject:* RE: Tutorial and Hackathon
>
>
>
> Hannes,
>
>
>
> As you know I already made the first step at Hackathon in Montreal when I
> brought a VM that I used to run the DDoS based on IoT devices. So, if there
> will be a VM with development tools I can add to it my python tools so all
> can check their devices. I can provide to Thomas all my tools to be also
> included in the VM. I have a problem though; it will require an additional
> travel to Berlin outside of the IETF formal meetings and it might create a
> problem for some people under the current travel restrictions. As it has to
> be F2F maybe we can do it a day before IETF 107 in Vancouver? Thoughts?
> Thank you
>
>
>
> ./Sorin
>
>
>
> *From:* TEEP <[email-masked]> *On Behalf Of *Hannes Tschofenig
> *Sent:* Tuesday, August 13, 2019 4:24 AM
> *To:* [email-masked]; [email-masked]
> *Cc:* Thomas C. Schmidt
> *Subject:* [Teep] Tutorial and Hackathon
>
>
>
> [EXTERNAL EMAIL]
>
> Hi all,
>
>
>
> at the Montreal meeting we briefly talked about the idea of organizing a
> tutorial followed by a hackathon for SUIT and TEEP.
>
> Thomas Schmidt (HAW Hamburg) offered to host the event in Berlin. As a
> date around Jan/Feb 2020 looks more realistic to prepare all the
> necessary material. The idea was to create a virtual machine with the
> development environment pre-installed and to make it available to the
> interested participants well in advance so that we don’t have to waste time
> with tool/IDE problems. This virtual machine image would primarily be used
> for embedded development. For the TEEP story a separate setup will be
> needed to support TrustZone/SGX-based devices (since the development
> environments are different). The virtual machine setup for embedded
> development would be tailored to a specific embedded hardware and we
> haven’t decided yet what hardware to use. The SUIT hackathon demo boards
> used in earlier IETF Hackathons may be an reasonable choice. Thoughts are
> nevertheless welcome. At the tutorial we would get participants up to speed
> on the most recent protocol/manifest format and the already written tools
> (e.g., the Python tool to create a manifest) so that time at the hackathon
> is spent as productive as possible.
>
>
>
> We thought it makes sense to cover both SUIT and TEEP in a single event
> because both groups plan to the manifest format and some of the use cases
> overlap.
>
>
>
> Russ suggested to conclude the event with a virtual interim meeting (maybe
> an hour long) to discuss the lessons learned.
>
>
>
> As you can see, the event is focused on hands-on work and hence we will
> not offer remote participation possibilities. If you are not interested in
> writing code this event is likely not very useful for you.
>
>
>
> We need your feedback:
>
>
>
>    - Would you like to participate in such an event?
>    - In case you know already, what topic would you like to explore at
>    the event?
>    - Is the Jan/Feb 2020 timeframe good for you?
>    - Is your interest in TEEP, SUIT, or both?
>    - Do you have additional suggestions for getting most out of this
>    event?
>
>
>
> Ciao
>
> Hannes
>
>
>
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> IMPORTANT NOTICE: The contents of this email and any attachments are
> confidential and may also be privileged. If you are not the intended
> recipient, please notify the sender immediately and do not disclose the
> contents to any other person, use it for any purpose, or store or copy the
> information in any medium. Thank you.
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit
>

---

From: Hannes Tschofenig <[email-masked]>
Date: Wed, 14 Aug 2019 08:55:13 +0000

Yes, that’s essentially the idea (+ the VM setup + covering TEEP as well).

I think the Berlin hackathon was both well attended and very productive. Hence it makes sense to repeat that model.

We would also get the necessary hardware so that everyone works with the same foundation.

Ciao
Hannes

From: Suit <[email-masked]> On Behalf Of Emmanuel Baccelli
Sent: Mittwoch, 14. August 2019 10:46
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Suit] Tutorial and Hackathon

FYI here's a link to the previous SUIT hackathon/interim which we organized last year, that Hannes mentions.
https://github.com/suit-wg/Hackathon-Interim-Berlin
So the idea would be to go prepend to this format some sort of tutorial, to be discussed, then.
Right?

On Wed, Aug 14, 2019 at 10:28 AM Hannes Tschofenig <[email-masked]<mailto:[email-masked]>> wrote:
Hi Sorin,

Ciao
Hannes

From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Dienstag, 13. August 2019 15:08
To: Hannes Tschofenig <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: Tutorial and Hackathon

Hannes,

./Sorin

[EXTERNAL EMAIL]
Hi all,

We need your feedback:

Ciao
Hannes

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
_______________________________________________
Suit mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/suit
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: <[email-masked]>
Date: Wed, 14 Aug 2019 14:05:40 +0000

Hannes,

From: TEEP <[email-masked]> On Behalf Of Hannes Tschofenig
Sent: Wednesday, August 14, 2019 4:28 AM
To: faibish, sorin; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [Teep] Tutorial and Hackathon

[EXTERNAL EMAIL]
Hi Sorin,

[sf] Just as a disclaimer: I am only focused on DDoS usecases but not sure TEEP or SUIT intention is to prevent DDoS attacks. I want to build tools that will test both protocols.

Thanks for your feedback. I believe your tools would be helpful in the context of the TEEP work but less so for the SUIT work (but maybe I am wrong).
[sf] My plan is to implement a set of tools that will allow to test IoT devices to be exploited for DDoS attacks; packet reflection or random network traffic generation. I am open to ideas as I intent to offer this as a student project. My intention is to test both protocols TEEP and SUIT and I am opened for proposals how to test resistance to DDoS traffic generation.

It is certainly something to think about as we are preparing the virtual machine image.
[sf] I can actually offer the image I already used in Montreal as the base and I will bring to Singapore hackathon.

Regarding the date: the thinking was that we should try it as early as possible but still leaving us enough time. The challenge with attaching the event to the IETF meeting is simply that there are so many other activities attached to it. While the hackathon at the IETF meeting is great (and I always enjoy attending it) it turns out getting so busy that it is difficult to get the actual coding done because there are so many distractions.
[sf] Actually I observed this in Montreal when I was not able to test anything, using my VM and tools, as most of the time we discussed the drafts and slides (no offense to anybody).

With a complex topic as embedded development and TEEs I believe having a much, much smaller group would actually be beneficial for folks. The SUIT hackathon in Berlin was we did last year was such an example. It was very focused and we accomplished a lot.
[sf] I completely agree but if it will only be F2F and I cannot travel I will have to ask somebody to run the tests using the tools that will be open sourced. Thanks

./Sorin

Ciao
Hannes

Hannes,

./Sorin

[EXTERNAL EMAIL]
Hi all,

We need your feedback:

Ciao
Hannes

---

From: <[email-masked]>
Date: Wed, 14 Aug 2019 14:35:24 +0000

Hannes,

One more point; I am only interested in testing the vulnerabilities of both protocols TEEP and SUIT to externally controlled DDoS traffic generation or reflection. So, to your point I believe both WG should be interested in this test. Thanks

./Sorin

[EXTERNAL EMAIL]
Hi Sorin,

Ciao
Hannes

Hannes,

./Sorin

[EXTERNAL EMAIL]
Hi all,

We need your feedback:

Ciao
Hannes