Subject: Re: [Teep] Working Group Last Call for HTTP Transport for Trusted Execution Environment Provisioning: Agent-to-TAM Communication

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 1 Apr 2020 18:40:31 -0700

[quoting is a bit busted, since color doesn't make it into text/plain]

On Wed, Apr 01, 2020 at 02:37:52AM +0000, Dave Thaler wrote:
>     
> 
>     
> 
>    From: TEEP <[email-masked]> On Behalf Of Konda, Tirumaleswar Reddy
>    Sent: Saturday, March 14, 2020 11:05 PM
>    To: [email-masked]
>    Subject: Re: [Teep] Working Group Last Call for HTTP Transport for Trusted
>    Execution Environment Provisioning: Agent-to-TAM Communication
>     
> 
>    5)  HTTP is susceptible to several attacks including pervasive monitoring,
>    any specific reason to support HTTP ?
> 
>     
> 
>    For debugging purposes before putting it into production.

It's not really clear to me that we need to include something in the
protocol spec that's just for debugging.  Do we really think people will
not figure out that they can use non-TLS HTTP for locally debugging an
HTTPS-based protocol?

>    Also some argue that since TEEP already does its own security layer
>    inside, the value of multiple layers of security
> 
>    Is diminished, especially if you're a constrained node looking to reduce
>    code size.   The text in the security consideration

(IMO the multiple layers do different things and complement each other, in
general.  I guess I haven't looked at this specific protocol in detail yet
but there's a general theme across protocols.)

-Ben

---

From: "Konda, Tirumaleswar Reddy" <[email-masked]>
Date: Mon, 6 Apr 2020 11:40:34 +0000

Agree with Ben. I don't see a need to include debugging as a reason to discuss HTTP in the document. User-Agent, URL, HTTP version and other headers in clear text can be used for pervasive monitoring (for example, identifying the device, TAM provider etc.).  Further, the document discusses QUIC for future use and QUIC mandates TLS 1.3. 

-Tiru

> -----Original Message-----
> From: Benjamin Kaduk <[email-masked]>
> Sent: Thursday, April 2, 2020 7:11 AM
> To: Dave Thaler <dthaler=[email-masked]>
> Cc: Konda, Tirumaleswar Reddy <[email-masked]>;
> [email-masked]
> CAUTION: External email. Do not click links or open attachments unless you
> recognize the sender and know the content is safe.
> 
> It's not really clear to me that we need to include something in the protocol
> spec that's just for debugging.  Do we really think people will not figure out
> that they can use non-TLS HTTP for locally debugging an HTTPS-based
> protocol?
> 
> general.  I guess I haven't looked at this specific protocol in detail yet but
> there's a general theme across protocols.)
> 
> -Ben