Subject: [Teep] Nonce and Token ... was RE: Size of NONCE in QueryRequest

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 3 Apr 2020 10:54:59 +0000

Hi Akira

The token is used to match the response to a request. Using an integer for the token is fine.

The nonce is used to providing freshness for the attestation token. The EAT draft (see https://tools.ietf.org/html/draft-ietf-rats-eat-03#section-3.3) says that it is a bstr (of size 8-64 bytes).

I think it would be useful to align with the EAT draft when it comes to the nonce.

Ciao
Hannes

-----Original Message-----
From: TEEP <[email-masked]> On Behalf Of Akira Tsukamoto
Sent: Friday, April 3, 2020 10:36 AM
To: [email-masked]
Subject: [Teep] Size of NONCE in QueryRequest

Hi all,

I would like to ask expertise in the mailing list.

The QueryRequest has member of NONCE in representation of bstr in teep protocol draft.

 From the feedback from the virtual hackathon last week in Japan, I prefer using bstr less as possible and use number representation in int or uint since it reduces the size of the teep message and int/uint are more programing language friendly.

Then I came across how large the integer could be to hold nonce in the member field.

Currently it is:

QueryRequest = {
....
      TOKEN : bstr,
....
      ? NONCE : bstr,
....
}

and would like to suggest

QueryRequest = {
....
      TOKEN => uint .size 4,
....
      ? NONCE => uint .size 4,
....
}

but not sure the unsigned 32bit is large enough or not.
The max of unsigned 32bit, 0x ff ff ff ff, is 4,294,967,295.
And do we expect negative numbers here, if not would like to use uint instead of int?

Any comments are welcome,

Akira

_______________________________________________
TEEP mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teep
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Akira Tsukamoto <[email-masked]>
Date: Fri, 3 Apr 2020 20:27:14 +0900

Hi Hannes,

Thanks for the clarification.

Keeping the NONCE as the same with EAT draft sounds better.

I will make the pull request or updating the token after I confirm the
implementation.

Thanks,
-Akira

On Fri, Apr 3, 2020 at 7:56 PM Hannes Tschofenig
<[email-masked]> wrote:
> .....
> .....
> .....
> .....
> .....
> .....

---

From: Hannes Tschofenig <[email-masked]>
Date: Fri, 3 Apr 2020 11:31:41 +0000

Thanks, Akira.

-----Original Message-----
From: Akira Tsukamoto <[email-masked]>
Sent: Friday, April 3, 2020 1:27 PM
To: Hannes Tschofenig <[email-masked]>
Cc: Akira Tsukamoto <[email-masked]>; [email-masked]
Subject: Re: [Teep] Nonce and Token ... was RE: Size of NONCE in QueryRequest

Hi Hannes,

I will make the pull request or updating the token after I confirm the implementation.

Thanks,
-Akira