Subject: Re: [Teep] [Suit] Value of COSE_Mac_Tagged/COSE_Sign_Tagged/COSE_Mac0_Tagged/COSE_Sign1_Tagged

From: Carsten Bormann <[email-masked]>
Date: Thu, 9 Apr 2020 13:07:21 +0200

On 2020-04-09, at 10:40, Hannes Tschofenig <[email-masked]> wrote:
> 
> Hi Akira, Hi Jim,
> 
> based on our TEEP conference call we reduced the size of options down to COSE_Sign1. Hence, the rest is gone.
> That should make things easier and COSE_Sign1 is defined in the COSE spec itself.
> 
> I posted a PR with the new CDDL at https://github.com/ietf-teep/teep-protocol/pull/26

Thanks, Hannes.  Based on this, Henk and I have done some additional cleanup.
We plan to have a first version of a PR by 1300Z.

Grüße, Carsten

---

From: Brendan Moran <[email-masked]>
Date: Thu, 9 Apr 2020 12:07:40 +0000

From a SUIT perspective, I’m still inclined to make sure that this is tagged as that allows for use-cases that we may not have considered.

Best Regards,
Brendan

> On 9 Apr 2020, at 12:07, Carsten Bormann <[email-masked]> wrote:
>
> _______________________________________________
> Suit mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/suit

IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 9 Apr 2020 14:12:07 +0200

> From a SUIT perspective, I’m still inclined to make sure that this is tagged as that allows for use-cases that we may not have considered.

Makes sense.  Let’s fix the definition of `SUIT-envelope` in the below.

Henk and I created a cleaned up version of the CBOR encoding and accompanying CDDL.
We should check whether this encoding helps us and then integrate it into the document.

https://github.com/ietf-teep/teep-protocol/pull/27

Grüße, Carsten

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 9 Apr 2020 13:29:01 +0000

>    Makes sense.  Let’s fix the definition of `SUIT-envelope` in the below.

We're missing the chance to use "overcoat" or "jacket" ... :)

---

From: Akira Tsukamoto <[email-masked]>
Date: Thu, 9 Apr 2020 22:38:07 +0900

Hi Carsten and Hannes,

The new pull request reflects all the discussion points of converting
from map and using minimum major type size for the array member.

When I was reading the cddl draft, I was not quite sure how to
describe the array with the label name.
In your pull request,

query-request = [
     type: TEEP-TYPE-query-request,
     token: uint,

The above cddl description has label name type and token with semicolon.
We were trying to avoid having label name inside the array.
I thought I have to use => for this purpose.

Other discussion we had with the teep is to use the same nonce as the
EAT defines.

nonce => bytes,
to be
nonce => bstr .size (8..64)

And the size of token we never really agreed about it.
How bout
  token: uint .size 4

The 32bit unsign integer seems to be reasonable for the usage in teep.

Best,
-Akira

On Thu, Apr 9, 2020 at 9:12 PM Carsten Bormann <[email-masked]> wrote:
> TEEP mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teep

---

From: Henk Birkholz <[email-masked]>
Date: Thu, 9 Apr 2020 16:13:31 +0200

Hello Akira,

in an array context, the name (aka label) is annotation only. It is not 
transferred over "the wire", so we did not bother to define a 
corresponding type.

In other words, you could simply omit "type: " and "token: " and nothing 
would change. It is annotation for humans, basically.

See https://tools.ietf.org/html/rfc8610#section-2.1

Viele Grüße,

Henk

---

From: Akira Tsukamoto <[email-masked]>
Date: Fri, 10 Apr 2020 08:43:37 +0900

Hi Henk,

Thanks for you comment.
I now am perfectly clear about the label name is just annotation for array in cddl.

Best,
-Akira

On 4/9/2020 11:13 PM, Henk Birkholz wrote:
> Hello Akira,
> 
> in an array context, the name (aka label) is annotation only. It is not transferred over "the wire", so we did not bother to define a corresponding type.
> 
> In other words, you could simply omit "type: " and "token: " and nothing would change. It is annotation for humans, basically.
> 
> See https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Frfc8610%23section-2.1&amp;data=02%7C01%7Cakira.tsukamoto%40aist.go.jp%7C85cf47c432354e5fa73a08d7dc903817%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637220384303337245&amp;sdata=%2B%2Bm5aUI2zpFdEXec5dNElG4KNhC%2B60TeUDxMcXjtGqo%3D&amp;reserved=0
> 
> Viele Grüße,
> 
> Henk
> 
>> https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fietf-teep%2Fteep-protocol%2Fpull%2F27&amp;data=02%7C01%7Cakira.tsukamoto%40aist.go.jp%7C85cf47c432354e5fa73a08d7dc903817%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637220384303337245&amp;sdata=ZDVr31cNQdQNR5H2bcvnC%2Bj7m%2BDgVz1kIe4us99%2B%2BsA%3D&amp;reserved=0
>>
>>> https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fietf-teep%2Fteep-protocol%2Fpull%2F27&amp;data=02%7C01%7Cakira.tsukamoto%40aist.go.jp%7C85cf47c432354e5fa73a08d7dc903817%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637220384303337245&amp;sdata=ZDVr31cNQdQNR5H2bcvnC%2Bj7m%2BDgVz1kIe4us99%2B%2BsA%3D&amp;reserved=0
>>>
>>> Grüße, Carsten
>>>
>>> https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fteep&amp;data=02%7C01%7Cakira.tsukamoto%40aist.go.jp%7C85cf47c432354e5fa73a08d7dc903817%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637220384303337245&amp;sdata=CG21OuaA8t16%2BzyvSFazbG3l2sEpc9sa8trHUmX5TBI%3D&amp;reserved=0
>>
>> https://jpn01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsuit&amp;data=02%7C01%7Cakira.tsukamoto%40aist.go.jp%7C85cf47c432354e5fa73a08d7dc903817%7C18a7fec8652f409b8369272d9ce80620%7C0%7C0%7C637220384303337245&amp;sdata=Cc9I9ZFT4Ms%2BI198MQw%2B78aJxlDsTlH0EonuB%2B7rKUg%3D&amp;reserved=0
>>