Subject: cr computation

From: "Greene, Jeremy" <[email-masked]>
Date: Fri, 15 Jun 2001 12:49:36 -0400

In the ospf/isis-te drafts, a method for distributing constraint information
is described without any discussion of path computation. Is that because:

a) It's assumed people can figure out and or want to do their own thing,
such as spf or other? Or is it intended to be covered in separate documents?
b) rsvp would be used hop-by-hop, with the next hop a function of the tspec
and advertised constraints; but if this is true, wouldn't some form of
crank-back be required?

Jeremy

btw, do others find the diff-serv/mpls/te draft set to be rather confusing?
It seems like it should be easier, if not at least (a lot) shorter, to
explain how to: a) map a dscp onto an lsp b) have the lsp indicate the
flow's dscp with and without the shim header c) have, or have not, the lsp
be a diff-serv flow based on the mapped dscp d) use the ospf/isis te lsa to
advertise phbs/dscps and e) request a phb path using rsvp (why tied to
mpls?)

---

From: "Kavi, Prabhu" <[email-masked]>
Date: Fri, 15 Jun 2001 13:06:00 -0400

Jeremy,

Think of it as three related steps:

1.  IS-IS and OSPF distribute the available bandwidth at
    each priority level to all nodes.
2.  The head-end that wants to setup the LSP has this 
    available BW in its Link State Database (LSDB).  It
    can use this information to determine candidate paths
    that have the bandwidth for the LSP it wants to setup.
    This is constraint-based routing.
3.  The head-end signals the path using RSVP.  Each node
    along the path verifies that the bandwidth required for
    the LSP is still available.  If all nodes along the 
    path have available bandwidth, the LSP is setup.  
    Otherwise, the LSP is rejected.

Once enough LSPs have been setup along a path, the bandwidth
on a link will cross an advertisement threshold.  Then 
OSPF/IS-IS will flood the current available bandwidths
on these links.

Prabhu
----------------------------------------------------------------------
Prabhu Kavi                     Phone:  1-978-264-4900 x125 
Director, Adv. Prod. Planning   Fax:    1-978-264-0671
Tenor Networks                  Email:  [email-masked]
100 Nagog Park                  WWW:    www.tenornetworks.com
Acton, MA 01720

> -----Original Message-----
> From: Greene, Jeremy [mailto:[email-masked]]
> Sent: Friday, June 15, 2001 12:50 PM
> To: Te-Wg (E-mail)
> Subject: cr computation
> 
>

---

From: "Don Fedyk" <[email-masked]>
Date: Fri, 15 Jun 2001 18:50:35 -0400

Girish  you wrote:

>Crank back may be required if the source does not have an up to date 
>information about the TE topology. I don't know if anyone has addressed 
>this issue yet.

the draft : draft-ietf-mpls-te-feed-01.txt
addresses this but I cannot find it. May be I am blind.

George 
Do you know where it went? I thought is was in last call.

Thanks,
Don