Subject: TE MIB (-06.txt) : tunnel instance

From: Sonam Thapa <[email-masked]>
Date: Thu, 14 Jun 2001 06:50:39 -0700 (PDT)

I am a bit confused by the mplsTunnelInstance
parameter in the MIB. Should each tunnel not have
its own name, index etc, even if it has the same
parameters as another tunnel. If this is so,
mplsTunnelInstance is not needed right?

Or does current equipment support such "multiple"
instances of the tunnel? If so what advantages 
does it have over 2 tunnels which differ in the
index and name fields.

Can the authors/implementors please comemnt.

TIA,
-aos.

__________________________________________________
Do You Yahoo!?
Spot the hottest trends in music, movies, and more.
http://buzz.yahoo.com/

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 14 Jun 2001 11:12:57 -0400

>does it have over 2 tunnels which differ in the

         This is useful for several reasons. First,
it allows pre-signalled back-up tunnels to be
displayed. They will appear as different instances
of the same tunnel. You can also use alternate
instances of the tunnel to have different
constraints (paths, etc...) which can be chosen
in the event that the primary path fails and
is rerouted. Finally, you can also have parallel
tunnels. Some implementations allow multiple instances of
the same tunnel to be signaled and used in parallel,
but appear as the same tunnel interface.

         --Tom

---

From: Sonam Thapa <[email-masked]>
Date: Thu, 14 Jun 2001 08:43:40 -0700 (PDT)

Tom,

Thank you for your reply. I understand what you
are saying and agree that this could be useful.

However, if 2 tunnels have the same <ingress, egress> 
but different instance ids, 2 questions come to
mind -
a) MUST they have the same TunnelIndex?
b) Besides Ifindexes, does this save anything else
   at the egress or the ingress over 2 regular
   tunnels between the same <ingress, egress>
   assuming one regular LSP is backing up another
   and is pre-signalled. Seems to me that this is
   equivalent to having tunnels with multiple
   instances.

Did I get it wrong?

TIA,
-aos

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 14 Jun 2001 14:02:46 -0400

>a) MUST they have the same TunnelIndex?

         No, definitely not. You can have as many
tunnels from point A to point B as your network
will support.

>    equivalent to having tunnels with multiple

         Honestly, you can do it either way and
the MIB will support it; it is really up to your
implementation to decide. We did this on purpose
when we designed the MIB so that we could support
all of the cases I described earlier.

         --Tom

---

From: Sonam Thapa <[email-masked]>
Date: Fri, 15 Jun 2001 08:27:15 -0700 (PDT)

Thanks Tom.

You have been very helpful!

-aos

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Fri, 15 Jun 2001 12:06:01 -0400

>You have been very helpful!

         Anytime. 8)

         --Tom