Subject: RE: Inter Area Requirements - draft-boyle-tewg-interarea-reqts-01.txt

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Wed, 17 Dec 2003 13:28:43 -0600

[Re-send, doesn't seem to have made it to the list]

Jim,

> Please review and comment, I also would like to resubmit this as a WG
> document (incorporating wg feedback of course).
> 
> We have nothing covering these, and it would be good to send something in
> this area forward to CCAMP along with the inter-as requirements.

Agreed.  I support as a WG document.

Here are a couple of comments:

1. Section 3.1, 2nd paragraph.  I suggest you add a reference to the [CRANKBACK] draft:
"In overview, the requirements below call for what may be called a crankback method [CRANKBACK] which employs head end direction for regional optimization."
Reference:
[CRANKBACK] http://www.ietf.org/internet-drafts/draft-ietf-ccamp-crankback-00.txt

2. Section 3.3, first sentence: "Facility protection of a single link is necessarily intra-area and not applicable to inter-area discussions."

I'm not sure what you mean here.  Many links are routed through a given transport facility, and these links could well be in different areas.  It seems that facility protection ala http://www.ietf.org/internet-drafts/draft-lang-ccamp-gmpls-recovery-e2e-signaling-02.txt will be affected by inter-area TE?  This should be clarified.

Thanks,
Jerry

---

From: Jim Boyle <[email-masked]>
Date: Fri, 19 Dec 2003 18:39:38 -0800 (PST)

> [CRANKBACK] http://www.ietf.org/internet-drafts/draft-ietf-ccamp-crankback-00.txt

I want to shy away from referencing a particular approach, however I will
add this, with the reference as an example.

> I'm not sure what you mean here.  Many links are routed through a given transport facility, and these links could well be in different areas.  It seems that facility protection ala http://www.ietf.…

My point was that when one uses bypass protection, it is usually just
to protect the next downstream link.  In this case, it acts a bit like
SONET BLSR.  However looking at the protocol draft
draft-ietf-mpls-rsvp-lsp-fastreroute-03.txt, it's clear that at least
the protocol allows you to try to use bypass LSPs in other situations
(E.g. protect downstream link and node, bundle LSPs together that go
past the node after the dowstream node).  So I guess the sentence you
quote up there is too limited, and as such there's really not a big
need to explain it.  I'll strike that, and change the next sentence
from "Per-path protection is necessary" to "LSP protection is
necessary...".

does that address your concern?

thanks,

Jim

---

From: "Ash, Gerald R (Jerry), ALABS" <[email-masked]>
Date: Sat, 20 Dec 2003 12:10:44 -0600

Jim,

> > 2. Section 3.3, first sentence: "Facility protection of a 
> > single link is necessarily intra-area and not applicable to 
> > inter-area discussions."
> >
> > I'm not sure what you mean here.  Many links are routed 
> > through a given transport facility, and these links could 
> > well be in different areas.  It seems that facility protection ala 
> > http://www.ietf.org/internet-drafts/draft-lang-ccamp-gmpls-recovery-e2e-signaling-02.txt 
> > will be affected by inter-area TE?  This should be clarified.

> does that address your concern?

Yes it does, thanks.

Regards,
Jerry