Subject: Re: [TICTOC] TICTOC - clock discovery

From: John.zhao <[email-masked]>
Date: Sun, 10 Aug 2008 10:05:43 +0100

Hi,Mike and Silvana

　  I understand what you just worry about. But from the protocol perspective, the clock source discovery is a necessary part to provide reliable redundancy. It can be useful for both of clock initial discovery and clock recovery. Without it , what is our assumtion to find the clock source? Is it hard code or others? Without clock discovery, how to deal with clock recovery, once the previous primary clock source fail? Only recovery from pre-configured list? 
     Just like NTP , we also have the mechanism to find NTP server. To deployment, we can select if it is got static or dynamic, that is true. I believe, that has been discussed many times before , maybe also in ITU. But currently, when we face to IETF protocol design, those necessary still can be considered again.
     My two cents.

　　　　　　　　Best Rgds,
Thanks,

　　　　　　　　　　　　　　John.zhao
　　　　　　　　　　　　　　[email-masked]
　　　　　　　　　　　　　　　2008-08-10
======== 2008-08-08 08:53:00 you have wrote:========

John, 

We had lengthy discussions about clock discovery at ITU and it seems that there are some concerns about it as Mike pointed out. 

Best Regards, 

Silvana

John, i can see that this may be a nice to have function for some apps but I also see that this may create a non optimal network wrt to performance. 
  
Mike 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John.zhao
Sent: 08 August 2008 08:42
To: [email-masked]
Cc: [email-masked]
Subject: Re: [TICTOC] TICTOC slots for Dublin IETF

Hi,Silvana 
  
    Maybe clock discovery is useful? 
  
    Best Rgds, 
Thanks 
  
john.zhao
Shanghai Huawei Technologies Co.,LTD 

发件人: [email-masked] [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2008年8月8日 5:21
收件人: [email-masked]
主题: Re: [TICTOC] TICTOC slots for Dublin IETF

Attached is the Protocol table that we worked on last Wednesday. 

Feedback is very welcome! 

Thanks, 

Silvana

Hi Silvana, 
 
Among the several of us were the 2 TICTOC chairs. 
 
Regards 
 
Jean-Loup 

De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 6 août 2008 23:14
À : [email-masked]
Objet : Re: [TICTOC] TICTOC slots for Dublin IETF

All, 

Several of us informally met on Wednesday afternoon to work on the requirements table. We proposed to have a table for the applications requirements and a table for the protocol requirements. Attached is the table for the application requirements that we worked on on the informal meeting. I will send the table for the protocol requirements tomorrow. 

Feedback is very welcome. 

Thanks, 

Silvana _______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

= = = = = = = = = = = = = = = = = = = = = = 
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: Yaakov Stein <[email-masked]>
Date: Sun, 10 Aug 2008 17:16:13 +0300

Hi all,

For applications in controlled service provider environments
the network designer will want to specify which clocks to use,
which are backups, etc. In this way timing loops can be avoided,
higher quality sources can be prioritirized, etc.

In other applications, it can be essential to find the timing source.
As John said, in the public Internet case, it would be unacceptable
to have the end-user manually configure the IP address of an NTP server
or servers.

In other cases it can be a matter of taste or nomenclature.
I don't want to get into an argument about what constitutes
a control plane and what a management plane,
but the border can be very fuzzy. So configuring the master clock
via a management system may end up being not that different
from several masters being advertised using a "control plane:
and the client selecting the one it wishes to use.

Finally, several times in the past I have brought up the issue
of "Classless Time Protocol" (CTP), which does not make
any hard decisions as to which clocks are masters and which are slaves.

So I think we DO need a column in the applications table
as to whether the master needs to be dictated / found / something in between.

Y(J)S

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of John.zhao
Sent: Sunday, August 10, 2008 12:06 PM
To: [email-masked]; mike.gilson
Cc: [email-masked]
Subject: Re: [TICTOC] TICTOC - clock discovery

Hi,Mike and Silvana

　　　　　　　　Best Rgds,
Thanks,

　　　　　　　　　　　　　　John.zhao
　　　　　　　　　　　　　　[email-masked]<mailto:[email-masked]>
　　　　　　　　　　　　　　　2008-08-10
======== 2008-08-08 08:53:00 you have wrote:========

John,

Best Regards,

Silvana

Mike
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of John.zhao
Sent: 08 August 2008 08:42
To: [email-masked]
Cc: [email-masked]
Subject: Re: [TICTOC] TICTOC slots for Dublin IETF

Hi,Silvana

    Best Rgds,
Thanks

john.zhao
Shanghai Huawei Technologies Co.,LTD
________________________________
发件人: [email-masked] [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2008年8月8日 5:21
收件人: [email-masked]
主题: Re: [TICTOC] TICTOC slots for Dublin IETF

Thanks,

Silvana

Hi Silvana,

Regards

Jean-Loup

________________________________
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 6 août 2008 23:14
À : [email-masked]
Objet : Re: [TICTOC] TICTOC slots for Dublin IETF

All,

Thanks,

---

From: "FERRANT JEAN-LOUP" <[email-masked]>
Date: Mon, 11 Aug 2008 09:24:40 +0200

Hi,
 
I concur with all of you.
 
Certainly if we are going this way, some points has to be considered again, mainly on the performance and architecture aspects; that may be also impacted by the "on path support" .
 
Regards
 
Jean-Loup

De : [email-masked] [mailto:[email-masked]] De la part de John.zhao
Envoyé : dimanche 10 août 2008 11:06
À : [email-masked]; mike.gilson
Cc : [email-masked]
Objet : Re: [TICTOC] TICTOC - clock discovery

Hi,Mike and Silvana 

　　　　　　　　Best Rgds,
Thanks,
 
　　　　　　　　　　　　　　John.zhao
　　　　　　　　　　　　　　[email-masked]
　　　　　　　　　　　　　　　2008-08-10

	John, 

	Best Regards, 
	
	Silvana

	Mike 
	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] On Behalf Of John.zhao
	Sent: 08 August 2008 08:42
	To: [email-masked]
	Cc: [email-masked]
	Subject: Re: [TICTOC] TICTOC slots for Dublin IETF
	
	Hi,Silvana 

	    Best Rgds, 
	Thanks 

	john.zhao

	
	
	Thanks, 
	
	Silvana

	Hi Silvana, 

	Regards 
	 
	Jean-Loup 

	

	All, 

	
	Thanks,