Subject: Re: [TICTOC] Specifying a frequency only service

From: Danny Mayer <[email-masked]>
Date: Sun, 10 Aug 2008 12:14:23 -0400

Yaakov Stein wrote:
> Marshall
> 
> Frequently we want frequency for CES services.
> 
> Averaging over 30 seconds will give long term accuracy,
> but unfortunately will not withstand TDM masks as during
> the 30 second averaging time the phase error will accumulate.
> 
> Stuart
> 
> Frequency MAY be obtained from a time service without looking at
> the timestamps, but there are other possibilities.
> 
> SyncE for one.  CBR streams is another.
> Neither has timestamps nor have any concept of time,
> but both can deliver frequency.
> 
> 
> Y(J)S

Don't you also need phase for such a service?

Danny
_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 11 Aug 2008 09:40:59 +0300

Danny,

No. A pure frequency service requires no phase alignment.
Only the frequency is important - but it has to be highly accurate
(not just traceable).
The term phase is often used in such cases, such as "phase locked loop"
or limiting the amount of "phase accumulation",
but there is no connection between the phase at various locations.

There are other applications (e.g. various TDD and TDMA systems)
that require distribution of what has been called "phase"
but which I prefer to call "uncalibrated time".
(Phase is not clear since it is not evident whether relative difference
between two different locations is implied.)
Here, there is no need to lock to UTC or any other recognized time system.

However, it is always possible to view such applications as distributing
"time", even if this time is not a recognized standard time.

Y(J)S

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]]
Sent: Sunday, August 10, 2008 7:14 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Yaakov Stein wrote:
> Averaging over 30 seconds will give long term accuracy, but
> unfortunately will not withstand TDM masks as during the 30 second
> averaging time the phase error will accumulate.
>
> Stuart
>
> Frequency MAY be obtained from a time service without looking at the
> timestamps, but there are other possibilities.
>
> Neither has timestamps nor have any concept of time, but both can
> deliver frequency.
>
>
> Y(J)S

Danny

---

From: "FERRANT JEAN-LOUP" <[email-masked]>
Date: Mon, 11 Aug 2008 08:45:59 +0200

Yaakov,

Uncalibrated time has been introduced in Dublin, this is certainly a good idea, but what about a "unreferenced time"? . I think that this uncalibrated time is simply missing a connection with an absolute time that is a reference.

Regards

Jean-Loup 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Yaakov Stein
Envoyé : lundi 11 août 2008 08:41
À : Danny Mayer
Cc : STUART VENTERS; Greg Dowd; [email-masked]
Objet : Re: [TICTOC] Specifying a frequency only service

Danny,

No. A pure frequency service requires no phase alignment.
Only the frequency is important - but it has to be highly accurate (not just traceable).
The term phase is often used in such cases, such as "phase locked loop"
or limiting the amount of "phase accumulation", but there is no connection between the phase at various locations.

There are other applications (e.g. various TDD and TDMA systems) that require distribution of what has been called "phase"
but which I prefer to call "uncalibrated time".
(Phase is not clear since it is not evident whether relative difference between two different locations is implied.) Here, there is no need to lock to UTC or any other recognized time system.

However, it is always possible to view such applications as distributing "time", even if this time is not a recognized standard time.

Y(J)S

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]]
Sent: Sunday, August 10, 2008 7:14 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Danny

---

From: "STUART VENTERS" <[email-masked]>
Date: Mon, 11 Aug 2008 09:41:37 -0500

Yaakov,

Interesting, it sounds like we have a third sort of service in the pot.

Those three being:

1) Time of day distribution. (as in time within x attoseconds of UTC or TAI)
2) My frequency, AKA your uncalibrated time distribution.  (as in meets some Telco wander mask)
3) Your frequency service (perhaps as in within x ppm of exact frequency)

I'd like to understand better how the 3rd service differs from the 2nd.

So what sort of accuracy specs do you need for this third service?
  It sounds like wander doesn't matter.
  Would it be a single number as in max ppm frequency offset.
  Or perhaps you also need a frequency stability spec.
  Would the averaging time for measuring the frequency be important?

Perhaps there is a specific TDD or TDMA application spec we could look at?

Regards,

Stuart

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Monday, August 11, 2008 1:41 AM
To: Danny Mayer
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: RE: [TICTOC] Specifying a frequency only service

Danny,

Y(J)S

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]]
Sent: Sunday, August 10, 2008 7:14 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Danny

---

From: "Kishan Shenoi" <[email-masked]>
Date: Mon, 11 Aug 2008 11:16:49 -0700

To further bolster Yaakov's point, the key quantitative measures applied to
date are MTIE and TDEV.  If you examine the definitions of these entities
you see that "initial phase" is moot, often ignored or assumed to be zero.
MTIE addresses phase accumulation whereas TDEV removes any flat frequency
offset, ignoring the phase accumulation associated with a constant frequency
(offset).

Kishan

---

From: "Kishan Shenoi" <[email-masked]>
Date: Mon, 11 Aug 2008 11:30:37 -0700

Stuart,

You bring up a very interesting point with #3.  In traditional telecom
networks "x" has always been essentially 0 (zero) (or "PRC-traceable") in
normal operation and in holdover ("trouble") mode limited by certain stratum
limits such as 4.6ppm for ST3 (in North America).  The fundamental need for
such an approach was to constrain slips in long distance communications.
Some emerging services may not be constrained in the same manner though it
is usually the most demanding application that sets the requirement.

The need for a frequency stability spec is apparent.  Generally a frequency
stability spec provides a limit on wander so indirectly wander is covered by
a frequency stability spec (e.g. TDEV).  Averaging time is important because
low-Fourier-frequency wander can appear to be a frequency offset when
averaging times that are much smaller than the underlying period of the
wander component.

Hope this helps,

Kishan

---

From: Yaakov Stein <[email-masked]>
Date: Tue, 12 Aug 2008 11:45:11 +0300

Sorry for missing a few emails and going back in the thread.

However, you misunderstood what I had intended regarding uncalibrated (or unreferenced) time.

My frequency only service is the classic TDM one, with MTIE and TDEV masks,
although I generalize it to optionally include the case where there is an absolute frequency
tolerance as well.

My phase only case is different as there IS explicit distribution of "phase"
i.e. unreferenced time, but this time need not be a recognized standard.
All that is required is for the members of a closed group to agree on
time offsets, and no traceability to an (inter)nationally recognized time scale
is required.

Y(J)S

-----Original Message-----
From: STUART VENTERS [mailto:[email-masked]]
Sent: Monday, August 11, 2008 5:42 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; [email-masked]; Danny Mayer
Subject: RE: [TICTOC] Specifying a frequency only service

Yaakov,

Those three being:

Regards,

Stuart

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Monday, August 11, 2008 1:41 AM
To: Danny Mayer
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: RE: [TICTOC] Specifying a frequency only service

Danny,

Y(J)S

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]]
Sent: Sunday, August 10, 2008 7:14 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Danny

---

From: "STUART VENTERS" <[email-masked]>
Date: Tue, 12 Aug 2008 09:57:46 -0500

Yaakov,

Thanks, I suspected as much, but it was worth asking just to make sure.

So there are 2 issues here:

ISSUE 1:

With regards to an absolute frequency tolerance for a frequency service,
   it seems like it's covered by an MTIE mask.

For example:
  If a point on the mask says the phase can't move by more than 1 uS in 1 second
     then the frequency is guaranteed to be
        within 1ppm over a 1 second averaging time.

(Granted, an absolute frequency tolerance spec is simpler, 
    but to mean anything I suspect it needs an averaging time.)

When you ask for an additional absolute frequency tolerance spec,
   would it be in addition to, or instead of MTIE?

I'm trying to understand why this would be useful in light of MTIE.
  I could go with simple is better for some specific app?

ISSUE 2:

With regards to the 'phase only' distribution requirement:

This brings up something that I've been wondering about for awhile.

If I say I'm distributing time of day to within x attoseconds of UTC or TAI then the client knows:
	1) He either does or does not have to deal with leap seconds.
	2) The time at the source is near correct with respect to the recognized source.
	3) The frequency at the source is near correct and pretty stable.

I guess a 'phase only' service would remove constraint 2 at the time server.
   (I'm not sure why a client would care.)

The interesting question is what about constraint 3.
   A client certainly cares if the server he is trying to lock on to is stable.
   In your 'phase only' service,
      what sort of frequency accuracy and stability constraints would remain on the server?

Regards,

Stuart

(We're a bunch of engineers and we have to be careful 
    when we indulge our compulsion to invent stuff regardless of need. ;)

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Tuesday, August 12, 2008 3:45 AM
To: STUART VENTERS
Cc: Marshall Eubanks; Greg Dowd; [email-masked]; Danny Mayer
Subject: RE: [TICTOC] Specifying a frequency only service

Y(J)S

-----Original Message-----
From: STUART VENTERS [mailto:[email-masked]]
Sent: Monday, August 11, 2008 5:42 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; [email-masked]; Danny Mayer
Subject: RE: [TICTOC] Specifying a frequency only service

Yaakov,

Those three being:

Regards,

Stuart

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Monday, August 11, 2008 1:41 AM
To: Danny Mayer
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: RE: [TICTOC] Specifying a frequency only service

Danny,

Y(J)S

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]]
Sent: Sunday, August 10, 2008 7:14 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Danny

---

From: "Doug Arnold" <[email-masked]>
Date: Tue, 12 Aug 2008 08:57:45 -0700

Good summary Stuart,

One minor point: MTIE is a great way to specify worst case frequency
stability performance.  Sometimes an RMS type spec is desired which is
why TDEV and ADEV are used as well.

//Doug Arnold

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of STUART VENTERS
Sent: Tuesday, August 12, 2008 7:58 AM
To: Yaakov Stein
Cc: Greg Dowd; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Yaakov,

ISSUE 1:

For example:
  If a point on the mask says the phase can't move by more than 1 uS in
1 second
     then the frequency is guaranteed to be
        within 1ppm over a 1 second averaging time.

ISSUE 2:

If I say I'm distributing time of day to within x attoseconds of UTC or
TAI then the client knows:
	1) He either does or does not have to deal with leap seconds.
	2) The time at the source is near correct with respect to the
recognized source.
	3) The frequency at the source is near correct and pretty
stable.

I guess a 'phase only' service would remove constraint 2 at the time
server.
   (I'm not sure why a client would care.)

The interesting question is what about constraint 3.
   A client certainly cares if the server he is trying to lock on to is
stable.
   In your 'phase only' service,
      what sort of frequency accuracy and stability constraints would
remain on the server?

Regards,

Stuart

(We're a bunch of engineers and we have to be careful 
    when we indulge our compulsion to invent stuff regardless of need.
;)

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Tuesday, August 12, 2008 3:45 AM
To: STUART VENTERS
Cc: Marshall Eubanks; Greg Dowd; [email-masked]; Danny Mayer
Subject: RE: [TICTOC] Specifying a frequency only service

However, you misunderstood what I had intended regarding uncalibrated
(or unreferenced) time.

My frequency only service is the classic TDM one, with MTIE and TDEV
masks, although I generalize it to optionally include the case where
there is an absolute frequency tolerance as well.

My phase only case is different as there IS explicit distribution of
"phase"
i.e. unreferenced time, but this time need not be a recognized standard.
All that is required is for the members of a closed group to agree on
time offsets, and no traceability to an (inter)nationally recognized
time scale is required.

Y(J)S

-----Original Message-----
From: STUART VENTERS [mailto:[email-masked]]
Sent: Monday, August 11, 2008 5:42 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; [email-masked]; Danny Mayer
Subject: RE: [TICTOC] Specifying a frequency only service

Yaakov,

Those three being:

1) Time of day distribution. (as in time within x attoseconds of UTC or
TAI)
2) My frequency, AKA your uncalibrated time distribution.  (as in meets
some Telco wander mask)
3) Your frequency service (perhaps as in within x ppm of exact
frequency)

Perhaps there is a specific TDD or TDMA application spec we could look
at?

Regards,

Stuart

-----Original Message-----
From: Yaakov Stein [mailto:[email-masked]]
Sent: Monday, August 11, 2008 1:41 AM
To: Danny Mayer
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: RE: [TICTOC] Specifying a frequency only service

Danny,

No. A pure frequency service requires no phase alignment.
Only the frequency is important - but it has to be highly accurate (not
just traceable).
The term phase is often used in such cases, such as "phase locked loop"
or limiting the amount of "phase accumulation", but there is no
connection between the phase at various locations.

There are other applications (e.g. various TDD and TDMA systems) that
require distribution of what has been called "phase"
but which I prefer to call "uncalibrated time".
(Phase is not clear since it is not evident whether relative difference
between two different locations is implied.) Here, there is no need to
lock to UTC or any other recognized time system.

Y(J)S

-----Original Message-----
From: Danny Mayer [mailto:[email-masked]]
Sent: Sunday, August 10, 2008 7:14 PM
To: Yaakov Stein
Cc: Marshall Eubanks; Greg Dowd; STUART VENTERS; [email-masked]
Subject: Re: [TICTOC] Specifying a frequency only service

Danny

---

From: Yaakov Stein <[email-masked]>
Date: Thu, 14 Aug 2008 17:00:40 +0300

Stuart,

Allow me to snip out everything except the questions.

> ISSUE 1

>    would it be in addition to, or instead of MTIE?

For classic TDM services the test is actually MRTIE,
i.e., one tests to see if the client hasnot wandered too far
away from the source frequency. This is the proper thing to do
since the purpose of G.823 and the like is to ensure that
there are not too many bit slips.

But then there are applications where IN ADDITION to
having to recover the TDM traffic without bit slips,
the frequency itself is used for other purposes,
e.g., as a reference frequency for the RF of a transmitter.
In order to ensure that that transmitter stay within its
allocated frequency location (and thus not interfere with nearby
transmitters who may be locked onto frequencies derived from
a different source), it is not enough to have MRTIE,
one also has to absolute frequency accuracy.

In the classical TDM world, primary clocks have absolute
frequency constraints (see G.811), but slave clocks have only
MRTIE type constraints.

That's why I said that I usually mean MTIE,
but realize that in certain cases absolute frequency is also needed.
For example, 3GPP 25.402 section 4.2
states that a G.812 or G.813 clock may be used,
but the absolute accuracy must be better than 50 ppb.

>   (I'm not sure why a client would care.)

With the "phase" or "unreference time" case there is never a leap second,
since the "time" is arbitrary, and does not have to keep in step with any astonomical events.

The time at the source is not "correct" as compared to any recognized standard,
since it is purposely "unclaibrated". Thus a particular group of participants
use some time which starts on TUESDAY, July 29, 2008 at 1300 Dublin time
and continues on from there at the rate determined by (and ONLY by)
the frequency of the source.

Consider a PON (Passive Optical Network) as an example.
The OLT has a clock, for which time=0 at some arbitrary time when
the network was started up. It is very important for all the ONUs to be locked
to that time, so that when they receive grants to transmit, they do so
in their alloted time, and not during that of some other ONU.
However, nothing else is important.

>      what sort of frequency accuracy and stability constraints would remain on the server?

Yes, the whole thing only works for a source clock which is sufficiently stable,
but the requirements are not that strict. Certainly if the source clock is not monotonic
(e.g., it sometimes goes backwards in time) then all bets are off.
For nonpathological cases, all we need is for the source time to be
approximately linear in real time over time intervals typical of the transactions
going on in the system. Going back to the PON example, one needs for
the time acquired by ONU 1 to agree sufficiently with that acquired by ONU 2 at
some later time. This is usually not a tough constraint.

BTW, there is another, even easier, case.
For certain kinds of sensor networks, even time is not needed, only ORDER.
One needs to know that event A happened BEFORE or AFTER event B.
This CAN be done using unreferenced time, but there are other methods
(see Lamport's clock).

Y(J)S