Subject: Re: [TICTOC] Duiplicate OID s in TICTOC PTP 1588V2 MIB?

From: Vinay Shankarkumar <[email-masked]>
Date: Tue, 28 Jun 2011 14:00:10 -0400

Hi Vijay,
Thanks for the comment, yes that is a typo error. It will be corrected 
in the next version of
the revised draft,

Regards,
-Vinay/.

On 6/28/2011 12:28 PM, Vijay Ammula wrote:
>
> Vinay,
>
> All,
>
> I hope I am looking at the latest version of this draft mib for PTP 
> 1588V2.
>
> I am seeing a OID duplication issue in the draft mib proposed by you 
> folks. While I am not an expert on SNMP and MIBs, it seems to be a 
> problem to me – could be even a cut-and-paste kind.
>
> Here is what I am talking about. Both ietfptpSystemTable and 
> ietfptpSystemProfile getting the same Object ID.
>
> ietfptpSystemTableOBJECT-TYPE
>
> SYNTAX SEQUENCE OF ietfptpSystemEntry
>
> MAX-ACCESS not-accessible
>
> STATUS current
>
> DESCRIPTION
>
> "Table of count information about the PTP system for all
>
> domains."
>
> ::= { ietfPtpMIB SystemInfo 1 }
>
> ietfptpSystemProfileOBJECT-TYPE
>
> SYNTAX ClockProfileType
>
> MAX-ACCESS read-only
>
> STATUS current
>
> DESCRIPTION
>
> "This object specifies the PTP Profile implemented on the
>
> system."
>
> REFERENCE "Section 19.3 PTP profiles of [1]"
>
> ::= { ietfPtpMIB SystemInfo 1 }
>
> Thanks,
>
> Vijay
>
> *Vijaya Ammula*
>
> ------------------------------------------------------------------------
>
> direct: +1.408.579.3290
>
> main: +1.408.579.2800
>
> *cid:[email-masked]*
>
>
> ------------------------------------------------------------------------
> DISCLAIMER:
> This e-mail and any attachments to it may contain confidential and 
> proprietary material and is solely for the use of the intended 
> recipient. Any review, use, disclosure, distribution or copying of 
> this transmittal is prohibited except by or on behalf of the intended 
> recipient. If you have received this transmittal in error, please 
> notify the sender and destroy this e-mail and any attachments and all 
> copies, whether electronic or printed.

---

From: Vinay Shankarkumar <[email-masked]>
Date: Tue, 28 Jun 2011 15:06:20 -0400

Vijay,
the same tree structure is followed. The typo was that it should have 
been mentioned as SystemInfo 3
instead of SystemInfo 1 for ietfptpSystemProfile, hope that helps,

Thanks,
-Vinay.

On 6/28/2011 2:41 PM, Vijay Ammula wrote:
> Thanks Vinay for your quick response.
>
> In the meantime, could you tell us where do they belong in the tree?
>
> Can we have ietfptpSystemTable  as it is now and shuffle   ietfptpSystemProfile to ?
>
> Thanks
>
> Vijaya Ammula
>
> direct: +1.408.579.3290
> main:   +1.408.579.2800
>
>
>
>
> -----Original Message-----
> From: Vinay Shankarkumar [mailto:[email-masked]]
> Sent: Tuesday, June 28, 2011 11:00 AM
> To: Vijay Ammula
> Cc: [email-masked]; Vinay Shankarkumar
> Subject: Re: Duiplicate OID s in TICTOC PTP 1588V2 MIB?
>
>
> Hi Vijay,
>> problem to me - could be even a cut-and-paste kind.
>>
>> ietfptpSystemProfile OBJECT-TYPE
>>
>> SYNTAX ClockProfileType
>>
>> MAX-ACCESS read-only
>>
>> STATUS current
>>
>> DESCRIPTION
>>
> This e-mail and any attachments to it may contain confidential and proprietary material and is solely for the use of the intended recipient. Any review, use, disclosure, distribution or copying of this transmittal is prohibited except by or on behalf of the intended recipient.  If you have received this transmittal in error, please notify the sender and destroy this e-mail and any attachments and all copies, whether electronic or printed.