Subject: [TICTOC] Open Source 1588 slave implementation

From: Yaakov Stein <[email-masked]>
Date: Thu, 29 Mar 2012 13:49:25 +0000

Hi all

This should be of interest to the TICTOC community.

A BDS-licensed Open Source implementation of a PTP demon for Linux/FreeBSD machines has appeared on SourceForge.
It is called ptpd (like ntpd) and claims to be a complete implementation of an IEEE 1588 slave clock.

See http://ptpd.sourceforge.net/

Y(J)S

---

From: Greg Dowd <[email-masked]>
Date: Fri, 30 Mar 2012 00:34:06 +0000

This has been around for 6 years I believe :)

Greg Dowd
gdowd at symmetricom dot com (antispam format)
Symmetricom, Inc.
www.symmetricom.com<http://www.symmetricom.com>
"A clever person solves a problem.  A wise person avoids it." Albert Einstein

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Thursday, March 29, 2012 6:49 AM
To: [email-masked]
Subject: [TICTOC] Open Source 1588 slave implementation

Hi all

Y(J)S

---

From: Yaakov Stein <[email-masked]>
Date: Fri, 30 Mar 2012 10:51:28 +0000

I had only seen the close-source windows one, not the Open Source one.

However, someone sent me a link to "a more advanced one" - http://code.google.com/p/ptpv2d/w/list .

It would be interesting to compare the three PC versions.

Y(J)S

From: Greg Dowd [mailto:[email-masked]]
Sent: Friday, March 30, 2012 02:34
To: Yaakov Stein; [email-masked]
Subject: RE: Open Source 1588 slave implementation

Greg Dowd

Hi all

Y(J)S

---

From: Danny Mayer <[email-masked]>
Date: Fri, 30 Mar 2012 08:07:34 -0400

George Neville-Neil who I believe is on this list has an open-source
implementation. I'm copying him on this message as well. See here:
http://ptpd.sf.net/ I believe that this is the same one that you
referred to. In fact this has a redirect to the page you referred to.
Please direct all questions about it to George.

Danny

On 3/29/2012 9:49 AM, Yaakov Stein wrote:
> A BDS-licensed Open Source implementation of a PTP demon for
> Linux/FreeBSD machines has appeared on SourceForge.
>

---

From: Tal Mizrahi <[email-masked]>
Date: Sat, 31 Mar 2012 23:25:30 +0300

And there is also Openptp:
http://sourceforge.net/projects/openptp/

Tal.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yaakov Stein
Sent: Friday, March 30, 2012 1:51 PM
To: Greg Dowd; [email-masked]
Subject: Re: [TICTOC] Open Source 1588 slave implementation

Y(J)S

Greg Dowd

Hi all

Y(J)S