Subject: Re: [TICTOC] [ntpwg] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt

From: Tal Mizrahi <[email-masked]>
Date: Tue, 6 Nov 2012 20:01:14 +0200

Right, I agree.
My point was just that we may be provisioning for something that will come out completely different than what we currently expect.
It is kind of like buying the tires before you decide which car you want to buy.  :)

Tal.

-----Original Message-----
From: Doug Arnold [mailto:[email-masked]] 
Sent: Tuesday, November 06, 2012 11:31 AM
To: [email-masked]; Tal Mizrahi
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [TICTOC] [ntpwg] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt

There is also some value in having these the treatment of NTP and PTP in one place.

//Doug Arnold

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Tuesday, October 23, 2012 8:11 AM
To: Tal Mizrahi
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [TICTOC] [ntpwg] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt

Tal,

It is true that developing an NTP option in parallel would potentially be more efficient and coherent; however, we have thus far had no volunteers to work on that document. The current approach is flexible enough to support PTP, NTP, and possibly other timing methods which is a generalization of the solution originally proposed.

We welcome proposals and volunteer document editors who wish to pursue the NTP option.

Regards,
Karen

On 10/22/12 4:35 PM, Tal Mizrahi wrote:
> Hi Shahram,
>
> Thanks for the prompt response.
> I would suggest to add some text to explain the scope of this draft in the context of NTP, i.e., your explanation below.
>
> A question to the WG chairs: if NTP TCs are indeed on the agenda, wouldn't it be best to define these entities in parallel to the MPLS draft? It seems more natural, and more likely to produce a coherent mechanism.
>
> Thanks,
> Tal.
>
> ________________________________________
> From: Shahram Davari [[email-masked]]
> Sent: Monday, October 22, 2012 6:46 PM
> To: Tal Mizrahi; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [TICTOC] I-D Action: 
> draft-ietf-tictoc-1588overmpls-03.txt
>
> Hi Tal,
>
> If you recall the Area director asked for generalizing this draft to NTP and other possible future Timing methods such as a Shim header that can carry Timing. I know NTP does not have TC, but IETF may add TC in future. Also on the egress LER the timing Label (defined in the draft) may be used as an indicator to sample ToD at the port level.
>
> Thanks
> Shahram
>
> -----Original Message-----
> From: Tal Mizrahi [mailto:[email-masked]]
> Sent: Monday, October 22, 2012 7:47 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [TICTOC] I-D Action: 
> draft-ietf-tictoc-1588overmpls-03.txt
>
> Hi Shahram et al.
>
> What is the motivation for adding NTP to this draft?
> Are we planning to define something similar to a correctionField in NTP?
>
> Regards,
> Tal.
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, October 22, 2012 10:28 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [TICTOC] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>   This draft is a work item of the Timing over IP Connection and Transfer of Clock Working Group of the IETF.
>
>          Title           : Transporting Timing messages over MPLS Networks
>          Author(s)       : Shahram Davari
>                            Amit Oren
>                            Manav Bhatia
>                            Peter Roberts
>                            Laurent Montini
>          Filename        : draft-ietf-tictoc-1588overmpls-03.txt
>          Pages           : 36
>          Date            : 2012-10-22
>
> Abstract:
>     This document defines the method for transporting Timing messages
>     such as PTP and NTP over an MPLS network.  The method allows for the
>     easy identification of these PDUs at the port level to allow for port
>     level processing of these PDUs in both LERs and LSRs.
>
>     The basic idea is to transport Timing messages inside dedicated MPLS
>     LSPs.  These LSPs only carry timing messages and possibly Control and
>     Management packets, but they do not carry customer traffic.
>
>     Two methods for transporting Timing messages over MPLS are defined.
>     The first method is to transport Timing messages directly over the
>     dedicated MPLS LSP via UDP/IP encapsulation, which is suitable for
>     MPLS networks.  The second method is to transport Timing messages
>     inside a PW via Ethernet encapsulation, which is suitable for both
>     MPLS and MPLS-TP networks.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-tictoc-1588overmpls
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ietf-tictoc-1588overmpls-03
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ietf-tictoc-1588overmpls-03
>
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc
> _______________________________________________
> ntpwg mailing list
> [email-masked]
> http://lists.ntp.org/listinfo/ntpwg

_______________________________________________
TICTOC mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tictoc

---

From: "Shahram Davari" <[email-masked]>
Date: Tue, 6 Nov 2012 19:58:27 +0000

Tal,

This draft just leaves the possibility for NTP and other Timing protocols to use the same mechanism. It does not define anything specific to NTP. Using your analogy, it basically defines a method for ordering a Tire, but does not define the Actual tire spec. So any tire could be purchased with this method, or alternatively another method.

Thanks
Shahram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tal Mizrahi
Sent: Tuesday, November 06, 2012 10:01 AM
To: Doug Arnold; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [TICTOC] [ntpwg] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt

Right, I agree.

Tal.

-----Original Message-----
From: Doug Arnold [mailto:[email-masked]] 
Sent: Tuesday, November 06, 2012 11:31 AM
To: [email-masked]; Tal Mizrahi
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [TICTOC] [ntpwg] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt

//Doug Arnold

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Karen O'Donoghue
Sent: Tuesday, October 23, 2012 8:11 AM
To: Tal Mizrahi
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [TICTOC] [ntpwg] I-D Action: draft-ietf-tictoc-1588overmpls-03.txt

Tal,

Regards,
Karen