Subject: Re: [TICTOC] Comments about draft-ietf-tictoc-shpiner-multi-path-synchronization-00

From: Doug Arnold <[email-masked]>
Date: Fri, 21 Dec 2012 20:41:45 +0000

This is an interesting proposal.  I believe that some kind of multi-path scheme for timing packets has value.

In section 5.2.1 (Two-way MPPTP) it states:

Every clock periodically sends a set of N Announce messages, using
its N addresses as the source IP address.

In 1588, however, only the best master sends multicast Announce messages.  Slaves never send Announce messages, and non-best masters do only if they set the Alternate Master Flag (see IEEE-1588-2008, sec. 17.4). However, masters can obtain slave addresses from received Delay Requests. Also, if masters used the Alternate Master Flag,  it would help prevent slaves which are not capable of mulit-path, from getting confused.

Alternatively this could be done without Alternative Masters, using the Unicast Discovery mechanism (IEEE-1588-2008, sec. 17.5) In this mechanism slaves must start with a list of master addresses.  The slaves then send unicast Announce message requests to the addresses, and subsequently receive unicast Announce messages.

//Doug Arnold
Symmetricom

---

From: Tal Mizrahi <[email-masked]>
Date: Sat, 22 Dec 2012 11:02:50 +0200

Hi Doug,

Thanks for your comments.

> In 1588, however, only the best master sends multicast Announce messages.  Slaves never send Announce messages
Indeed we received similar comments Peter Meyer, and in the next draft we are going to update this issue.
The next draft will clarify that slaves use unicast negotiation to request unicast service from the master. The draft will also discuss how unicast discovery can be used when the master identity is known in advance.

Regards,
Tal.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Doug Arnold
Sent: Friday, December 21, 2012 10:42 PM
To: [email-masked]
Subject: Re: [TICTOC] Comments about draft-ietf-tictoc-shpiner-multi-path-synchronization-00

//Doug Arnold
Symmetricom