Subject: Re: [TICTOC] YANG compilation issue: draft-ietf-tictoc-1588v2-yang

From: Benoit Claise <[email-masked]>
Date: Fri, 2 Dec 2016 18:54:19 +0100

Thanks Yuanlong,

I added two new compilers to 
http://www.claise.be/IETFYANGPageCompilation.html
And a new issue is found for your YANG module, with yanglint:
     err : Invalid keyword "01".
     err : Module parsing failed.

Regards, Benoit
> Hi Benoit,
>
> This is fixed in the new revision: https://tools.ietf.org/html/draft-ietf-tictoc-1588v2-yang-02
> BTW, the validation tool provided in http://www.yangvalidator.com/ cannot detect it.
>
> Thanks,
> Yuanlong
>
> -----Original Message-----
> From: Benoit Claise [mailto:[email-masked]]
> Sent: Friday, November 25, 2016 6:22 PM
> To: [email-masked]; [email-masked]
> Subject: YANG compilation issue: draft-ietf-tictoc-1588v2-yang
>
> Dear authors,
>
> We can't extract the YANG module correctly out of draft-ietf-tictoc-1588v2-yang.
> The reason is:
>
> OLD:
>       <CODE BEGINS> file "ietf-ptp-dataset@2016-11-25"
>
> NEW:
>       <CODE BEGINS> file "[email-masked]"
>
> See RFC 6087 for the conventions and examples.
> Once corrected, the YANG compilation tool chain should work fine. See http://www.claise.be/IETFYANGPageCompilation.html
>
> Regards, Benoit

---

From: Jiangyuanlong <[email-masked]>
Date: Mon, 5 Dec 2016 12:33:38 +0000

We will upload a new revision to resolve it.

Thanks,
Yuanlong 

-----Original Message-----
From: Benoit Claise [mailto:[email-masked]] 
Sent: Saturday, December 03, 2016 1:54 AM
To: Jiangyuanlong; [email-masked]; [email-masked]
Subject: Re: YANG compilation issue: draft-ietf-tictoc-1588v2-yang

Thanks Yuanlong,

Regards, Benoit