Subject: [TICTOC] WGLC for draft-ietf-ntp-mode-6-cmds

From: Karen O'Donoghue <[email-masked]>
Date: Thu, 31 May 2018 03:26:12 +0000

Folks,

This begins a 2 week working group last call for the following document: 

Control Messages Protocol for Use with Network Time Protocol Version 4
https://datatracker.ietf.org/doc/draft-ietf-ntp-mode-6-cmds/

Please review the referenced document and send any comments to the mailing list including your assessment of whether this document is mature enough to proceed to the IESG. Please note that these messages of support for progression to the mailing list will be used to determine WG consensus to proceed. 

Please send all comments in by Friday 15 June 2018.  

Thank you!
Karen and Dieter

---

From: J Ignacio Alvarez-Hamelin <[email-masked]>
Date: Thu, 31 May 2018 09:29:12 -0300

Dear tic-toc-ers,

I read the document thoughtfully, and you find here my comments. Some of them intended to make easier their lecture, aiding the reader (see 1, 2, 3 and 4).

1_ Page 3, section 1.1, 2nd paragraph: the maximum length of 576 can be justified with a cite about UDP (and also adding that it is the DATA of a UDP message).
2_ Page 3, section 1.1, 3er paragraph: adding the names of the fields "R" and "R" help to understand quickly.
3_  Page 3, section 1.1,  4th paragraph: when authors cite "system variables and peer variables" could give an example or some citation.
4_ Page 3, section 1.1, 4th paragraph: it will better point out the exact name of the “Association ID” field directly.
5_ Page 13, section 4, first paragraph: the IP representation only considers IPv4, what about IPv6?
6_ Page 13, section 4, first paragraph: there are different criteria for the timestamp and delay-or- offset (hexadecimal vs. decimal), and perhaps it is inherited of NTP (forgive me my lack of awareness), but it seems not consistent. I think it should be in one format to be clear for every host. Also, this sentence is too long, and it could be cut into two parts, one for the timestamp and another for the delay and offset.
7_ Page 16, section 4, the first paragraph in that page: the term "Regurgitation" can be replaced by "Resending message."

Best regards,

	J. Ignacio

_______________________________________________________________

Dr. Ing. José Ignacio Alvarez-Hamelin
CONICET and Facultad de Ingeniería, Universidad de Buenos Aires
Av. Paseo Colón 850 - C1063ACV - Buenos Aires - Argentina
+54 (11) 5285 0716 / 5285 0705
e-mail: [email-masked]
web: http://cnet.fi.uba.ar/ignacio.alvarez-hamelin/
_______________________________________________________________

> On 31 May 2018, at 00:26, Karen O'Donoghue <[email-masked]> wrote:
> 
> Folks,
> 
> _______________________________________________
> TICTOC mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tictoc