Subject: [Time] questions regarding considered data plane technologies

From: <[email-masked]>
Date: Wed, 11 Jun 2014 08:33:30 +0000

Hi Qin,
What are the data plane technologies that  are considered by TIME for OAM support?
Are the same ones that are being considered for GMPLS, e.g., packet, cell, TDM, wavelength, etc?
Best regards,
Georgios

---

From: Qin Wu <[email-masked]>
Date: Wed, 11 Jun 2014 09:47:05 +0000

Good question.
The assumption we are making at this stage is the network we are tackling should have IP capability.

To support multi-layer OAM, a good candidate data plane technologies we are thinking is BFD protocol since it can work independent of encapsulating protocols, and medium
Types. Other existing data plane technologies can be reused, e.g., existing OAM protocols in layer 1&2&3. The TIME will most focus on how to abstract OAM information common to various
Layer(especially layer 4 to 7) and provide them to management entity via unified interface. It doesn’t matter what kind of data plane technologies are used.

To apply multi-layer OAM to service function chaining environment, new data plane OAM atop layer 3 may be specified. That could be a new shim layer that carries OAM information to support various OAM functions. The TIME also need to think about how to abstract these kind of OAM information from that layer in the form of Generic Yang Data Model.

Regards!
-Qin
发件人: Time [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2014年6月11日 16:34
收件人: [email-masked]
主题: [Time] questions regarding considered data plane technologies

Hi Qin,

---

From: <[email-masked]>
Date: Wed, 11 Jun 2014 10:00:37 +0000

Hi Qin,

Okay, thanks! This is interesting!

It will be great to have an use case that describes how the GMPLS OAM can be supported/enhanced by TIME!

Best regards,
Georgios

From: Qin Wu [mailto:[email-masked]]
Sent: woensdag 11 juni 2014 11:47
To: Karagiannis, G. (EWI); [email-masked]
Subject: RE: questions regarding considered data plane technologies

Good question.

Regards!
-Qin

Hi Qin,

---

From: Qin Wu <[email-masked]>
Date: Wed, 11 Jun 2014 10:06:36 +0000

Good point, we need to decide where Technology Specific OAM is required, and where Generic OAM should be used.
We have initial description of use cases in the draft-ww-opsawg-multi-layer-oam.
We plan to have separate Use Case I-D describing the type of network where Generic OAM is required.
Your contribution and  input are welcome.

Regards!
-Qin
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2014年6月11日 18:01
收件人: Qin Wu; [email-masked]
主题: RE: questions regarding considered data plane technologies

Hi Qin,

Best regards,
Georgios

From: Qin Wu [mailto:[email-masked]]
Sent: woensdag 11 juni 2014 11:47
To: Karagiannis, G. (EWI); [email-masked]<mailto:[email-masked]>
Subject: RE: questions regarding considered data plane technologies

Good question.

Regards!
-Qin
发件人: Time [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2014年6月11日 16:34
收件人: [email-masked]<mailto:[email-masked]>
主题: [Time] questions regarding considered data plane technologies

Hi Qin,