Subject: [Time] Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

From: Qin Wu <[email-masked]>
Date: Wed, 18 Jun 2014 07:36:28 +0000

Different level has different layer OAM. In the abstract level(i.e., Level3), we can use transport independent OAM. All these OAM at different level forms end to end OAM.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 Jun 2014 08:34:54 +0000

Hi Qin,
I'd note that IP and IP/MPLS do not have definitions of MEP and MIP. These, Up and Down MEP and MIP, been only defined in Ethernet and MPLS-TP so far. Thus I believe that we should start with defining these, their location relative to traffic, ports, switching elements, and etc. Further, we should look whether IP and IP/MPLS support only e2e service OAM or Segment and/or Link, e.g. through OAM Levels as in Ethernet Service OAM model of IEEE/ITU-T. MPLS-TP, for example, does support Segment OAM though through SPME LSP.

                Regards,
                                Greg

From: Time [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Wednesday, June 18, 2014 12:36 AM
To: [email-masked]
Subject: [Time] Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

---

From: Qin Wu <[email-masked]>
Date: Wed, 18 Jun 2014 08:59:23 +0000

Greg:
Very good comment, this is something important we need to sort out first.
My initial thought to this, we adopt IEEE 802.1ag CFM model and apply these common definitions to both IP/MPLS and Ethernet, MPLS-TP.
Yes, segment OAM and end to end OAM is another common thing we need to sort out.

Regards!
-Qin
发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2014年6月18日 16:35
收件人: Qin Wu; [email-masked]
主题: RE: Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

Hi Qin,
I’d note that IP and IP/MPLS do not have definitions of MEP and MIP. These, Up and Down MEP and MIP, been only defined in Ethernet and MPLS-TP so far. Thus I believe that we should start with defining these, their location relative to traffic, ports, switching elements, and etc. Further, we should look whether IP and IP/MPLS support only e2e service OAM or Segment and/or Link, e.g. through OAM Levels as in Ethernet Service OAM model of IEEE/ITU-T. MPLS-TP, for example, does support Segment OAM though through SPME LSP.

                Regards,
                                Greg

From: Time [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Wednesday, June 18, 2014 12:36 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Time] Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 Jun 2014 09:08:13 +0000

Hi Qin,
my understanding is that OAM domain, Maintenance Points are applicable only to connection oriented network domains. Hence these been defined to subset of MPLS – MPLS Traffic Profile, not the IP/MPLS which presents connectionless environments. That may explain why there’s no such model for IP yet.

                Regards,
                                Greg

From: Qin Wu [mailto:[email-masked]]
Sent: Wednesday, June 18, 2014 1:59 AM
To: Gregory Mirsky; [email-masked]
Subject: RE: Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

Greg:

Regards!
-Qin
发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2014年6月18日 16:35
收件人: Qin Wu; [email-masked]<mailto:[email-masked]>
主题: RE: Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

Hi Qin,

                Regards,
                                Greg

---

From: Qin Wu <[email-masked]>
Date: Wed, 18 Jun 2014 09:16:20 +0000

Good point, I see the reason.
I think it may be a good idea to apply these definitions to technology independent OAM whether is connection oriented or connectionless.
Yes, for technology independent OAM protocol, we still need to distinguish which OAM functions are for connection oriented and which OAM functions are connectionless.
Does this make sense?

Regards!
-Qin
发送时间: 2014年6月18日 17:08

Hi Qin,

                Regards,
                                Greg

From: Qin Wu [mailto:[email-masked]]
Sent: Wednesday, June 18, 2014 1:59 AM
To: Gregory Mirsky; [email-masked]<mailto:[email-masked]>
Subject: RE: Use Case1 for Transport Independent OAM in Multi-Layer Environment (TIME): Multi-Level OAM

Greg:

Regards!
-Qin

Hi Qin,

                Regards,
                                Greg