Subject: [Time] Transport Independent OAM Requirements

From: Qin Wu <[email-masked]>
Date: Wed, 18 Jun 2014 07:18:26 +0000

Hi,all:
Thanks for Gerogies to raise this issue to me.
I like to discuss Transport Independent OAM Requirements.
What are the requirements that we need to apply in TIME in order to identify the mechanisms, models and protocol to be worked out within TIME?
o) What is the information that needs to be collected/disseminated?

[Qin]: My Initial thought about this is
Common OAM information
a.Measurement Domain
b.Measurement Level
c.Measurement Endpoint (MEP)
d. Measurement Intermediary point (MIP)
e. Measurement Association
f. On demand OAM vs Continuous OAM (Connectionless OAM and Connection oriented OAM)
g.Proactive Activation vs On Demand Activation
h.Point to Point OAM and Point to Multi-Point OAM

o) How can this information be modelled?

[Qin]: We can use Yang Data model. But it doesn't exlude other model languages.

o) How is the information being collected and disseminated?

[Qin]We can either use SNMP, or NetConf to collect or disseminate these information.
We prefer to use NetConf protocol.

o) How often (is this periodic or event based) needs this information to be requested and distributed?\

[Qin]: First,It is up to what management plane protocol is selected.
Second, OAM test can triggered on demand or can be performed continuously and collect information periodically.

o) What is the security and privacy that needs to be applied?

[Qin]: It is up to what management plane protocol is selected.

o) Which are the entities that are involved in the above communication procedure?

[Qin]: I think I at least two type of entities that need to involved in. One is management plane entity,e.g., OSS/NMS, the other is network element that is managed by OSS/NMS
o) Are the TIME mechanisms/protocols  technology independend and applied along multiple administrative domains? If yes, what are the additional requirements compared to technology dependend (one technology) mechanisms and protocols applied only to one administrative domain?
Yes, we are focusing on technology independent OAM and we are looking for consolidation in both data plane and management plane.
Yes, it could be applied across domain. So we need to decide the measurement domain, measurement level, measurement endpoints, measurement intermediary point,
For service function chains, it will be more complicated to setup measurement domain and decides measurement endpoints.

---

From: <[email-masked]>
Date: Wed, 18 Jun 2014 08:51:38 +0000

Hi Qin,

Thanks for the provided answers!

It will be great to hear the opinion of others on your answers!

Best regards,

Georgios

________________________________
Van: Time [[email-masked]] namens Qin Wu [[email-masked]]
Verzonden: woensdag 18 juni 2014 9:18
Aan: [email-masked]
Onderwerp: [Time] Transport Independent OAM Requirements

Hi,all:

[Qin]: We can use Yang Data model. But it doesn’t exlude other model languages.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 18 Jun 2014 09:01:21 +0000

Hi Qin,
please consider my comments in-line and tagged GIM>>.

                Regards,
                                Greg

From: Time [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Wednesday, June 18, 2014 12:18 AM
To: [email-masked]
Subject: [Time] Transport Independent OAM Requirements

Hi,all:
GIM>> I believe these top questions are our primary focus. Without them we would not be able to make any progress in correlating Ethernet Service OAM to IP and/or MPLS layers.
GIM>> I think that we cannot equate on-demand OAM with connectionless mode. Ethernet Service OAM is, IMO, connection-oriented though it has on-demand OAM tools, e.g. Loopback, Linktrace, DMM/DMR, and LMM/LMR. At the same time Continious OAM cannot be viewed as analogous to Connection-oriented OAM, as BFD operates in connectionless IP though continuously.

g.Proactive Activation vs On Demand Activation
h.Point to Point OAM and Point to Multi-Point OAM
GIM>> There are few attempts of p2mp OAM, e.f. CFM and BFD for multi-point networks. I'm not aware of p2mp Performance Measurement OAM.

---

From: Qin Wu <[email-masked]>
Date: Wed, 18 Jun 2014 09:30:57 +0000

发件人: Gregory Mirsky [mailto:[email-masked]]
发送时间: 2014年6月18日 17:01
收件人: Qin Wu; [email-masked]
主题: RE: Transport Independent OAM Requirements

Hi Qin,

                Regards,
                                Greg

From: Time [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Wednesday, June 18, 2014 12:18 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [Time] Transport Independent OAM Requirements

Hi,all:

[Qin]: Agree.

[Qin]:Thanks for correction. We need to make distinction about these definitions.

g.Proactive Activation vs On Demand Activation
h.Point to Point OAM and Point to Multi-Point OAM
GIM>> There are few attempts of p2mp OAM, e.f. CFM and BFD for multi-point networks. I’m not aware of p2mp Performance Measurement OAM.
[Qin]: me either, P2MP poses great challenge for performance measurement since P2MP service consists of not a single pair of endpoints.