Subject: [TLS] optional session

From: "Hussam Saeed" <[email-masked]>
Date: Tue, 5 Oct 2004 14:25:34 +0530 (IST)

what is the optional session has been made to reduce the number of
connections in TLS?
why we are XORing the plaintext with the output generated from PRF in the
stream cipher encryption?

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Jostein Tveit <[email-masked]>
Date: Tue, 05 Oct 2004 13:13:52 +0200

> what is the optional session has been made to reduce the number of

Do you mean optional session caching?
Session caching is a mechanism to reduce the cost of establishing
a new SSL connection. You can read about session caching in
RFC2246 or "SSL and TLS" by Eric Rescorla.

> stream cipher encryption?

To encrypt the plaintext :)

-- 
Jostein Tveit ([email-masked])