Subject: Re: [TLS] Proposed TLS WG recharter

From: Eric Rescorla <[email-masked]>
Date: Thu, 17 Nov 2005 13:14:05 -0800

"Joshua Ball" <[email-masked]> writes:
> WRT 1.2, I would also like to examine the possibility of designing a new
> ciphersuite negotiation scheme, one that allows a more flexible approach
> to choosing the various algorithms individually, rather than on a "per
> ciphersuite" basis. That is to say, I am not against having ciphersuites
> as strict definitions of support. In fact, I think it is crucial that we
> maintain this notion to keep the explosion of possibilities down. But
> this is no reason, IMHO, to not allow each individual variable (i.e.
> symmetric cipher, key exchange, hashes, to be negotiated within a subset
> of those possibilities required for compliance with the standard. 
>
> Yes, this will require considerable design and implementation changes to
> ciphersuite negotiation, but I think going forward it might very well be
> worth it. I think it might be too early to make this a goal, but is this
> something that we might look into? 

So, my position is that this charter doesn't exclude looking
into this, but that it says that we would need to have a strong
argument to actually move forward with it. Does that work for
you?

-Ekr

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: "Joshua Ball" <[email-masked]>
Date: Thu, 17 Nov 2005 11:31:59 -0800

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Eric Rescorla
Sent: Thursday, November 17, 2005 9:32 AM
To: [email-masked]
Subject: [TLS] Proposed TLS WG recharter

Here's my proposed TLS WG recharter. Any comments?

-Ekr

Description of Working Group:
Goals and Milestones:
The TLS Working Group has completed a series of specifications
that describe the Transport Layer Security protocol versions
1.0 and 1.1, extensions to the protocol, and new ciphersuites
to be used with TLS.

The primary goal of the WG is to publish a revision of TLS, 
version 1.2,
that removes the protocol's dependency on the MD5 and SHA-1 digest
algorithms, which have been either wholly or partially compromised by
recent research. The TLS WG will also work on adding major new cipher
suites to TLS, including Counter (CTR) and authenticated encryption
modes. In the preparation of TLS 1.2, the Working Group will attempt
to avoid gratuitous changes to TLS 1.1.

Goals and Milestones
-------------------
Done	  	Agreement on charter and issues in current draft.
Done	  	Final draft for Secure Transport Layer Protocol ('STLP')
Done	  	Working group 'Last Call'
Done	  	Submit to IESG for consideration as a Proposed Standard.
Done	  	First revised draft of TLS specification 
3/06		First revised draft of TLS 1.2 specification.
3/06		Submit specification of Counter Mode cipher suites
		to IESG for publication as Proposed Standard.
3/06		First draft of authenticated encryption mode 
cipher suites
		specification.
12/06		Submit specification of TLS 1.2 specification to
		IESG for publication as Proposed Standard.
12/06		Submit specification of authenticated encryption mode
		cipher suites to IESG for publication as Proposed
		Standard.