Subject: [TLS] question: decode_eror

From: Peter Williams <[email-masked]>
Date: Wed, 20 Dec 2006 12:43:03 -0800

is the TLS1.0 procedure for creating alerts well established AND uniform in 
practice, for the last case below:-
 
      In the interests of forward compatibility, it is permitted for a       client hello message to include extra data after the compression       methods. This data must be included in the handshake hashes, but       must otherwise be ignored. This is the only handshake message for       which this is legal; for all other messages, the amount of data       in the message must match the description of the message       precisely.
For example, are folks required to send the alert: decode_error (mandatory fatal)?
 
What does the IETF require of implementors concerning WHEN this is alert is 
sent, given the server.write queue may have data?
_________________________________________________________________
Fixing up the home? Live Search can help.
http://imagine-windowslive.com/search/kits/default.aspx?kit=improve&locale=en-US&source=wlmemailtaglinenov06

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Wed, 20 Dec 2006 14:58:31 -0800

The TLS extensions RFC retroactively defines a format for the
data that follows the compression methods.  See RFC 4366.  If
the data isn't in that format, then you must send a fatal
decode_error alert.

Mike

Peter Williams wrote:
>       In the interests of forward compatibility, it is permitted for a
>        client hello message to include extra data after the compression
>        methods. This data must be included in the handshake hashes, but
>        must otherwise be ignored. This is the only handshake message for
>        which this is legal; for all other messages, the amount of data
>        in the message must match the description of the message
>        precisely.
> 
> 
> ------------------------------------------------------------------------
> View Athletes' Collections with Live Search. See it! 
> <http://sportmaps.live.com/index.html?source=wlmemailtaglinenov06>
> 
> 
> ------------------------------------------------------------------------
>