Subject: [TLS] Review of draft-salowey-tls-rsa-aes-gcm-00-rev

From: EKR <[email-masked]>
Date: Sat, 10 Mar 2007 12:35:52 -0800

$Id: draft-salowey-tls-rsa-aes-gcm-00-rev.txt,v 1.2 2007/03/10 20:47:45 ekr Exp $

This draft is needed and looks well written. I have two main
comments:

1. Why limit the application to RSA? Given that the suite b document
   gives us GCM for ECC don't we want to provide it here for both
   RSA and DH?
2. We will probably want to harmonize the counter format with
   what was discussed in San Diego (but which I was too lame to
   get a new counter version out). Namely, 4 bytes of salt 
   and 8 bytes of explicit nonce.

-Ekr

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: "Joseph Salowey \(jsalowey\)" <[email-masked]>
Date: Sun, 11 Mar 2007 22:03:51 -0700

> -----Original Message-----
> From: EKR [mailto:[email-masked]] 
> Sent: Saturday, March 10, 2007 12:36 PM
> To: [email-masked]
> Subject: [TLS] Review of draft-salowey-tls-rsa-aes-gcm-00-rev
> 
[Joe] Do you mean adding static DH, anonymous DH or both to this draft?
I don't see any problem adding these. 

>    and 8 bytes of explicit nonce.
[Joe] Definitely, I think that is what we tried to put in the draft, I
may have had some difficulties in getting this expressed.   I agree the
suite b draft and this draft should be in sync as much as possible.

---

From: EKR <[email-masked]>
Date: Sun, 11 Mar 2007 23:14:53 -0700

> I don't see any problem adding these. 

I would think RSA/DSS-DHE?

> suite b draft and this draft should be in sync as much as possible. 

Yeah, the suite b has changed but not been posted yet :(

I'll let you know when I get it fixed.

-Ekr