Subject: Re: [TLS] Straw poll on TLS SRP status

From: Peter Sylvester <[email-masked]>
Date: Mon, 04 Jun 2007 11:15:13 +0200

[email-masked] wrote:
> Folks,
>
> The one remaining issue with TLS SRP is its intended status (Proposed
> Standard, Informational, or Experimental). I and Eric think we need
> more data to determine consensus here, so this message starts a
> two-week straw poll on this issue. (Our apologies that this has 
> taken so long; this poll should have been some time ago already.)
>
> The question is: Do you support advancing draft-ietf-tls-srp as 
> Proposed Standard? 
>
>    [ ] Yes.
>    [ ] I think Informational/Experimental is better.
>    [ ] I don't care about the status, just get it published.
>    [ ] Something else, please state:
>
>   
Yes.

The IPR concerns only a small part of the world's population.

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Jeffrey Altman <[email-masked]>
Date: Mon, 04 Jun 2007 23:44:20 -0400

[email-masked] wrote:
> You may reply either on the list, or privately to the chairs.
I vote Yes.  Proposed Standard.
>
> Some points you may wish to consider, summarizing some of the
> arguments made earlier:
>
> - The document describing SRP-3 (not exactly the same 
>   algorithm as here), RFC 2945, is Proposed Standard.
RFC 2944, Telnet Authentication SRP is also proposed standard.
There are several commercial and open source implementations of RFC 2944
and RFC 2945. 
Those same parties are likely to add support for TLS-SRP as well.

Jeffrey Altman
Secure Endpoints Inc.

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Tue, 5 Jun 2007 12:45:22 +0300

>    [ ] Something else, please state:

I say Yes. I'll only comment on the IP status. SRP is a patented technology 
and the patent holder offers a free license for the patent. The only problem 
is that there are claims by competitive technology patent holders that their
patent applies to SRP. These are unproven claims. 

I see no reason not to move forward with this draft, based only on unproven 
claims made by companies that hold competitive technologies.

regards,
Nikos

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 07 Jun 2007 06:29:46 -0700

>    [ ] I think Informational/Experimental is better.

Informational/Experimental. 

-Ekr