Subject: [TLS] TLS 1.2

From: Mike <[email-masked]>
Date: Sat, 28 Jul 2007 14:42:05 -0700

I realize it's still a moving target, but I updated
my test server to implement TLS 1.2 as of the latest
draft (-04).  You can test against it at

       https://www.mikestoolbox.net

Mike

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Mike <[email-masked]>
Date: Sun, 29 Jul 2007 10:22:19 -0700

I found an issue with hash agility that I think
needs to be addressed.  Right now I can claim to
support all of the hash functions since my code
can handle RSA with SHA-XXX.  I also support DSA
with SHA-1, and since currently that is the only
supported hash function for DSA, I'm OK.

The problem will come about when DSA is changed
to allow the use of SHA-256, etc.  If I were to
leave my code as is, it would suddenly be broken
since if someone were to try using DSA with SHA-
256, it would fail to create/verify signatures.

This means I either need to advertise support for
only SHA-1 and MD5, and wait for my encryption
library provider to support the new DSA modes,
or I can disable all of DSA until my encryption
library supports them, which will allow me to
support RSA with the better SHA algorithms.

Neither of these options is optimal.

I think the solution we need is to specifically
list each supported signature algorithm, e.g.

     enum {
       rsa_with_md5(0),    rsa_with_sha1(1),
       rsa_with_sha256(2), rsa_with_sha384(3),
       rsa_with_sha512(4), dsa_with_sha1(5),
       (65535)
     };

These may not be specific enough, as I've seen
suggestions for, e.g. rsa_pkcs1v1_5_with_sha1,
and I've heard that some algorithms need
parameters, but I think I've made my point.

Mike