Subject: [TLS] opensource implementations of TLS-SRP?

From: Ken Peirce <[email-masked]>
Date: Tue, 24 Jul 2007 07:44:40 -0700 (PDT)

Does anyone know of an opensource TLS SRP implementation?
Cheers,
Ken Peirce

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: Trevor Perrin <[email-masked]>
Date: Tue, 24 Jul 2007 10:37:37 -0700

> Does anyone know of an opensource TLS SRP implementation?

Yes, but they will need to be updated once the RFC issues, since 
assigned numbers will change.

- http://www.edelweb.fr/EdelKey/ (OpenSSL, C-based)
- http://www.trevp.net/tlslite/ (Python-based)
- http://www.gnu.org/software/gnutls/ (C-based, GPL)

(see recent list archives for more detail)

Trevor