Subject: [TLS] Updated TLS ID

From: Eric Rescorla <[email-masked]>
Date: Mon, 29 Oct 2007 14:48:13 -0700

An updated TLS ID can be found at:

https://svn.resiprocate.org/rep/ietf-drafts/ekr/tls/tls.txt

The changes list is:
- Redid the hash function advertisements for CertificateRequest
  and the client-side extension. They are now pairs of
  hash/signature and the semantics are clearly defined for
  all uses of signatures (hopefully). [Issue 41]

- Clarified the DH group checking per list discussion [Issue 35]

- Added a note about DSS vs. DSA [Issue 58]

- Editorial issues [Issue 59]

- Cleaned up certificate text in 7.4.2 and 7.4.6 [Issue 57]

The major change is the first one: I completely overhauled the
signature/hash advertisements as a result of the mailing list
discussion. 

The only open issue I am still aware of is whether we should
have "q" in the DH group info in the ServerKeyExchange. I'm
hoping to get that nailed down this week, then do a final
copy-edit and have a new draft out and ready for WGLC mid Nov.

-Ekr

_______________________________________________
TLS mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tls

---

From: <[email-masked]>
Date: Wed, 31 Oct 2007 17:24:59 +0200

>   all uses of signatures (hopefully). [Issue 41]
<snip>
> - Cleaned up certificate text in 7.4.2 and 7.4.6 [Issue 57]

This looks pretty good. In Section 7.4.2, I think there's
still some room for simplification. Currently it says:

   If no "signature_algorithms" extension is present, the end-entity
   certificate MUST be signed as follows:

      Key Exchange Alg.  Signature Algorithm Used by Issuer

      RSA                RSA (RSASSA-PKCS1-v1_5)
      DHE_RSA
      DH_RSA
      RSA_PSK
      ECDH_RSA
      ECDHE_RSA

      DHE_DSS            DSA
      DH_DSS

      ECDH_ECDSA         ECDSA
      ECDHE_ECDSA

I think it would be simpler to specify the default behavior
in one place, and not to make it ciphersuite-dependent.
E.g. "if the client does not send signature_algorithms,
behave as if rsa+sha1 had been sent". Or we could just require
everyone to send signature_algorithms.

Best regards,
Pasi