Subject: [TLS] SAS extension?

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 29 Jul 2008 14:19:58 -0600

In the XMPP community we are defining a way to use TLS for end-to-end 
encryption. We'd love to use short authentication strings (SAS) for 
identity verification. As far as I can see no one has worked on a TLS 
extension for SAS. Is there interest in doing so? I'd be happy to help 
write an I-D on this topic, but I'm not a TLS or security expert so it 
might not be appropriate for me to lead the effort.

Thanks!

Peter

--
Peter Saint-Andre
https://stpeter.im/
_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: <[email-masked]>
Date: Wed, 30 Jul 2008 21:39:52 +0300

There have been some earlier efforts, but AFAIK they're
not actively worked on:

http://tools.ietf.org/html/draft-fischl-sipping-media-dtls-01
(Section 8.5)

https://svn.resiprocate.org/rep/ietf-drafts/ekr/draft-mcgrew-tls-sas.txt

You might want to contact the authors of those drafts
to discuss more (well, many of them are probably subscribed
to this mailing list, too :).

Best regards,
Pasi

> -----Original Message-----
> From: Peter Saint-Andre
> Sent: 29 July, 2008 23:20
> To: [email-masked]
> Subject: [TLS] SAS extension?
> 
> extension for SAS. Is there interest in doing so? I'd be 
> happy to help write an I-D on this topic, but I'm not a TLS or 
> security expert so it might not be appropriate for me to lead the 
> effort.
> 
> Thanks!
> 
> Peter
> 
> --
> Peter Saint-Andre
> https://stpeter.im/
>