Subject: [TLS] Ordered list of cypher strengths

From: "Olivier MJ Crepin-Leblond" <[email-masked]>
Date: Sat, 17 Oct 2009 12:42:06 +0200

Hello there,

could someone please point me to references or a page discussing cypher strengths and listing them in increasing order, in an email specific context? For example, I'm seeing emails transfers which seem to be using:

- AES256-SHA
- RC4-MD5
- DHE-RSA-AES256-SHA
- ADH-AES256-SHA
- EDH-RSA-DES-CBC3-SHA

etc.

I know of the page: http://www.openssl.org/docs/apps/ciphers.html which lists cypher suites, but are these listed in order of increasing strength?

Warm regards,

-- 
Olivier MJ Crépin-Leblond, PhD
http://www.gih.com/ocl.html

---

From: Michael D'Errico <[email-masked]>
Date: Sat, 17 Oct 2009 08:34:32 -0700

This is a difficult question to answer.  There are three factors to
consider when determining the relative strengths of cipher suites.
First there is the key exchange mechanism, such as RSA, DHE_DSS, etc.
Second is the bulk encryption algorithm and key length, and third is
the MAC.

The key exchange mechanism is problematic because there is no way to
specify the key length by the client; the server selects it.  Many
servers use 1024-bit RSA keys and 1024-bit Diffie-Hellman parameters
which roughly correspond to "only" 80 bits of security.  This may be
the weak link.  Using AES-256 may provide no more security than RC4
if a 1024-bit RSA key exchange is done.

I know this is not the answer you were hoping for, but the reality
is you can't create the list you want.

Also, with email, messages are only protected in transit.  The server
at each hop will have the full plaintext of your message.  And even
if the first hop uses TLS for that transfer, there is no guarantee
that TLS will be used on every transfer all the way to the recipient.
And then once it's at the recipient, you don't know that they've set
up their mail client to use TLS with POP3 or IMAP.

Mike
----
http://mikestoolbox.com

Olivier MJ Crepin-Leblond wrote:
> Hello there,
>  
> could someone please point me to references or a page discussing cypher 
> strengths and listing them in increasing order, in an email specific 
> context? For example, I'm seeing emails transfers which seem to be using:
>  
> - AES256-SHA
> - RC4-MD5
> - DHE-RSA-AES256-SHA
> - ADH-AES256-SHA
> - EDH-RSA-DES-CBC3-SHA
>  
> etc.
>  
> I know of the page: http://www.openssl.org/docs/apps/ciphers.html which 
> lists cypher suites, but are these listed in order of increasing strength?
>  
> Warm regards,
>  
> --