Subject: Re: [TLS] Conflicts between W3C specs and ES5?

From: David-Sarah Hopwood <[email-masked]>
Date: Wed, 18 Nov 2009 05:08:58 +0000

Brendan Eich wrote:
> On Nov 17, 2009, at 6:41 PM, Maciej Stachowiak wrote:
> 
>>>> otherWindow.copyOfEvalFromYetAnotherWindow("...") throws
[...]
>>>
>>> What is the rationale for throwing in this last case, rather than
>>> using the explicit base object (otherWindow) as |this|?
[...]
> The standard ECMA-262 semantics want otherWindow -- "bound method"
> exceptions prove the rule.

There are bound methods in ES implementations? I'm all ears.

(One thing I've never understood is why ES implementors add features
or exceptional behaviour that users of the language could only find,
or even know to look for, by reverse engineering or guesswork. What's
the point? Doesn't it take more work to add all this stuff?)

-- 
David-Sarah Hopwood  ⚥  http://davidsarah.livejournal.com

---

From: David-Sarah Hopwood <[email-masked]>
Date: Wed, 18 Nov 2009 23:24:22 +0000

Oops, wrong mailing list. Sorry about that.