Subject: [TLS] no_renegotiation alert and SSLV3

From: "Robert Dugal" <[email-masked]>
Date: Tue, 22 Dec 2009 08:09:41 -0500

I am wondering what to do for section 6.2 of
draft-ietf-tls-renegotiation-02.txt when SSLv3 is negotiated and RI/SCSV
was not in the ClientHello.   

The no_renegotiation alert was not defined in SSLv3. 

-- 

Robert Dugal                        Senior Software Developer

Certicom Corp.                    A Subsidiary of Research In Motion 

[email-masked]

direct        905.501.3848

fax             905.507.4230

www.certicom.com

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Martin Rex <[email-masked]>
Date: Tue, 22 Dec 2009 14:57:05 +0100 (MET)

> The no_renegotiation alert was not defined in SSLv3. 

If you want to abort the handshake, you could send a fatal handshake alert.

I admit to have no relevant implementation experience in that
area, but if your objective is to permit the client to continue
without renegotiation, I would try the pragmatic approach and
send the no_renegotation alert with warning level anyway.

This could work at least for those clients that are merely configured
to use SSLv3 and not _limited_ to SSLv3.

-Martin

---

From: Martin Rex <[email-masked]>
Date: Tue, 22 Dec 2009 15:29:18 +0100 (MET)

> If you want to abort the handshake, you could send a fatal handshake alert.

I meant fatal handshake_failure(40) alert.

-Martin