Subject: Re: [TLS] fyi: paper on compelled, certificate creation attack and applicable appliance

From: Yoav Nir <[email-masked]>
Date: Thu, 25 Mar 2010 04:22:50 +0200

On Mar 24, 2010, at 6:41 PM, Peter Gutmann wrote:

> Yoav Nir <[email-masked]> writes:
> 
>> 2. Section 5 is entitled "evidence", and then goes on to present the
>> evidence: a marketing brochure and something someone told him at a booth in a
>> trade show.
> 
> I've seen the same thing done with a $29 Openmesh box but without the cert
> MITM, it relies on the Hamming distance between an SSL and non-SSL site being
> so minute that users don't notice, and in practice no-one did.  Worked really
> well, I have some screenshots of it in action with a banking site and
> Verisign's site-seal in my book draft at
> http://www.cs.auckland.ac.nz/~pgut001/pubs/book.pdf search for "EV
> Certificates: PKI-me-Harder" and scroll down about two pages.  No need to mess
> with SSL's PKI when it doesn't work anyway, read the surrounding text for
> details.
> 
> Peter.

Interesting stuff. 

Maybe the STS initiative could defeat those other ways well enough that you really have to mess with SSL's PKI.

http://lists.w3.org/Archives/Public/www-archive/2009Sep/att-0051/draft-hodges-strict-transport-sec-05.plain.html
or
http://en.wikipedia.org/wiki/Strict_Transport_Security

---

From: Adam Langley <[email-masked]>
Date: Thu, 25 Mar 2010 13:57:47 -0400

> http://en.wikipedia.org/wiki/Strict_Transport_Security

I haven't mentioned this on the list yet, and it's not an answer to
the problems in this papers, but we are actively welcoming entries on
the Preloaded STS list. If you know someone who runs a major HTTPS
site, please mention it.

http://dev.chromium.org/sts:

Preloaded STS sites

There is still a window where a user who has a fresh install, or who
wipes out their local state, is vulnerable. Because of that, we'll be
starting a "Preloaded STS" list. These domains will be configured for
STS out of the box. In the beginning, this will be hardcoded into the
binary. As it (hopefully) grows, it can change into a list this is
shared across browsers, like the safe-browsing database is today.

If you own a site that you would like to see included in the preloaded
STS list, contact [email-masked].

Current members of the preloaded STS list:

    * www.paypal.com

AGL