Subject: Re: [TLS] TLS 1.2 test clients?

From: "Davies, Joshua" <[email-masked]>
Date: Tue, 1 Feb 2011 08:47:19 -0600

I wrote a sample TLS 1.2 client as a companion to a book - you can download the source from http://media.wiley.com/product_ancillary/16/04709204/DOWNLOAD/920411%20implementing_ssl_gcc.zip .  The TLS 1.2 client is in the "after/ch9" directory; just run:

$ make
$ ./https https://whatever.com

It's not especially robust (it will crash if you try to connect to a pre-TLS 1.2 server, for example), but you might find it useful for experimentation purposes if you want to change, for example, the PRF hash function or allow null cipher specs.
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Xuelei Fan [[email-masked]]
Sent: Monday, January 31, 2011 10:38 PM
To: Paul Hoffman
Cc: [email-masked]
Subject: Re: [TLS] TLS 1.2 test clients?

The recent JDK 7 snapshot releases support TLS 1.2 (see
http://download.java.net/jdk7/). You're able to get and run the very
simple sample code for simple HTTPS connections from
http://download.oracle.com/javase/7/docs/technotes/guides/security/jsse/JSSERefGuide.html#HTTPSSample.

If you run Java with "-Djavax.net.debug=all -Dhttps.protocols=TLSv1.2"
options, you would be able to find the detailed debugging log for
TLS/SSL handshaking.

About the detained tech guides, please refer to
http://download.oracle.com/javase/7/docs/technotes/guides/security/jsse/JSSERefGuide.html.

Xuelei Fan
Java Platform, Oracle

On 2/1/2011 12:35 AM, Paul Hoffman wrote:
> Greetings again. I would like to test how servers react to a TLS
> client that only does TLS 1.2. There are two browsers that can be put
> into this state (IE under Win 7, and Opera), but neither give very
> good diagnostics when a failure occurs. Further, Wireshark doesn't
> give good dumps for TLS 1.2.
>
> Thus, if anyone here has a TLS 1.2 client that has reasonable
> debugging of the TLS handshake and can do trivial HTTP (just send a
> "GET /" and receive the response would be fine) after setting up a
> tunnel, I'd greatly appreciate it. Also, if anyone has a Wireshark
> plugin (?) that brings its TLS decoding up to 1.2, that would be great
> as well.
>
> --Paul Hoffman, Director
> --VPN Consortium
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---

From: <[email-masked]>
Date: Mon, 7 Feb 2011 20:57:00 -0500

RSA BSAFE Share for JavaTM Platform supports TLS 1.2. You can download the toolkit and samples from here: https://community.emc.com/docs/DOC-4741  There is a sample to show you how to create a TLS client which only support certain protocol versions.

Peter
------------------------------------------------
Peter Robinson - [email-masked]
Engineering Manager
RSA, The Security Division of EMC - http://www.rsa.com/
Level 32, Waterfront Place, 1 Eagle Street, Brisbane, Queensland 4000, AUSTRALIA.
Phone: +61 7 3227 4427, Mobile: +61 407 962 150, Fax: +61 7 3227 4400.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Paul Hoffman
Sent: Tuesday, 1 February 2011 2:36 AM
To: [email-masked]
Subject: [TLS] TLS 1.2 test clients?

Greetings again. I would like to test how servers react to a TLS client 
that only does TLS 1.2. There are two browsers that can be put into this 
state (IE under Win 7, and Opera), but neither give very good 
diagnostics when a failure occurs. Further, Wireshark doesn't give good 
dumps for TLS 1.2.

Thus, if anyone here has a TLS 1.2 client that has reasonable debugging 
of the TLS handshake and can do trivial HTTP (just send a "GET /" and 
receive the response would be fine) after setting up a tunnel, I'd 
greatly appreciate it. Also, if anyone has a Wireshark plugin (?) that 
brings its TLS decoding up to 1.2, that would be great as well.

--Paul Hoffman, Director
--VPN Consortium