Subject: [TLS] Request for review: Camellia cipher suites for TLS

From: Satoru Kanno <[email-masked]>
Date: Fri, 04 Feb 2011 18:25:11 +0900

Folks,

I've submitted "draft-kanno-tls-camellia-00".
 URL: http://www.ietf.org/internet-drafts/draft-kanno-tls-camellia-00.txt

We merged three drafts into one draft. We included all additional cipher
suites in a single draft to make it easier on implementers.
But the cipher suites with SHA-1 are not included in this draft.

Existing three drafts:
 - draft-kanno-tls-camellia-ecc-sha
 - draft-kanno-tls-camellia-psk
 - draft-kanno-tls-camellia-gcm

New draft includes features as a following:
 - SHA2 variants
 - ECDH(E) and ECDSA
 - Galois/Counter Mode
 - Pre-shared key

Comments about our document would be welcome.

We plan to make this draft to next step 'Publication Request'
within two weeks.

Regards,

----------------------------------------------------------------
A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title           : Addition of the Camellia Cipher Suites to Transport
Layer Security (TLS)
	Author(s)       : S. Kanno, M. Kanda
	Filename        : draft-kanno-tls-camellia-00.txt
	Pages           : 11
	Date            : 2011-02-04

This document specifies forty-two cipher suites for the Transport
Security Layer (TLS) protocol to additional support the Camellia
encryption algorithm as a block cipher.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-kanno-tls-camellia-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

-- 
Satoru Kanno

Security Business Unit
Mobile and Security Solution Business Group
NTT Software Corporation

e-mail: [email-masked]

---

From: Simon Josefsson <[email-masked]>
Date: Fri, 04 Feb 2011 14:04:56 +0100

>  URL: http://www.ietf.org/internet-drafts/draft-kanno-tls-camellia-00.txt

I cannot find an IPR statement when searching for that draft on the IETF
IPR Disclosure search page:

https://datatracker.ietf.org/ipr/search/?option=document_search&id_document_tag=21179

Since Camellia is patented by NTT, I believe you need to submit an IPR
disclosure for this document.

/Simon

---

From: Sean Turner <[email-masked]>
Date: Fri, 04 Feb 2011 20:45:18 -0500

On 2/4/11 8:04 AM, Simon Josefsson wrote:
> Satoru Kanno<[email-masked]>  writes:
>
>> Folks,
>>

There is this:

https://datatracker.ietf.org/ipr/41/

spt