Subject: [TLS] AES-GCM implementation

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Sat, 05 Feb 2011 09:05:28 +0100

Hello,
 Are there any public servers implementing the AES-GCM (RFC5288)
ciphersuites for TLS?

regards,
Nikos

---

From: Rob P Williams <[email-masked]>
Date: Mon, 7 Feb 2011 06:32:52 -0500

Hi,

You can confirm interop against tls.secg.org

Thanks.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nikos Mavrogiannopoulos
Sent: Saturday, February 05, 2011 3:05 AM
To: [email-masked]
Subject: [TLS] AES-GCM implementation

Hello,

regards,
Nikos

_______________________________________________
TLS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tls

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Mon, 07 Feb 2011 13:50:43 +0100

> You can confirm interop against tls.secg.org

Thank you. It seems we interoperate.

regards,
Nikos

---

From: Nasko Oskov <[email-masked]>
Date: Fri, 11 Feb 2011 18:29:39 +0000

>Sent: Saturday, February 05, 2011 12:05 AM
>To: [email-masked]

The interop server we have at Microsoft supports AES-GCM. The address is tls.woodgrovebank.com.
Let me know if you have any troubles trying to interop.

Thanks,
Nasko Oskov

---

From: "Davies, Joshua" <[email-masked]>
Date: Fri, 11 Feb 2011 13:14:08 -0600

Which cipher suites?  I just sent a client hello with TLS_RSA_WITH_AES_128_GCM_SHA256 (0x009C) and tls.woodgrovebank.com terminated the connection without responding with a server hello.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Nasko Oskov
Sent: Friday, February 11, 2011 12:30 PM
To: Nikos Mavrogiannopoulos; [email-masked]
Subject: Re: [TLS] AES-GCM implementation

Thanks,
Nasko Oskov

---

From: Wan-Teh Chang <[email-masked]>
Date: Fri, 11 Feb 2011 11:48:56 -0800

On Fri, Feb 11, 2011 at 11:14 AM, Davies, Joshua
<[email-masked]> wrote:
> Which cipher suites?  I just sent a client hello with
> TLS_RSA_WITH_AES_128_GCM_SHA256 (0x009C) and tls.woodgrovebank.com
> terminated the connection without responding with a server hello.

Since Internet Explorer advertises support for only the two ECDHE-ECDSA
AES-GCM cipher suites (apparently for Suite B compliance), the Microsoft
interop test server is unlikely to support TLS_RSA_WITH_AES_128_GCM_SHA256.

Wan-Teh Chang

---

From: Geoffrey Keating <[email-masked]>
Date: 11 Feb 2011 13:49:18 -0800

> terminated the connection without responding with a server hello.

If you connect to https://tls.woodgrovebank.com/Cipersuites.htm, it
tells you which cipher suites it supports.  It appears to support GCM
only with ECDSA.

---

From: Adam Langley <[email-masked]>
Date: Fri, 11 Feb 2011 17:45:25 -0500

> tells you which cipher suites it supports.  It appears to support GCM

Although the certificate has expired: "Not After : Jan 26 00:29:01 2011 GMT"

AGL

---

From: Martin Rex <[email-masked]>
Date: Sat, 12 Feb 2011 01:34:08 +0100 (MET)

> tells you which cipher suites it supports.  It appears to support GCM

The information at 

  https://tls.woodgrovebank.com/Ciphersuites.htm

seems to contain errors (but otherwise align with productive SChannel):

It says:

  TLS_RSA_WITH_AES_128_CBC_SHA      0x002F       All Supported

but as previously discussed, SChannel unnecessarily aborts when receiving
only this ciphersuite along with ClientHello.client_version = {0x03,0x00}

TLS_RSA_WITH_3DES_EDE_CBC_SHA  0x000a works with client_version {0x03,0x00}

-Martin

---

From: Nasko Oskov <[email-masked]>
Date: Tue, 15 Feb 2011 17:59:41 +0000

>From: [email-masked] [mailto:[email-masked]] On Behalf Of Adam Langley
>Sent: Friday, February 11, 2011 2:45 PM
>To: Geoffrey Keating
>Cc: Davies, Joshua; [email-masked]

This should be now fixed.
Thanks,
Nasko