Subject: Re: [TLS] Rizzo claims implementation attach, should be interesting

From: =JeffH <[email-masked]>
Date: Mon, 12 Sep 2011 10:45:27 -0700

perhaps based on  similar attacks against the
predictable implicit IV in SSL 3.0 and TLS 1.0 described several years ago by
Greg Bard:

A CHALLENGING BUT FEASIBLE BLOCKWISE-ADAPTIVE
CHOSEN-PLAINTEXT ATTACK ON SSL
<http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.61.5887&rep=rep1&type=pdf>

?

=JeffH

---

From: =JeffH <[email-masked]>
Date: Tue, 20 Sep 2011 16:31:50 -0700

Martin Rex <[email-masked]> noted..
 >
 > I haven't yet seen a detailed description of the BEAST attack, but
 > what has been leaked so far (and that TLSv1.1 is allegedly not
 > susceptible to this particular attack) suggests that they're
 > exploiting a definite design flaw in the web browser that exhibits an
 > obvious and serious negligence in the management of TLS connection states
 > therefore providing a free "chosen adaptive plaintext attack" facility
 > as a courtesy to the attacker besides the courtesy to run arbitrary
 > attacker-supplied active content.

uh, yes, web browsers are full of such issues, some by accident, some (more or 
less) by design.This provides a high-level & very brief survey & bibliography 
of the landscape..

The Need for a Coherent Web Security Policy Framework
<http://kingsmountain.com/doc/HodgesSteingruebl-NeedCoherentWebSecurityPolicyFramework-2010.pdf>

See also..

Browser Security Handbook
https://code.google.com/p/browsersec/wiki/Main

=JeffH