Subject: [TLS] TLS Next Proto Negotiation

From: [email-masked]
Date: 5 Sep 2011 04:25:13 -0000

Hi,
Thanks Adam, for confirming that we need to use the Next Protocol handshake message in plain for FINISH computation. Now that this message is 32 byte padded, do we need to use the padbytes also for finish calcualtion or use only the message until padbytes only.
Thanks and Regards,
Swarupa.G

---

From: Adam Langley <[email-masked]>
Date: Mon, 5 Sep 2011 10:11:45 -0400

> Thanks Adam, for confirming that we need to use the Next Protocol handshake message in plain for FINISH computation. Now that this message is 32 byte padded, do we need to use the padbytes also for…

The pad bytes are included.

Cheers

AGL