Subject: Re: [TLS] Working group last call for draft-ietf-tls-dtls-heartbeat-02

From: Joe Salowey <[email-masked]>
Date: Mon, 26 Sep 2011 15:10:51 -0700

Working group last call has completed and there were a few minor revisions suggested.  Authors, please submit a revised draft to be submitted to the IESG.

Thanks,

Joe
On Aug 21, 2011, at 10:07 PM, Joe Salowey wrote:

> This announcement is for the working group last call of  draft-ietf-tls-dtls-heartbeat-02.  Please send comments to the list by September 09, 2011.  
> 
> 
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Michael Tüxen <[email-masked]>
Date: Tue, 27 Sep 2011 22:50:24 +0200

> Working group last call has completed and there were a few minor revisions suggested.  Authors, please submit a revised draft to be submitted to the IESG.
Done.

The changes based on comments on the list between the -02 and -03 version are:

* Grammar / spelling.
* Some general clarifications in the text.
* Clarification of the formulas regarding the padding length
* Registry policies changed from Specification Required to Expert Review
* Reference to RFC4347 replaced by draft-ietf-tls-rfc4347-bis-06

Robin has updated the patch for OpenSSL which is available at
http://sctp.fh-muenster.de/dtls-patches.html
to this latest version. While doing that one additional detail was addressed:
When using a reliable transport protocol, TLS/DTLS does not run timers.
So it does not make sense to introduce one just for this extension.
Therefore the last sentence of section 3 was changed from

 If no corresponding HeartbeatResponse message has been received after a user configured
 amount of time, the DTLS/TLS connection SHOULD be terminated.

to

 If no corresponding HeartbeatResponse message has been received after some amount of
 time, the DTLS/TLS connection MAY be terminated by the user.

In the OpenSSL implementation a function is provided to figure out if a HB is in-fight.
So the application can check if a HB-Response has been received anytime it wants
and can take the appropriate action.

Best regards
Michael