Subject: [TLS] draft-agl-tls-chacha20poly1305-03

From: SM <[email-masked]>
Date: Sat, 16 Nov 2013 11:52:29 -0800

Hi Adam,

For what it is worth, OpenSSH implemented ChaCha20-Poly1305 based on 
what is proposed in draft-agl-tls-chacha20poly1305-03.

Regards,
-sm

---

From: Adam Langley <[email-masked]>
Date: Sat, 16 Nov 2013 15:43:55 -0500

On Sat, Nov 16, 2013 at 2:52 PM, SM <[email-masked]> wrote:
> For what it is worth, OpenSSH implemented ChaCha20-Poly1305 based on what is
> proposed in draft-agl-tls-chacha20poly1305-03.

Yea. I told djm that he should match the AEAD construction exactly
because then he would be able to use the OpenSSL API in the future,
but to no avail :)

Cheers

AGL