Subject: [TLS] TLS chairing changes

From: Stephen Farrell <[email-masked]>
Date: Tue, 11 Mar 2014 22:54:59 +0000

Hiya,

Now that the TLS WG has rechartered to work on TLS 1.3, I've
been chatting with the chairs and we wanted to announce some
adjustments intended to help that effort.

Effective April 1st, Sean Turner will become a third TLS
co-chair in order to free up Eric who will be a TLS 1.3
document editor. (Sean picked the date, it really means
whenever he gets back from his post-AD vacation so it could
be in a week or so:-)

Eric will stay on as co-chair to help Sean get up to speed
but the plan is for him to step down as chair around about
IETF 90 in July. And Joe will continue chairing with Sean
from then onwards.

Many thanks to Joe and Eric for their ongoing efforts and
thanks also to Sean for being willing to get back into the
saddle for such an important WG so quickly.

Cheers,
S.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 11 Mar 2014 22:22:00 -0400

> Many thanks to Joe and Eric for their ongoing efforts and thanks also to Sean for being willing to get back
> into the saddle for such an important WG so quickly.

Hear, hear!

And interesting to hear that Sean is such a glutton for punishment. :)

	/r$

--  
Principal Security Engineer
Akamai Technology
Cambridge, MA

---

From: Trevor Perrin <[email-masked]>
Date: Wed, 12 Mar 2014 08:06:54 -0700

On Tue, Mar 11, 2014 at 3:54 PM, Stephen Farrell
<[email-masked]>wrote:

> document editor.

Hi Stephen,

There was discussion about having a more competitive process for TLS 1.3
[1].

I guess it's been decided to not do that, to use Eric's draft as a base,
and appoint Eric as editor?

Could you remind me where the WG reached consensus on all this?

Trevor

[1] http://www.ietf.org/mail-archive/web/tls/current/msg10533.html

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 12 Mar 2014 15:43:41 +0000

Hi Trevor,

> There was discussion about having a more competitive process for TLS 1.3

I'm not at all sure a "competition" is the right way to pick
an initial draft as a starting point. Of course, people are
free to write any I-D they choose and propose that to the WG,
but I think that the process being followed so far of discussing
the features and building from those seems to be going fine.

> and appoint Eric as editor?

No, however I think that's a reasonably likely occurrence so
we're planning for making the process easier and cleaner in
the case where it happens.

> Could you remind me where the WG reached consensus on all this?

Its up to the chairs to decide that, and they will, and part of
that would be that Eric moving from chairing creates a good option.

And in any case, while the WG consensus will I'm sure be tested
at all the right places, you should bear in mind that its entirely
up to the WG chairs to hire (and fire) document editors.

Lastly, I'd suggest giving Sean a week or so to get back from
vacation and chat in detail with Joe and Eric and then I'm sure
they'll be proposing how to go forward from there.

Cheers,
S.

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 12 Mar 2014 09:49:07 -0600

> the features and building from those seems to be going fine.

IMHO, basically starting from RFC 5246 will improve transparency. 
Speaking of which, let me send the XML-ized version I have to Eric.

Peter

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 13 Mar 2014 11:32:30 +1100

On 13 Mar 2014, at 2:49 am, Peter Saint-Andre <[email-masked]> wrote:

> IMHO, basically starting from RFC 5246 will improve transparency. Speaking of which, let me send the XML-ized version I have to Eric.

I have a markdown-ized version nearing completion; all that needs to be done is converting some of the references and a bit of cleanup.

EKR, should I continue that, or do you want to go XML? If I slap it on github and get help from a few people, it shouldn't take long.

Cheers,

--
Mark Nottingham   http://www.mnot.net/

---

From: Trevor Perrin <[email-masked]>
Date: Thu, 13 Mar 2014 12:51:43 -0700

> the features and building from those seems to be going fine.

I thought EKR's drafts were more of a brainstorming / strawman to get
people thinking about things [1,2].

I assumed at some point after re-chartering we'd discuss process,
timelines, and requirements some more, and have an open process for TLS 1.3
candidates.  Until your email, it wasn't made clear - at least to the list
- that EKR's draft was the presumptive TLS 1.3.

It's great that EKR's draft is driving discussion.  But that draft makes
many choices which may be optimal, or may not:

 * For an initial handshake, EKR's draft recommends a 2-RTT flow with 2 DH
computations.  I think it could also support a flow with 1-RTT, 2 DH, and
reduced foward secrecy for the first RT of Application Data.  This seems a
step backwards from current TLS, which can support a False-Start handshake
with 1-RTT, 1 DH, and full forward secrecy.

 * For a "reconnect" handshake, EKR's draft performs DH with a
"semi-static" DH key.  This is more computation than a traditional
session-ticket resumption.

 * EKR's draft assumes we want to reuse TLS structures as much as possible,
for simplicity.  An alternative would be to design structures which are
more different from TLS, but more simple in their own right.

And there's a lot else to be decided wrt key agreement, ciphersuites,
renegotiation, SNI, potential integration with (Client Auth, ChannelID,
PAKE, TACK), etc.

Anyways, I'd prefer a process where the WG held off from anointing a single
draft as "the" TLS 1.3 WG item for several months, and invited individual
contributions.  Eric's draft would be such a contribution, but so could
designs based on QUIC or MinimaLT, or anything else.

This would let us to explore the design space via comparing and contrasting
different designs.  Once the WG was satisfied that it preferred one
candidate, this would be made a WG item for finishing the spec.

Trevor

[1] http://www.ietf.org/mail-archive/web/tls/current/msg10404.html
[2] http://www.ietf.org/mail-archive/web/tls/current/msg11300.html

---

From: Stephen Farrell <[email-masked]>
Date: Thu, 13 Mar 2014 21:20:42 +0000

Trevor,

> - that EKR's draft was the presumptive TLS 1.3.

I must be crap at writing mail;-) I thought I had said all of:

- We will as always have an open process.
- "discussing the features and building from those" does not mean
  that any particular I-D has been adopted by the WG
- and as I said, the chairs organise whatever consensus calls are
  needed (incl. for WG adoption of initial drafts if needed)

And lastly (again), maybe wait a week until Sean, Joe and Eric
have time to talk before setting the innuendo flying? There really
is no need to fuss in the meantime.

Thanks,
S.