Subject: [TLS] Presentation language parser on github

From: "Salz, Rich" <[email-masked]>
Date: Thu, 1 May 2014 12:13:19 -0400

Some folks may remember I wrote a parser for the language used in the TLS RFC's.  I put it on github, https://github.com/richsalz/tlsparser As a learning exercise in git.

There are some minor nits and such that I'll raise issues for.  BTW, better to open an issue, make a fix and do a pull request (more learning!) or both?

The biggest one is that "ASN1.Cert" is used all over the place, and that period is annoying to the parser. Can we make the usage be "ASN1Cert" throughout?

--
Principal Security Engineer
Akamai Technologies, Cambridge, MA
IM: [email-masked]<mailto:[email-masked]>; Twitter: RichSalz

---

From: Martin Thomson <[email-masked]>
Date: Thu, 1 May 2014 11:02:38 -0700

On 1 May 2014 09:13, Salz, Rich <[email-masked]> wrote:
> There are some minor nits and such that I’ll raise issues for.  BTW, better
> to open an issue, make a fix and do a pull request (more learning!) or both?

Sorry, couldn't help myself:
https://github.com/tlswg/tls13-spec/pull/30

In my experience, the preference order for editorial/minor stuff like this is:
1. pull request
2. issue
3. email

Issues with actual substance are best handled with email, or
email+issue if you are certain that it's an issue.  If you have a
proposal for a fix, a pull request helps, but I often find that it's
best to wait until some discussion has happened.