Subject: Re: [TLS] IPR Disclosure: INEOVATION's Statement about IPR related to draft-ietf-tls-applayerprotoneg-05

From: Stephen Farrell <[email-masked]>
Date: Mon, 12 May 2014 22:27:58 +0100

Hi All,

On 12/05/14 22:07, IETF Secretariat wrote:
> 
> Dear Stephan Friedl, Andrey Popov, Adam Langley, Stephan Emile:
> 
>  An IPR disclosure that pertains to your Internet-Draft entitled "Transport
> Layer Security (TLS) Application Layer Protocol Negotiation Extension" (draft-
> ietf-tls-applayerprotoneg) was submitted to the IETF Secretariat on 2014-05-12
> and has been posted on the "IETF Page of Intellectual Property Rights
> Disclosures" (https://datatracker.ietf.org/ipr/2357/). The title of the IPR
> disclosure is "INEOVATION's Statement about IPR related to draft-ietf-tls-
> applayerprotoneg-05."");

After the draft was placed in the RFC editor's queue we got
a heads-up that this might be coming so I asked the RFC editor
to hold publication for a bit hoping we'd find out more which
we now have.

So if the WG wanted to make some change to the document,
that is still possible. If the WG are happy to go ahead then
I can ask the RFC editor to proceed as normal.

I'll wait for the WG chairs to tell me what action to take.

Regards,
S.

> The IETF Secretariat

---

From: Yoav Nir <[email-masked]>
Date: Tue, 13 May 2014 01:19:15 +0300

> I can ask the RFC editor to proceed as normal.

IANAL, but that patent seems to be about multiplexing multiple applications within a single session, so more like SSL-VPN than just TLS. In fact the patent talks about VPNs in the description part. 

More specifically, all the application negotiation in the patent happens in application data records, not handshake records. So it’s multiplexing at the application layer, vs selection at the handshake. Doesn’t seem to me that it applies. 

But regardless of applicability, the IPR disclosure says this: “Licensing Declaration to be Provided Later.”  How can we make any rational decisions based on that?

Yoav

---

From: Mohamad Badra <[email-masked]>
Date: Tue, 13 May 2014 22:20:53 +0400

On Tue, May 13, 2014 at 2:19 AM, Yoav Nir <[email-masked]> wrote:

> IANAL, but that patent seems to be about multiplexing multiple
> applications within a single session, so more like SSL-VPN than just TLS.
> In fact the patent talks about VPNs in the description part.
>
> More specifically, all the application negotiation in the patent happens
> in application data records, not handshake records. So it's multiplexing at
> the application layer, vs selection at the handshake. Doesn't seem to me
> that it applies.
>
>
The application negotiation is done by using a TLS extension, in which the
client send a list of application names and the server replies with the
selected application (See Fig. 2 in the patent and the description text
[0022]).
Best regards,
Badra

---

From: IETF Secretariat <[email-masked]>
Date: Mon, 12 May 2014 14:07:47 -0700

The IETF Secretariat