Subject: [TLS] New Liaison Statement, "Response to LS on TLS and DTLS terminology [to 3GPPA SA3, IETF WG TLS, 3GPP CT4]"

From: Liaison Statement Management Tool <[email-masked]>
Date: Mon, 02 Feb 2015 10:33:54 -0800

Title: Response to LS on TLS and DTLS terminology [to 3GPPA SA3, IETF WG TLS, 3GPP CT4]
Submission Date: 2015-02-02
URL of the IETF Web page: http://datatracker.ietf.org/liaison/1379/

From: Transport Layer Security (Sean Turner <[email-masked]>)
To: ITU-T Q3/16 (Rosa De Vivero <[email-masked]>)
Cc: Joseph Salowey <[email-masked]>,Stephen Farrell <[email-masked]>,Kathleen Moriarty <[email-masked]>,Transport Layer Security Discussion List <[email-masked]>,Scott mansfield <[email-masked]>
Response Contact: Christian Groves <[email-masked]>
Technical Contact: 
Purpose: In response
Referenced liaison: LS on TLS and DTLS terminology [to 3GPPA SA3, IETF WG TLS, 3GPP CT4] (http://datatracker.ietf.org/liaison/1363/)
Body: Thanks for your questions about (D)TLS.  What follows is a response to your questions; questions proceeded by Q# and answers by A#.  If you have additional question please let us know.

Q1.

[What is] the distinction between (D)TLS session and (D)TLS connection (which implies a definition for each term, beyond the available descriptions / glossary from RFC side)

A1.

A TLS session is shared cryptographic state established by a full TLS handshake between two peers.  The session’s cryptographic state is used to establish the cryptographic key material for a TLS connection.  A TLS connection is a transport relationship established between two peers that contains the cryptographic state to cryptographically protect data sent and received on the connection established through a full or abbreviated (session resumption) TLS handshake.  A TLS session may span one or more TLS connections.  Every TLS connection is associated with one TLS session.  If session resumption (abbreviated handshake) is not used then the TLS session and TLS connection will essentially be the same.  A TLS session is identified by a Session ID in the client and server hellos.  A TLS connection is usually identified by a host addresses and port numbers.

Q2.

The DTLS association concept, e.g., is it equivalent to a DTLS session or DTLS connection or something in addition?

A2.

The DTLS association is the same as a DTLS connection

Q3.

The TLS renegotiation procedure: what is the definition and at which level (TLS session or TLS connection level) does this procedure occur?

Q4.

The TLS resumption procedure: what is the definition and relation to TLS renegotiation?

A3 and A4:

Resumption refers to the use of the state from an existing TLS session to establish a new TLS connection using an abbreviated handshake.  During resumption the cryptographic parameters (algorithms etc.) remain the same.  TLS renegotiation is the process of executing a new TLS handshake to establish new cryptographic parameters for a TLS connection (effectively a new TLS connection using the same host addresses and ports as the previous one). If the handshake is a full handshake then both a new session and a new connection are established and the renegotiated session may have different parameters.

Please note that session resumption and renegotiation are optional features; though TLS 1.2 recommended support for renegotiation; renegotiation was also updated by RFC 5746.  Please note that TLS 1.3 is currently under development and these features are being reviewed.
Attachments:

No document has been attached

---

From: "Angeles-Leon De Vivero, Rosa" <[email-masked]>
Date: Tue, 3 Feb 2015 16:24:06 +0000

Dear Mr Turner,

We wish to acknowledge receipt of your reply LS received for ITU-T Study Group 16. It will be processed shortly and available in our SG16 website.

Many thanks.

Kind regards,

Rosa Angeles-Leon De Vivero
Administrative Assistant for ITU-T Study Group 16, IPTV-GSI, JCA- IPTV & IRG-AVA
International Telecommunication Union
Place des Nations
CH-1211 Geneva , Switzerland
Tel :+41 22 730 5445
Fax :+41 22 730 5853
[email-masked]<mailto:[email-masked]>
[email-masked]<mailto:[email-masked]>
www.itu.int<http://www.itu.int/>

-----Original Message-----
From: Liaison Statement Management Tool [mailto:[email-masked]]
Sent: 02 February 2015 19:34
To: Angeles-Leon De Vivero, Rosa
Cc: Joseph Salowey; Stephen Farrell; Kathleen Moriarty; Transport Layer Security Discussion List; Scott mansfield; Christian Groves
Subject: New Liaison Statement, "Response to LS on TLS and DTLS terminology [to 3GPPA SA3, IETF WG TLS, 3GPP CT4]"

Title: Response to LS on TLS and DTLS terminology [to 3GPPA SA3, IETF WG TLS, 3GPP CT4] Submission Date: 2015-02-02 URL of the IETF Web page: http://datatracker.ietf.org/liaison/1379/

From: Transport Layer Security (Sean Turner <[email-masked]<mailto:[email-masked]>>)

To: ITU-T Q3/16 (Rosa De Vivero <[email-masked]<mailto:[email-masked]>>)

Cc: Joseph Salowey <[email-masked]<mailto:[email-masked]>>,Stephen Farrell <[email-masked]<mailto:[email-masked]>>,Kathleen Moriarty <[email-masked]<mailto:[email-masked]>>,Transport Layer Security Discussion List <[email-masked]<mailto:[email-masked]>>,Scott mansfield <[email-masked]<mailto:[email-masked]>> Response Contact: Christian Groves <[email-masked]<mailto:[email-masked]>> Technical Contact:

Purpose: In response

Q1.

A1.

Q2.

A2.

Q3.

Q4.

A3 and A4:

Attachments: