Subject: [TLS] Adding Curve448-Goldilocks to draft-ietf-tls-curve25519

From: Joseph Salowey <[email-masked]>
Date: Sun, 28 Jun 2015 20:16:45 -0700

Does anyone have an objection to adding Curve448-Goldilocks
to draft-ietf-tls-curve25519?  Please respond by July 5, 2015.

Thanks,

Joe

---

From: Yoav Nir <[email-masked]>
Date: Mon, 29 Jun 2015 13:55:00 +0300

Yes!

CFRG has not chosen a higher-security curve yet, but that one seems to have the most support, and nobody’s claimed that it is problematic in any way (other than “not as many bits as some other curve”). So I think we can move forward with this.

Yoav

> On Jun 29, 2015, at 6:16 AM, Joseph Salowey <[email-masked]> wrote:
> 
> Does anyone have an objection to adding Curve448-Goldilocks to draft-ietf-tls-curve25519?  Please respond by July 5, 2015.  
> 
> Thanks,
> 
> Joe
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Rob Stradling <[email-masked]>
Date: Mon, 29 Jun 2015 12:02:34 +0100

On 29/06/15 11:55, Yoav Nir wrote:
> Yes!
>
> CFRG has not chosen a higher-security curve yet,

Haven't they?

On 25th Feb, Alexey Melnikov (CFRG co-chair) wrote:
"So CFRG prefers curve 448." [1]

[1] http://www.ietf.org/mail-archive/web/cfrg/current/msg06398.html

> but that one seems to
> have the most support, and nobody’s claimed that it is problematic in
> any way (other than “not as many bits as some other curve”). So I think
> we can move forward with this.
>
> Yoav
>
>> On Jun 29, 2015, at 6:16 AM, Joseph Salowey <[email-masked]
>> <mailto:[email-masked]>> wrote:
>>
>> [email-masked] <mailto:[email-masked]>

-- 
Rob Stradling
Senior Research & Development Scientist
COMODO - Creating Trust Online
Office Tel: +44.(0)1274.730505
Office Fax: +44.(0)1274.730909
www.comodo.com

COMODO CA Limited, Registered in England No. 04058690
Registered Office:
   3rd Floor, 26 Office Village, Exchange Quay,
   Trafford Road, Salford, Manchester M5 3EQ

This e-mail and any files transmitted with it are confidential and 
intended solely for the use of the individual or entity to whom they are 
addressed.  If you have received this email in error please notify the 
sender by replying to the e-mail containing this attachment. Replies to 
this email may be monitored by COMODO for operational or business 
reasons. Whilst every endeavour is taken to ensure that e-mails are free 
from viruses, no liability can be accepted and the recipient is 
requested to use their own virus checking software.

---

From: Ilari Liusvaara <[email-masked]>
Date: Mon, 29 Jun 2015 14:10:03 +0300

On Mon, Jun 29, 2015 at 01:55:00PM +0300, Yoav Nir wrote:
> Yes!
> 
> CFRG has not chosen a higher-security curve yet, but that one seems
> to have the most support, and nobody’s claimed that it is problematic
> in any way (other than “not as many bits as some other curve”). So I
> think we can move forward with this.

Huh, I was under impression that they had picked the higher-secrity
curve for Diffie-Hellman months ago (March).

In months since, nothing has come up with that (apart from one KAT
being wrong[1]).

Regarding their progress, they now have CfP on signatures (will
run for ~1 more week). Only 3 proposals in ~1 week, I would have
expected more.

[1] The final DH result for Curve448 test vectors is wrong in
cfrg-curves-02. For the correct one, see:

https://www.ietf.org/mail-archive/web/cfrg/current/msg06770.html

-Ilari

---

From: Yoav Nir <[email-masked]>
Date: Mon, 29 Jun 2015 14:20:42 +0300

> On Jun 29, 2015, at 2:02 PM, Rob Stradling <[email-masked]> wrote:
> 

Thanks. I’ve missed that. And now that I’m checking, it even got into the curves draft. 

So definitely yes.

Yoav