Subject: [TLS] New version of draft-lonc-tls-certieee1609-01.txt

From: Arnaud KAISER <[email-masked]>
Date: Wed, 1 Jul 2015 12:08:22 +0000

Dear members of TLS WG,

A new version (-01) of draft-lonc-tls-certieee1609 has been submitted. The draft can be found here:
https://tools.ietf.org/html/draft-lonc-tls-certieee1609-01

The proposal of this draft is to extend the TLS protocol to support ITS-specific certificates defined by IEEE and ETSI.

Any comments are welcome. Also, if possible, we can do a short presentation of the draft at the 93rd IETF meeting.

Best regards,
Arnaud Kaiser

---
Arnaud Kaiser
Research Engineer
IRT SystemX
8, Avenue de la vauve
91120 Palaiseau, France

---

From: Hubert Kario <[email-masked]>
Date: Thu, 09 Jul 2015 14:31:33 +0200

On Wednesday 01 July 2015 12:08:22 Arnaud KAISER wrote:
> The proposal of this draft is to extend the TLS protocol to support
> ITS-specific certificates defined by IEEE and ETSI.
> 

In section 4 of draft, ec_point_formats also affects use of ECC

-- 
Regards,
Hubert Kario
Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Thu, 09 Jul 2015 15:43:16 +0200

> ITS-specific certificates defined by IEEE and ETSI.

Hi,
 This draft uses the rfc6091 cert_type extension. If that is not
intentional, rfc6091 was made obsolete by rfc7250 which uses the
server_certificate_type and client_certificate_type extensions (even
though the text doesn't mention that).

regards,
Nikos

---

From: Arnaud KAISER <[email-masked]>
Date: Thu, 16 Jul 2015 10:08:22 +0000

Thank you for this information, we'll have a look at that an upgrade the draft accordingly.

Regards,
Arnaud

---
Arnaud Kaiser
Research Engineer
IRT SystemX
8, Avenue de la vauve
91120 Palaiseau, France

-----Message d'origine-----
De : Nikos Mavrogiannopoulos [mailto:[email-masked]] 
Envoyé : jeudi 9 juillet 2015 15:43
À : Arnaud KAISER <[email-masked]>; [email-masked]
Objet : Re: [TLS] New version of draft-lonc-tls-certieee1609-01.txt

> ITS-specific certificates defined by IEEE and ETSI.

Hi,
 This draft uses the rfc6091 cert_type extension. If that is not intentional, rfc6091 was made obsolete by rfc7250 which uses the server_certificate_type and client_certificate_type extensions (even though the text doesn't mention that).

regards,
Nikos

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Tue, 21 Jul 2015 07:41:39 +0200

> though the text doesn't mention that).

There is no explicit "obsoletes:" header in 7250.  Should we post an
erratum to either 7250 or 6091 or both to provide clearer guidance for
future authors?

       --dkg