Subject: Re: [TLS] sect571r1

From: "Blumenthal, Uri - 0553 - MITLL" <[email-masked]>
Date: Wed, 15 Jul 2015 22:18:44 +0000

I like Tony's recommendation - except that I'd rather not ‎lose the 571 curve. But I'm not going to fight the entire WG over this. 

Sent from my BlackBerry 10 smartphone on the Verizon Wireless 4G LTE network.
From: Tony Arcieri
Sent: Wednesday, July 15, 2015 18:07
To: Dave Garrett‎
Cc: <[email-masked]>
Subject: Re: [TLS] sect571r1
‎
On Wed, Jul 15, 2015 at 2:39 PM, Dave Garrett <[email-masked]> wrote:
It's the most used of the rarely used curves.

I think all "rarely used curves" should be removed from TLS. Specifically, I think it would make sense for TLS to adopt a curve portfolio like this:

- CFRG curves (RECOMMENDED): Curve25519, Ed448-Goldilocks
- NIST curves (SUPPORTED): P-256, P-384, P-521

All other curves should be removed, IMO.
‎

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Jul 2015 16:23:53 -0700

On 15 July 2015 at 15:18, Blumenthal, Uri - 0553 - MITLL <[email-masked]>
wrote:

> I'd rather not ‎lose the 571 curve.

I'd like to understand why you think it's worth keeping.