Subject: [TLS] Comments from CELLOS consortium

From: Shin'ichiro Matsuo <[email-masked]>
Date: Tue, 06 Oct 2015 04:54:01 +0900

Dear all,

Members in the CELLOS consortium (https://www.cellos-consortium.org), which is the consortium on security of cryptographic protocols, are studying on the TLS 1.3 protocol. We have several comments and suggestions to make the specification of TLS1.3 better. 

Please find the comments at the following URL.

https://www.cellos-consortium.org/studygroup/tls_1_3-draft_08_issues_rev1.pdf

The comments are on the following matters.

- AEAD
- KDF
- Full Handshake
- Hello Retry Request
- Shared Secret
- Client Authentication
- Cipher Suite
- 0-RTT
- Resumption and PSK

Some of them are already fixed, such as HFDF. However, we left it as a result of our study.

Regards,
Shin’ichiro Matsuo

---

From: Sean Turner <[email-masked]>
Date: Sat, 17 Oct 2015 17:13:13 -0400

Since we’ve been using github as an issue tracker, I’m going to copy these comments there.  I’m going to put “CELLOS” somewhere in the issue so they can be easily found.  Also note that some of these are resolved, similar to others, or over taken by events so I expect some to be closed almost immediately.

spt

On Oct 05, 2015, at 15:54, Shin'ichiro Matsuo <[email-masked]> wrote:

> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls

---

From: Shin'ichiro Matsuo <[email-masked]>
Date: Thu, 22 Oct 2015 11:11:49 +0900

Dear Sean, Eric, Dave, and all,

We appreciate much kind treatment for our comments at GitHub on the following items.

CELLOS: AEAD-1/2
CELLOS: 0-RTT 1/2/3
CELLOS: Resumption & PSK 2
CELLOS: KDF
CELLOS: SharedSecret
CELLOS: ClientAuthentication
CELLOS: HelloRetryRequest

With Best Regards,
Shin’ichiro Matsuo

> On Oct 18, 2015, at 6:13 AM, Sean Turner <[email-masked]> wrote:
>