Subject: [TLS] chacha/poly interop?

From: "Salz, Rich" <[email-masked]>
Date: Thu, 10 Dec 2015 01:02:49 +0000

OpenSSL just landed our chacha/poly implementation into master.  We pass the RFC test vectors, looking for other implementations to test against.  Thanks.

--
Senior Architect, Akamai Technologies
IM: [email-masked] Twitter: RichSalz

---

From: David Benjamin <[email-masked]>
Date: Thu, 10 Dec 2015 01:22:13 +0000

BoringSSL has an implementation of the AEAD itself you could test against.
It's the EVP_AEAD named EVP_aead_chacha20_poly1305_rfc7539 (to be renamed
to EVP_aead_chacha20_poly1305 later).

On Wed, Dec 9, 2015 at 8:02 PM Salz, Rich <[email-masked]> wrote:

> OpenSSL just landed our chacha/poly implementation into master.  We pass
> the RFC test vectors, looking for other implementations to test against.
> Thanks.
>
>
>
> --
>
> _______________________________________________
> TLS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tls
>

---

From: Hubert Kario <[email-masked]>
Date: Thu, 10 Dec 2015 17:02:42 +0100

On Thursday 10 December 2015 01:02:49 Salz, Rich wrote:
> OpenSSL just landed our chacha/poly implementation into master.  We
> pass the RFC test vectors, looking for other implementations to test
> against.  Thanks.

I have implementation in pure Python here:
https://github.com/tomato42/tlslite-ng/blob/master/tlslite/utils/chacha20_poly1305.py

There's also support for the obsolete draft-00 of the TLS ciphersuites.
-- 
Regards,
Hubert Kario
Senior Quality Engineer, QE BaseOS Security team
Web: www.cz.redhat.com
Red Hat Czech s.r.o., Purkyňova 99/71, 612 45, Brno, Czech Republic

---

From: Nikos Mavrogiannopoulos <[email-masked]>
Date: Mon, 14 Dec 2015 13:49:47 +0100

> pass the RFC test vectors, looking for other implementations to test
It seems to interoperate with gnutls' implementation.
regards,
Nikos